Kwikset smartcode deadbolt pairing

I have a Verde 2 which I paired with with a Kwikset Smartcode lock. I then could no longer get it to communicate with the lock so I did a zwave reset on the Verde 2. I am now trying to pair the lock again and I cannot get it to pair. I have a second Kwikset Smartcode lock which I had not previously paired and I was able to pair. I am guessing this may relate to the fact that I did not unpair before I did the zwave reset. Can you tell me how I can now get this lock paired?

Thank you

Try removing batteries, tapping the program button three times to reset the lock, adding the lock with Vera plugged in. Make sure to keep the lock and Vera together until the secure classes are transferred, it takes awhile.

I have tried that about 5 times with no luck


I had the same problem and here’s what worked for me:

First unpair the Kwikset lock. Second reset the Vera. Then pair them again.

I’ve tried everything that people have suggested on the Forum and this is the only thing that worked for me. I had reset the Vera before and unpaired the lock but once I did the unpair BEFORE reseting the Vera, that worked. And I have 2 locks and 2 Veras and it worked on both.

The downside is if you have a lot of other devices, they all disappear and have to be included once more.

I have two Kwikset locks for sometime, and have not had any problems pairing the devices; the process that I’ve been successful with is the following;

  1. locate your Vera unit in close to the switch, this means that you might not be able to use the UI to monitor the various message transactions
  2. I first unpair the device by depressing the z-wave for 5 seconds or when the z-wave light starts to flash rapidly, with the vera close to the switch I depress Kwikset button to unpair the device, patience is a virtue I watch Vera Z-wave to rapidly flash indicating that its communicating with the Lock, then the flash should return to the unpairing rate again in order to unpair another device. At this point I end the unpairing mode by
  3. depress the z-wave the z-wave flash either flashes at a slower rate or it sometimes remains solid.
  4. If the light is flashing at the include slower rate then depress the Kwickset button agian patience is a virtue (30 seconds) the z-wave light will change its rate to a rapid flash rate indicting that its commuicating with the Lock, what for the z-wave light to return to the include rate, at that point depress the z-wave button and the indicator should return to a non flashing rate. If you at step 3 you were left with a sold light, then simply depress the zwave button and release to place Vera in a include mode (slower flash rate).
  5. Leave your vera in close location to the switch 5-10 ft for 20-30 mintues, this should allow Vera to resolve the special association with the lock in question.
  6. The only reason I took a little time describing how to unpair and pair manually is that if your like me my computer is another location that require a wireless and/or wired connection to see what messages that Vera is displaying (not practical in my situation).
  7. Once done I then put my Vera in its original loccation usually not next to the switches how ever I do have them withing 20-30 ft of my locks. The reason is that many devices (e.g battery, Leviton, theromstats ect) can not handle the special association properties, in one of my earlier post it was explained that the GE dimmer/switches are one of the few devices that can propgate the special associations therefore you can move your Vera further away.
  8. I do a system heal
  9. You might get a unable do a speical associate, again patience…I found that the problem usually resolved its self overnight.

I’ve found this method to work consistently for situation, I hope this helps. I agree with Kbolvin, resetting Vera is the pits.



Why do you refer to pressing the programming button three times to reset the lock? I can’t find any information anywhere about resetting the lock (short of possibly pulling the batteries and pressing a button to drain the power.)

The documentation for pairing the Kwikset locks via z wave seems to be very terse- Schlage has them beat hands down there!

I have only found a short instruction sheet on pairing z wave which basically says press button B to pair and/or exclude. (B is the topmost left mini button as far as I can tell). And nowhere does it say to press the big program button for anything other than creating/deleting user lock codes.

Anyone have a link to better documentation? My Kwikset lock with Home Connect didn’t even come with the information on how to pair it with a z wave controller. Had to scrounge around online for the pathetic scrap of information that I finally found.

Not sure if I’m actually resetting the lock, and definitely having trouble pairing the darn thing!


anyone want to buy my bronze kwikset deadbolt? i didn’t get it to pair and i’ve lost interest in trying to figure it out. this site needs a classifieds section. throw me some offers if interested i guess

There should be some way to join these two Kwikset pairing threads:

Nobody seems to know where the mention about pressing the program button multiple times to clear the lock comes from, but its mentioned in the above thread again. I’ll try this tonight and see if it helps- otherwise I’m waiting for the next firmware release!

Or maybe since there is so much discussion about mashing programming buttons to help the Kwikset pair with Vera, I should just go caveman and get out the darn hammer!

It really shouldn’t be this squirrely.

kdiggz, don’t give up. Give MCV tech support a call asap. I was having problems pairing the locks with my Vera 1 until I called support. I got Ovidiu on the phone and he helped me right to the the point where I finally did pair the locks and they work great. I can’t believe all the time, patience and dedication Ovidiu gave in finding a solution.
MCV tech support is A1+.

question for mike blackwell. when you say you depress the kwikset button, which button is that on the kwikset lock. i did the remove battery, hit the program button 3 times on teh kwikset and then it found the lock and i went thru the setup process on the dashboard. only other problem is when i try to unlock or lock i get a “server busy” so it fails.
so two questions - what is the kwikset button and any ideas on the server busy - i have the vera hooked up to my network with an ethernet cable.

@jwthompson the Kwikset button is the one that is accessible after you remove the cover located the button upper left side if I recall. For Z-Wave devices you use the button to include and exclude the lock device. The other button upper right is for Zigbee devices.

It sounds like you’ve at least was able to pair VERA with the Lock. Did you leave your Vera next to lock so that special association are created? if not do so I usually leave it for a few hours or overnight, once it’s established your in like flint. As to Server busy, not sure why other than try it first with Vera close to the lock to verify that it’s not a distance or communication issue. You should be able to lock/unlock via Vera UI, if not I suggest excluding and including the lock again just to verify that your Pairing worked, Mike

I paired my lock by doing basically as described above…
However, I took the lock to Vera, and used an iPhone to interface with Vera.
I did a low power include, removed the batteries from the lock, pressed Program 3 times, waited 5 seconds, inserted the batteries, waited until the Red light extuingished. Then pressed Program button. Vera Detected the lock, and I waited for about 3 or so minutes, and Vera asked me to assign it a location, I left it alone for 5-10 minutes and returned. It was had a RED cog, but the lock/unlock via Vera worked…
So, I installed it in the door, on other side of house, and Repair’ed my network. (I have a Vera 1, BTW).
After repair, it still had a RED cog…
So, I am performing another repair as we speak, and will leave it over night… Will report findings tomorrow…

If someone else has ideas, I will be glad to learn them…

PS. I am leary to switch to Vera 2, latest firmware, as my Vera 1 works well. My Vera 2 is still nice and cozy in the box…
Anyone have any thoughts on switching or staying?


And after several days, I noticed it was “Green” coged and showed all 3 of the codes I manually entered, although I thought I entered them as 1,2, & 3, it shoued 1, 3, 5.

So, given enough time, it seemed to come up and work fine…

I have Vera 2 running on latest firmware. I paired Kwikset smartcode deadbolt with vera 2 without any problem.
First I installed the lock as per instruction given in the installation manual supplied with the lock. Then I programmed smartcode for first user . Lock works with smartcode .

For pairing with Vera 2, I put vera 2 in include mode with battery pack supplied with vera 2 and bring close to Kwikset deabolt within 2 feet range.
Please note that Z wave button for Kwikset deadbolt is small button located on top most left corner under the cover . Don’t use program button for pairing purpose. After pressing z wave button on deadbolt wait for 30 sec. Vera 2 z wave led will flash fast indicating that deadbolt is paired with vera 2 .
Then press z wave button on vera 2 to return back to normal mode .
Immediately I shifted vera 2 to its original location and connected to internet. Then I open mios portal dashboard to confirm Kwickset deadbolt is included. I operated deadbolt from mios dashbord and can able to open and close deadbolt without any problem.
I have ipad 2 with SQ Remote HD app installed. I assign one button in SQ remote to Kwikset deadbolt,
now I can open and close door from my ipad without any problem.
I think most of guys are facing problem due to using program button for pairing.

When you’re referring to “Kwikset smartcode deadbolt” could you please share what model Kwikset lock this is? Thanks.

I installed Kwikset 99100-004 Motorized Deadbolt .


Thanks for the info - So I ordered 99100-011 - Hopefully I’m able to get it paired reading all your comments here.

I think smartcode programming on Kwikset Deadbold is must before pairing with Vera 2.
Vera 2 will access this code for opening of the Deadbolt ::slight_smile:

@cbdeshmukh - thanks for the info. I’ll program smartcode first prior to pairing with Vera :slight_smile:

Goodness!!! I ordered 5 Kwiset’s 99100-011 - With little pain got 4 working. This one lock just don’t want to pair with Vera. I actually don’t think it has anything to do with Vera…Perhaps the lock itself (4 out of 5 works but why not one?)

  1. I put Vera in include mode just like usual
  2. I press the button on the lock
  3. Vera still blinks indicating its waiting to include a device and never goes off.

So I’m convinced that the problem is with the lock not transmitting when I press the include button…

Any thoughts…thx for your help.