iTach Flex Startup Lua Failed

I got the ITach Flex Wifi from Global Cache.

I installed the GC100 App but when I put the IP of the unit is get:
GC100[38] : Startup Lua Failed

At one point I was get GC100 IO error.

Any help will be appropriated .

Thank you.

Did you set the IP Address ?


Are you sure that’s the right IP address for your iTach ?

I’ve just got an answer from one of my colleagues from the development team and it seems that the reason why you’re encountering this issue is because the GC100 plugin was made to be used with the GC100 and iTach devices.

The iTach Flex requires additional changes to the plugin to be done as it uses a different api than the rest.

These changes should be implemented into the future versions of the plugin, but I cannot give you an exact date as to when that will happen.

I’m sorry for the inconvenience.

Best Regards.

Did not know they had a new API.

hello :slight_smile:

any update on the FLEX plugin?


I got exactly same error trying to connect WF2CC iTach device to VERA LITE (was planning to use it for garage door opener) :frowning:

There has not been an update for the iTach FLEX yet that I know of.
It probably would not be difficult to fix … I believe the new API is documented.

Would you recommend some other device to get for garage opener instead of waiting for API fix?
Thank you very much for your advice in advance! :slight_smile:

I use the Older iTach devices.
I might be able to do help you remotely If you know enough how to setup an SSH tunnel to your vera … and you are willing to allow me to access your Vera remotely.

This is a trust issue … and I understand not allowing this …
Or if you want to mail your iTach to me … I can work on it and send it back when I get the driver updated.

I also brought the flex but had a lot of problems with it, the first flex had problem with the firmware and they told me to send it back, then the second flex just die after one month, so I ask them to send me the old itach instead of new flex, really happy with it, and working great with the vera, don’t think the flex ready for prime time

Sent from my HTC One X using Tapatalk 2

What driver are you using for the iTach FLEX ? Can you send the details from the Advanced Tab.

Did MCV provide you a driver directly ?

Here is the link the API.

[quote=“RichardTSchaefer, post:13, topic:175667”]@ntk
What driver are you using for the iTach FLEX ? Can you send the details from the Advanced Tab.

Did MCV provide you a driver directly ?[/quote]
no, i ask global cache to send me the old itach and not the new flex, i have this itach now

and i’m using the cg100 plugin

Once again … I do not mind to update the GC100 driver … if someone will send me an iTach FLEX to play with for a few days.


Please PM me shipping address. Thank you very much for the offer!

Hi all,

After the sudden death of my old IR Blaster (Redeye unit) I have recently bought an iTach Flex with a Tri Port IR Cable and I modified the GC-100 plugin to get it working.
I also add a second function to send iTach Code instead of Pronto Code.

The iTach code must be splitted to keep only the IR part
ex :
Full iTach code :

iTach code to be used in the plugin :

All seem to be working well so I share with you the files I changed but maybe the creator of the plugin can check it out…

PS : Only tested with Tri Port Cable

Enjoy !

Thanks very much Macfly. It worked great. I really appreciate it.

Does anyone know where the remote codes for this plugin come from? I can’t find one for my Sony AV Receiver.

Thanks guys , i’ve added 2 devices , TV and AVR . having a problem with adding the dreambox have no idea why .

anyway , My denon AVR is working fine for basic commands , ON - OFF AND MUTE , but it has a lot of more options that are not working , see attached .

Is there anyway i can test the commands manually using luup instead of everytime i have to create a scene and add an action , test if it’s working then i discover it’s not , i edit the scene and try again , it’ll take forever .