Imperihome talks

For me it is very important that you can add more controllers to the app. Currently I work with three Vera controllers and a Fibaro Home Center 2. They communicate with each other AND in Imperihome I have them all 4 in 1 app.
With current Vera app you can only add 1 Vera controller and functionality is very very limited compared to Imperihome


Has anyone managed to get Imperihome and their configuration backup file working on a brand new Android device?

I just bought a budget Lenovo Tab E7 tablet to replace one of my old Amazon Fire 7 gen 5 tablets.

During the initial Android startup wizard on the new device, I selected to restore both the Imperihome Pro app and the Imperihome app.

Once in to Android I then restored my Imperihome configuration file and it restored all my dashboards OK and everything was looking good.

The Imperihome app said it was logged in as there was a log out option on the menu.

However to my horror after closing down the Imperihome app and reopening it again I was faced with the Imperihome login screen which obviously no longer works.

I then tried restoring my configuration file again and the same thing my dashboards all came back OK, but when closing the app and reopening, same thing again it was at the login screen.

I couldn’t find a solution.

In the end I had in remove those current versions of the Imperihome app and install the old Imperihome Lite and Imperihome Pro apk files from way back, version 3.0.11

This is the last version of Imperihome before they introduced the account login system, so its not there basically.

I restored my configuration file again and my dashboards are back and I can close and reopen the app OK no issues.

At a glance all my Vera devices are present and the few I have tried seem to be working and controlling stuff.

Only slight problem is this very old version of Imperihome does not have the Philips Hue 2 object so I lost that, not a big issue I can still access and control my Philips Hue lights via the Vera object.

And the Weather object is not there in the older version so I lost that object also. Both I can live without.

I have a similar issue in my setup also. If I close the app and restart it it will ask for login, witch is not possible.
The workaround I have for this is to restart the device, when the device starts it will also automatically start Imperihome and I will be again logged in without entering any credentials.
I don’t remember if this automatic start of ImperiHome is something I have configured.

There is a setting in Imperihome to have it launch at device startup.

1 Like

Then that is probably what I have done, luckily it starts without asking for the credentials so every time I get kicked out for some reason I just restart my device.

I forgot to turn off in the Google Play store automatic updates for Imperihome. It’s updated to version 4.3.17
2019-01-14 .

And I am stuck at the login prompt again.

Will have to uninstall, install old APKs restore backup and then turn off automatic app updates for Imperihome.

EDIT Seems you can turn off auto updates for just one particular app?

I’ve had to turn off the setting for all apps so they don’t auto update.

EDIT2 Looks like you can turn it off per app


1 Like


What has happened to Imperihome is sad.


Does anyone knows a replacement?

Can anybody tell me the latest version of Imperihome that does not need to login?

Imperihome Lite and Imperihome Pro apk files from way back, version 3.0.11

1 Like

I could not find a way to disable auto update except disabling auto-update for all Apps.

Is there any way to prevent just Imperihome from Updating?

Yes you just need to read further up this thread.

On Android go to the Imperihome app in the Play Store click the 3 dots in the top right hand corner and uncheck Enable Auto Update.

I don’t use Apple iOS devices so you’ll have to figure that out yourself.

Did you find version 3.0.11 apks online somewhere ?

I saved them ages ago just before they introduced the account login feature.

Any chance you are willing to share

Message me

I was bored just installed Imperihome on to a Amazon FireTV stick. It works but is a bit clunky as it needs touch screen inputs, but kinda works with the mouse toggle mouse cursor app installed also.

1 Like

I love the Imperihome :slight_smile: is great special with plugin. Good job @Cw-kid

Does anyone know where I can download an older iOS version of Imperihome ?

Versions 3.0.3 / 3.0.4 / 3.0.8 appear to be the version numbers before they added the login account system.

We have one iPad device in the house that is my daughters and would like Imperihome on there.

I never use iOS so don’t know much about it or their apps structure or how to side load them.


Pulling my hair out trying to install a new installation of Imperihome on to an iPad.

After a lot of messing around I manged to download an older version of Imperihome from the Apple App Store following this guide here. I now have version 3.0.8 .IPA file which is the last version before Account Login was introduced.

I managed to get the app installed on to the iPad and it is indeed the old version 3.0.8.

However I need to do the in app purchase to purchase the app as I only previously paid for the Android version.

When I select the option in the Imperihome app to Buy Premium it comes up with an error and says something like it cannot find products.

I cannot import my exported json file from my Android tablet either on to the iPad app as it says that is a premium feature.

I cannot load the very latest version of the Imperihome app on to the iPad and try the in app purchase as the first thing you have to do when launching the app is login to the Imperihome account which obviously is not working.

So I don’t think it is possible to do a brand new installation of Imperihome on to an iOS device :cry:

So, I have a partial working solution for Imperihome on a new Android device with some major caveats.

  • I installed ImepriHome Lite 3.0.11
  • I then installed ImperiHome Pro (unlocker) 2.0.1
  • I restored my configuration, and it works!

Here are the caveats:

  • After some time, the tool reverts back to “lite” mode. Sometimes, I can just reinstall the unlocker to get it going again, other times, I have to clear the storage for ImperiHome and start fresh
  • The old versions of ImperiHome cannot get access to your WiFi AP because location permissions are needed, and apparently the tool does not ask for them. The implication is that it cannot easily determine if you are local or remote.

One thing I will say, is that the pre-login version of ImperiHome seems to do everything that the login version does, and it appears to have snappier response

I only have the old version of Imperihome installed on a new Lenovo E7 tablet. I have not had it revert back to only Lite mode.

As its a tablet I don’t take it out of the house so cannot comment on if it would switch between local and remote.

However I have just seen something strange. I went into the Android settings and looked at the Imperihome apps permissions. I could see location listed and turned on in the permissions list.

However when I went out of the settings and back in again to look at the apps permissions again, the location permission had vanished from the list and now cannot be seen.

In the actual Imperihome app Settings - General Preferences under the Configuration section “Local WiFi Network” it does detect my AP when I press the “Get Current Network” button.

@cw-kid: Are you saying you got the old Imperihome working without the unlocker? (v3.0.11) If so, how’d you do that?

As for the WiFi stuff, what version of Android are you using? I’m using Android 10, and I know they changed the way WiFi is accessed.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules