How to work with virtual devices in Ezlo Plus and Ezlo Secure

You need to use the Online API Tool.

https://apitool.ezlo.com/dashboard

However there was a problem where new users could not register to use it, please try and let me know if it works?

Also see my guide linked above in this thread, for how to create virtual devices on Ezlo hubs.

I am also having difficulty registering

OK I will tell the Devs again.

Thanks

I couldn’t login, so I tried creating an account. Same error…

Hello @wbhood,
We are checking this issue now.

1 Like

What happens if you don’t attempt to register for a new account in the Online Api Tool website and instead just try to login with your existing Vera user account username and password?

I just created a brand new Vera user account for something to add a new controller and I was able to just login to the Online Api Tool Web page with those new login details.

Thanks for posting this cw-kid. I wasn’t able to create a new account, but I was able to login using my ezlogic.mios.com username and password.

Hi, trying to uploading node_test_plugin and an error occur while update plugin.

At the moment I installed virtual devices with apiTool on ezloPlus and I can’t controll them with Alexa. (no level 0 and no other level)

Is there an official way to create virtual devices that can be controlled by Alexa?
and about VOI, any news?

Hello,

We are working to resolve the issues with eZLO VOI and therefore the possibility to add Virtual devices.

For now, we strongly recommend following the guide shared by CW-KID

Please keep in mind that you will need to create virtual devices that can be controlled through Alexa like Smart Switches and Light Bulbs.

I will also create a support ticket so we can have access to your unit and test with your controller, that way we could replicate it, as it doesn’t on our side.

I was able to replicate the issue and reported it to the appropriate team to take a look at and fix it as soon as possible (EPPT-4910).

@Leonardo and @Leandro thanks
all my test bulb_dimmer no works with alexa command.

in Dashboard happens this

all dimmers switching to any level return like to a default level.

I have an Ezlo Secure and I am unable to delete Google from my devices. I have already unlinked my hub from Google Home. When I hit delete and remove without unlinking nothing happens. It just stays in the devices. I have tried doing a factory reset with a paperclip and it still is there. I have several WiFi bulbs setup in Google and it used to work fine using a Zwave remote Switch to turn the lights off and on through the Ezlo Voi. It just stopped working one day and now I can’t do anything with the Voi.

1 Like

I am unable to create a login for the api tool also. Getting the same http failure response error. Is there a work around for this?

Hello @homeuser,

Could you please try with the same credentials you use to access your controller through the app o Ezlogic and let us know?

Regards.

I tried that too but it says You have entered an invalid username or password.

Thanks

Hi @homeuser,

I sent you a PM.

Best.

I found this procedure was easier to create a virtual switch.

Using the MiOS API Tool page at Ezlo API Tool to me is easier than SSH into Ezlo. I believe its doing the same thing but just a less techie interface.

1 Like

Where should I write this code?
Thanks!

you need to login to the api site. https://apitool.ezlo.com/auth/login

You are supposed to be able to login with the same credentials you use to access your controller through the app on Ezlogic. If that doesn’t work for you someone from tech support can help you with the login.

Then follow this guide: Create Virtual Devices in EZLogic - help.mios.com

Once I was able to login to the api site, it worked for me. The best part is you can create multiple virtual devices at once. I needed 14 virtual switches so I changed the code

 "devices_count": 1

to

 "devices_count": 14

When I opened the device list on the ezlogic.mios.com site there were 14 vitrual switches waiting for me.

2 Likes