Fibaro FGD-212 scene control function not visible in Meshbot

I’ve got a FGD-212 dimmer paired to my Ezlo Hub, and configured the dimmer to act as a scene controller (by setting parameter 28 to ‘1’). Examining the ha-zwaved.log file I can see the dimmer is correctly sending scene commands to the Ezlo hub:

2023-03-26 14:20:54.245088 INFO : znetSceneActivationSetResult (node id: 44, scene number: 26)
2023-03-26 14:20:54.245453 INFO : onSceneActivated: onSceneActivated, nodeId: 44, command: 43, channelId: 0, sceneNumber: 26

However, even though I rediscovered the device and rebooted my hub, this scene control functionality does not show up in meshbots as a trigger.

Is there a specific method to make sure the meshbots act accordingly, or do I need to edit the zwave device_setting.json file on the hub to expose this functionality?

Please advice…

It probably hasn’t been implemented into Meshbots.

They likely need to add triggers that support being able to select / monitor “scene number” and allow you to specify what scene number you are expecting and for the rule to then trigger and run its actions based on that.

This is a pretty important feature, as I also have Fibaro dimmers and use double and triple clicks on the wall switches to run various different rules.

I am currently using Multi System Reactor rules to do this however as Pattick added support for it after I asked him.

Oh, another thing I noticed: The dimmer has 2 inputs and 2 outputs. Controlling the first input shows the expected response on the dashboard, either turning on/off or dimming up or down.

However, controlling the second input gives identical results in the dashboard, it responses as if the first input was controlled. Even though nothing changes with the physical lights, so the dimmer is controlling the right output.

Looks like they haven’t fully integrated or tested this Fibaro device then.

For reference here was the thread on the MSR forum where we talked through and Patrick added the required support for it to work.

Might be some useful information on there for the Ezlo devs?

And this is the related bit from the Fibaro user manual.

Reading bits of that MSR thread again looks like we are using lastsceneID numbers instead of sl_sceneactivated.

I am using MSR with my Vera Plus however which is where my Fibaro modules are still paired.

I dont have any Fibaro modules paired to my Ezlo Plus currently. And looks like I wouldn’t want to pair them to the Ezlo hub after reading this thread.

The device seems integrated on the previous reports. I will have it re-checked. @jouked
I created a ticket onbehalf of you. You can track progress from there. Log in - MiOS

1 Like

Thanks for that! It’s integrated, as in the inclusion steps are nicely documented in the App etc. Not all features work though as indicated above.

@cw-kid: basic scene control is supported by meshbots already. My Aeotec Wallmote quad devices work fine, however they send a slightly different zwave scene command: znetCentralSceneNotification instead of znetSceneActivationSetResult used by Fibaro. The basics are in there it seems.

I know, I was able to setup a Remotec Scene Master ZRC-90 Scene Controller with my Ezlo Plus and Meshbot Scenes OK and that works as you say. I had to edit each desired scene individually however and add a trigger for a button press of the Scene Controller device.

However its still not as good as an old Vera hub as they was no central area in the web GUI to see what buttons were mapped to which scenes.

You have to remember what scenes you had assigned and then manually edit each of those scenes and their triggers.

Which isn’t great if you programmed your scene controller months ago and then later want to make some changes or see what buttons you previously assigned etc as there is no page to see and view all button assignments.

Unless they have recently added that? Which I dont think so.

Osman this was a feature request quite some time ago on my list. So you can do double and triple clicks on the wall switch connected to a Fibaro mobile, to then run scenes / meshbots etc.

Note - This is regarding regular Scene Controllers not about the original question regarding Fibaro “Scene Activation”.

Looking in the Vera mobile app on my Remotec Scene Master device paired to the Ezlo Plus hub.

You can actually see that it lists the scenes that are being used as triggers. It doesnt say which buttons are mapped to which scenes however.
You would have to edit each scene and look at their triggers to work out which buttons / button presses were for which scene.

If you then switch the Vera mobile app to connect to a Vera Plus hub instead and go into a Scene Controller device, in this case an Aeotec Minimote, there is then an extra option called “Set Button Actions” if you click that I then just see this page which doesnt do anything. So that is broken. On the Android app at least. I didn’t try the iOS app.

However if you use the old UI7 web GUI and go into your Scene Controllers devices setttings you can get to a “central area” / page that lists which buttons are assigned to which scenes. And from this central location you can easily assign the buttons to scenes.

  • This is missing from the Ezlogic web GUI for scene controller devices and ideally needs to be added in to the devices settings area as it is on the old Vera UI7 web GUI.

As you can see in the below screenshot for an Aeotec Minimote it even lists the different types of button press. E.g. Tap or long Hold for each button. Meaning one button can run two different scenes.

I mentioned some of this before on an old thread here.

Diving a bit into this, it’s intriguing to see the devices.json file in the zwave plugin directory on the hub. For some devices (e.g. FGS-213), it automatically seems to configure the switch to enable scene control for all modes (271 is fibaro, 1027_4096 is a FGS-213):

        "271_1027_4096": {
                "configurations": [{
                        "channel_id": 0,
                        "description": "Enable scene controller functionality for first switch",
                        "name": "S1 Switch - scenes sent",
                        "number": 28,
                        "size": 1,
                        "value": 15
                }, {    
                        "channel_id": 0,
                        "description": "Enable scene controller functionality for second switch",
                        "name": "S1 Switch - scenes sent",
                        "number": 29,
                        "size": 1,
                        "value": 15

Which switches are you using? I can check if the config is in there for that specific switch.

This is off your Ezlo hub right?

Not a Vera hub.

I am using Fibaro Dimmer 2, Fibaro Roller Shutter 2, and some Fibaro Relays forget which ones. But as I said they are all still currently paired to my Vera Plus hub.

So that is missing for a Dimmer 2 if you look at its devices.json file ?

I have got a spare 3kw Fibaro relay switch module. I could maybe pair that to my Ezlo plus.

Yeah, it’s from the ezlo hub, you can find it in /opt/firmware/plugins/zwave/configs/

The list seems to configure certain parameters on the devices matching the device id. I’m assuming that if a device is not in there, it’s not ‘fully’ supported.

1 Like

The FGS-212 is not in there, some others are. So it could be that if you have the exact type in there, you might run lucky in scene support in a meshbot.

1 Like

Yeah that would make sense.

I dont have any of the newer Fibaro “Switches” to try just the original older Relay modules.