feedback request: 1.0.843 Luup beta for the general public

This release has past our complete test sequence, and can read and convert the pre-Luup configuration files. So we will be releasing this as a beta version for the general public, and start moving our customers over to it. If you have any Luup plugins you’d like included in the gallery for this release, email aaron [at] micasaverde dotcom and I’ll get them included over the weekend. Also, if you’re aware of any bugs or glitches, particularly in the non-Luup stuff that will effect the general users, like scenes, timers, etc., please post to this thread and I’ll try to reproduce and fix them this weekend.

  1. Rendition off for TemperatureSensor based components
    All render with the word “OFF” on the end of the temp, as in the following from my HSM100:


This is also true for other Devices that also implement the interface:

  1. Light Sensor component of HSM100 renders as “OFF” instead of Level

  2. Battery (?) Component of HSM100 renders as “OFF” instead of Battery Level, and displays as “Generic IO”

(update: picture attached to make it clearer)

Ok, I must be completely blind, where do we find this or any other version of the firmware?

Hey Boyo,
MCV lists all formal Alpha/Beta releases using the link:

Just got this in the logs, which looks a little odd, since some of the [SQL implementation] internals of are being exposed:

[tt]01 08/09/09 21:48:11.210 RAServerSync::SyncDevice 127 got Database request failed:

  • Error no: 1054
  • Error: Unknown column ‘Type’ in ‘field list’
  • SQL query: REPLACE INTO Device (PK_Device,Description,FK_Room,Type,Category) VALUES(‘127’,‘Area Breach Area 4’,‘4’,‘urn:schemas-micasaverde-com:device:MotionSensor:1’,‘4’)

for,2,3,4,5,6,8,9,10,23,24,25,26,27,28,29, 30,31,32,33,34,35,36,37,38,39,40,41,42,43,44,45,46,47,48,49,50, 51,52,53,54,55,56,57,58,59,60,61,62,63,64,65,66,67, 68,69,70,71,72,73,74,75,76,77,78,79,80,81,82,83,84,85,86,87,88,89,90, 91,92,93,94,95,96,97,98,99,100,104,105,106,107,108,109,110, 111,112,113,114,116,117,118,119,120,121,122,123,124,125,126,127&DeviceID=127&DeviceDesc=Area%20Breach%20Area%204&DeviceType=urn:schemas-micasaverde-com:device:MotionSensor:1&DeviceCategory=4&FK_Room=4 <0x402>

Because the top post in this thread said this release could read and convert pre-LUUP config files, I went ahead and upgraded without resetting to factory defaults.

When the update was done, I got the “cannot retrieve user data” error. I was updating from 602.

I ended up reloading 602 using the URL: [vera_ip]\cgi-bin/cmh/


Ok, decided to go to 616 first, then 843. This time it worked.


So 616 to 843 works now without having to reset settings? That was the only reason I hadn’t done it yet.

I tried upgrading 616 buti did not use the load from url mechanism in findvera because i could not get it to work. I did not restore to factory setting due to the first post here which led me to belive it was not nessesary. I instead used the flash firmware utility program. The upgrade and loading and booting of Vera went ok. But when hooking up with findvera i got the “cannot retrieve user data”. I have tried to downgrade again but can not get out of this problem. Please advice???

David mentioned that he “I ended up reloading 602 using the URL: [vera_ip]\cgi-bin/cmh/” which I do not understand how is done.


Well, in my case, I still have problems. I cannot look at jobs, I cannot log in via SSH, and scheduled scenes do not trigger. The Dashboard works fine. I have two support tickets open with MCV to see if they can resolve it. I figured I could revert again, but the community at large might benefit if I let MCV take a look and figure out what is happening. (I’m nice that way!)


DrZeller - regarding the scenes triggering, I have seen the same thing. Each time it happened to me I actually found the dongle locked up.

I managed to do the upgrade. I am posting the methode for general interest:

  1. Did a restore of factory settings by using the button on the back of Vera
  2. Did a firmware flash by the rescue.exe program with following boot ( automatic but it takes a little time)
  3. Tried to connect to findvera and got message that i needed to activate it
  4. Removed network connection (cable) and attached localy ( this does not work if the network connection is present???)
  5. Had to tune the network setup to fit my setup (configure without firewall and bridged, this was automativ when i first started up with 616)
  6. Activated findvera and it seemed i was in business

But not so… I performed reset on all zwave devices and included them in the normal fashion. Was not able to comunicate with any of them (Merten light dimmer, Merten radio button, Duewi motor controller to controll my projector lift etc etc.).

Given Davids post I think I will revert to 616 and wait until the firmware is debuged further. I will give it a try for some time first in order to aid the debuging.


I wanted to “play” with the LUUP a little so I decided to update to this newest version. I followed what I have understood is the update procedure and got 843 installed. A lot of messages came up just after the restarting which seemed to indicate that I was still running 616! It said something like: the database was empty and that it could not find any user data etc - which I presume is normal (I selected factory reset setting before upgrading).

Then I removed the power because the unit appeared hanging and when I reconnected it came back stating that I now was running version 843.

Then it found all my Z devices (which I presume was still stored in the stick?) but with no assignments so I decided to create new rooms (with different names from the ones I used before) and assigning them with the devices.

Then I created the same users as I had in my old setup and when saving the newly created data - my old assignments from 616 reappeared for a while (two minutes or so) after which it displayed my new assignments again?!

Well the main problem now is that my scenes no longer work! Each individual Z device can switch ON and OFF alright but when using scenes only some lights get switched. This is quite a basic functionality (I would have thought?) so I am a little surprised that it does not work! At least it does not work for me.

So my question is: when will 834 (or 1000 as it perhaps should be called when all bugs are removed) be released as a stable version? If we are talking weeks or even months then I will revert to 616 so that I can use basic scenes to control my house.


[quote=“guessed, post:2, topic:164680”]1. Rendition off for TemperatureSensor based components
All render with the word “OFF” on the end of the temp, as in the following from my HSM100:


This is also true for other Devices that also implement the interface:

  1. Light Sensor component of HSM100 renders as “OFF” instead of Level

  2. Battery (?) Component of HSM100 renders as “OFF” instead of Battery Level, and displays as “Generic IO”

(update: picture attached to make it clearer)[/quote]

I’ve got the same problem like you … :-[

Just a question, how do you add Yahoo Weather ?

I wrote a driver for the Yahoo! Weather component, including the usual suspects ([D|I}_YahooWeather.xml). It’s not finished just yet, as I still have to work out how to parameterize the “Yahoo LocationID” that I need to drive it.

For now, it “hardcodes” a Yahoo LocationID that maps to Reno.

Unfortunately there doesn’t appear to be a way to go from the luup.location information (lat/long, city/state/country) information that Vera can give me, and the LocationID that Yahoo requires for their Weather interface, so I’m going to have people type it in. The Weather interfaces don’t let me do that, so I can’t make it automatic.

When I get some time to work that out, it’ll be published. MCV already has a copy for review (along with my Alarm Panel interface).

I’m happy to have this discussion but we need a new, separate thread to contain it. I don’t want to detract further from the main discussion on stabilization of the 843 Beta, since that’s important to every one of us.

I used several hours yesterday to get the 843 to work. In my view its far from a state where it can be released to the public. I tried to integrate and control the following devices:

Merten Light dimmer Works Ok
Merten Radio pusch button to act as a secondary control of the light dimmer… NOT able to integrate
Duewi motor control to control the projector lift… Integrates ok but did not accept control comunication
3in1 sensor integrates ok but behaves erratic and I am not able to use it to trigger scenes
Merten Switch Works OK

And I can not find the support for the USBUIRT that was the reason I wanted to switch so that I can use a IR remote to trigger scenes in Vera???

From a system points of view… i.e. to control scenes I have big problems to get everything that worked ok in 616 to work at all. In fact some scenes does not trigger at all

I have reinstaled the 616 as I can not get my Media Rom to work with the nes firmware. Please let me know if I can be of assitance


Yep. Looks like it locks up regularly now. I used to have it happen every couple of days, not it is every 2nd or 3rd command. The GUI will not reset it. It gives one of several different errors if I try.

I still haven’t heard a thing from support, so I am reverting… again.


I had a lot of problems with the downgrade. I ended up having to use the rescue utility to get going again.

I updated the thread about a bricked Vera with my experience. In it, someone had had problems with using Win7. So did I. I finally tried running rescue.exe in WinXP compatibility mode, and it worked.

As an aside, do not forget to revert your network setting on your PC after the process - which instructs you to set your IP to

UPDATE: Restoring my old 602 backup did not work. It couldn’t load the data for some reason. This back up was the last one I did before the upgrades this week. I ended up doing two (yep) restore with defaults and then an old backup from June.

This process has to get a LOT better for general consumption!


So we are stuck with a very buggy 843 and can not easily revert! What is the proposition of vera on this??