Ezlo Softhub with CCTV and AI capabilities Downloadable for FREE

You can now download our softhub with CCTV and AI capabilities to run on both Linux and Windows.

With these amazing capabilities for FREE:

  • Support for any IP camera /ONVIF devices
  • NO Limit on number of devices
  • 24/7 recording with unlimited on storage (depends on HW)
  • Mobile access
  • Facial recognition
  • Object Detection (Person, Vehicle, Pet … more coming soon)
  • Audio Detection
  • QR Code detection
  • Hot Zones for detection
  • All Mios Platform Automation capabilities natively integrated
  • All Mios Platform Integration capabilities natively integrated
  • … more coming soon

Please check it out and share your experiences with us !

5 Likes

So…
On Windows 10 I ran that powerscript command like five times and each time something different happend. Now it ends with : serial 10000xx01 is running. In Docker it shows two containers running, with a total of 8 images.
The vhub is showing in my list of controllers on home.getvera.com. I have no zwave or zigbee stick, so did a skip on both.

If I browse to localhost:80 I get a sort of home page where only the Signin link does anything. If I use my normal credentials it just keeps spinning, when I try to register it just keeps spinning.

Can you give some instructions how this is suppose to work post install? Should it work with my normal Vera account, do I need to register a new one? Etc…

I have this SoftHub plus Vidoo CCTV up and running on a Linux Debian box.

Initally I also was unable to login to the Vidoo web UI on port 80, also got a spinning wheel and then just got kicked back to the login page again.

I reported this to the devs and it was fixed, for me at least and yes I am just using my regular Vera account username and password.

The windows image seems to have the same problem, but did not get fixed it seems.

1 Like

Maybe I never tried the Windows one. @adamjacobmuller will know.

When you do get logged in to the local web UI on port 80, you will see the regular Vidoo CCTV NVR user interface, if you used that before.

The SoftHub part of it, just acts like any other Ezlo hub in the Vera mobile app for example and in the Ezlogic web UI.

You may need to add the SoftHub to your Ezlo Main controller group in the Ezlogic web UI under the “Controllers” menu item.

hi @reneboer,

Set-ExecutionPolicy -ExecutionPolicy RemoteSigned -Scope CurrentUser; powershell Invoke-WebRequest -uri https://www.ezvidoo.com/install/start.ps1 -outfile start.ps1; .\start.ps1 -vidoo

Can you please try with this version, it should work correctly for you.

If it does not, can you please show me the output of:
docker ps --all

Thank you!

-Adam

1 Like

Hi @adamjacobmuller

Thsi ends with this :

and:
C:\Users\Rene>docker ps -all
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
0b0d7e6c773e us-east4-docker.pkg.dev/softhub-354014/softhub/orchestrator-vhubzz:latest “/root/orchestrator …” 3 minutes ago Up 3 minutes orchestrator-vhubzz

Hi Rene,

Can you download/try again please

Hi,
That now loaded and I could login. However, it did not find any of my camera’s and adding it manually also did not show a picture (Foscam). I rebooted my PC and now two of the images are not restarting (ezlomlapi and nginx-1).

I did a test with the VM based windows version of Vidoo, that did find the cameras and shows the pictures. For one camera motion detection works, for the other it does not…
Also seeing that each time the script is run, I get a new controller to show in my home.getvera.com login.

Hi,

You should be able to restart them by running the initial script again, that should ensure that all of the correct components are updated.

This is older and hasn’t been updated in a while.

Is this with the vm version, or the native version?

The script keeps creating new controllers. I am now at #8.
Not sure if there are some config errors for a typical windows install. I noticed that I sometimes get a error message in Docker that the directory /tmp/compose does not exists (manually created one).
The Docker version is not finding any camera’s and not connecting to any either. When I restart the container, all settings and manually added cameras are gone.

None of my Hikvision or Ezviz cameras were auto detected. I had to add them all manually with their RTSP urls.

They did all play OK and show images in the Vidoo web UI, apart from one which was the Ezviz DB1 video doorbell.

I also managed to add manually their own VistaCam 1203 video doorbell and that one did play.

On the Linux install I’ve not had any issues with multiple controllers being created or losing settings or added cams.

In the Android Vera mobile app, in the devices list, I do not get a cam preview image loading in here, its just gray.

And as for the cam motion sensor devices. I havent tested them yet properly but they do appear to trip and untrip. However they can remain tripped for what seems like an overly extended period of time.

Hi,

That obviously should not happen, let me test in windows and see. as @cw-kid mentions, linux is a bit more tested at this point.

I guess I look at starting a Pi4 up and finding out how to install docker on that then.

I do have a problem with badly tested software trown over the fences that is costing users tons of time just to find out it is not working. It does not add to the brand name of Ezlo that this seems the standard operating mode.

1 Like

“This is the way” as Mando would say…

I followed this guide for Docker on Debian. (Install using the repository)

Well this does not work on a Pi4. Again time waisted.

Status: Downloaded newer image for us-east4-docker.pkg.dev/softhub-354014/softhub/orchestrator:latest
2022/09/13 07:59:00 vidoo is only supported on amd64

Really ? :roll_eyes:

My Linux Debian box was installed using amd64 version…

Pi4 is arm64, not amd64. The latter is intel based.

1 Like

Hi Rene,

The message there is accurate, for right now, the CCTV/AI component is not supported on Raspberry PI yet, but, the core softhub features are.

We’re actively working on supporting ARM for Vidoo/CCTV, but, it’s a bit early for me to give you a good ETA since once we make things work for the new architecture we will also need to test and benchmark to understand the ability of the PI hardware to support the AI/ML models.

Please do let me know if you see issues with the core softhub and stay tuned for the CCTV/AI on PI!

-Adam