Ezlo plus parity with vera plus?

Hi, I’m a longtime customer who’s used VeraLite, VeraEdge, VeraPlus, and am now trying the Ezlo-branded generation of devices as they’re the only ones available for purchase.

I hope this doesn’t come across the wrong way, but: even a year or so after release, I don’t find the Ezlo Plus works anywhere nearly as well for me as the Vera Plus, and I’m wondering if these are known issues, if there’s a plan to address them, or if there’s any way to buy additional Vera Plus devices until Ezlo Plus has feature and reliability parity?

Specific issues I have with the Ezlo Plus

  1. no web UI (or only something that’s in beta and has not been updated in a while). I really would prefer to do complex configuration tasks from a real computer and not a phone. Also, I find it disconcerting that the web controllers console (Login) knows I have an Ezlo Plus, but shows it offline instead of unsupported. It literally says “Controller offline” which is not true, but scary.

  2. the interface for configuring scenes is much less rich on Ezlo Plus (and Ezlo Atom) compared to the Vera generation of devices. I tried Ezlo Atom first, and saw this, and thought it was maybe an intentional limitation of the lower-end product line, but then I tried Ezlo Plus and it’s the same. In the Vera Plus generation, the Scenes configuration flow of Triggers, Actions, Finish makes sense and works well, and using the same mobile app to configure Scenes on an Ezlo Plus, the options are much more limited.

  3. notifications aren’t delivered reliably. I set up a bunch of Fibaro Z-wave flood sensors and paired them with the Ezlo Plus (as I had done with Vera Plus at a different site). All the pairing went fine, and I continue to see the devices in the app (along with live temperature proving they’re communicating). But if I force-test the flood situation by putting the flood sensor in a pan of water, it beeps locally (it does detect the flood) and it doesn’t generate any notifications in the Vera app. Actually, when I first set up the devices I tested them and they worked (including sending me notifications that the scene ran), and then later it stopped working (I don’t know when): I heard beeping from the flood sensor due to a leak, but I never got any remote notifications, only the local beeping sound.

I have a bunch more detailed observations if they would be useful to report, but by and large, it boils down to: I miss the web interface, I miss the old interface for configuring scenes (even in the mobile app it was better before), and I need scenes to run and notify me reliably (and they don’t on the Ezlo Plus).

I should say, my primary use case here is remote notifications for flood sensors in a vacation house, so reliably delivering the notifications about scene events is of primary importance to me.

All this worked fine on Vera Plus and I wish I could buy more of those for additional sites.


1- https://ezlogic.mios.com/ its a very sophisticated web UI as well as it has a dashboard.
2- as above
3-we have a whole new Notification framework with Notification MeshBots (much more reliable and customizable than ever before

Thanks for responding. I don’t quite get the full import of what I’m looking at here (even after logging into ezlogic and playing with it a bit).

This is a new web UI that doesn’t replace the previous web UI (for Vera devices that had one) or the mobile app? (This doesn’t seem like something that can stand alone; I see minimal configuration options, no way to add or configure z-wave devices, it lists my controller by number and not name under “unassigned controllers” and I’m not finding any way to “assign” it to anything, the dashboard has a clock for a timezone I’m not in and no easily apparent way to change that…)

Is this intended as the new UI for Ezlo devices ? I’m just confused on why this doesn’t have more of a web presence; ie I’m surprised I learn of it here in a forum post and not from the Ezlo or Vera websites or marketing effort, or having the existing apps tell me about it. I did find the help site at Documentation - help.mios.com but many of the articles (everything under Integration and Visualization, perhaps?) are empty. I also found the ezlogic forums (EZLogic - Ezlo Community) but they are pretty sparsely populated.

What I do see here is MeshBots which, yes, do seem like a more flexible way of defining scenes, actions, automations. In fact, my scenes are here, with the right triggers, but no actions nor notifications. (I have 2 scenes, each shows up as a meshbot with type=automation, a Trigger clause that makes sense, and an empty Action clause.)

Is this normal? Are you suggesting that I should create new meshbots here instead of using scenes in the mobile app? Or use the meshbot configuration to finish off the scenes that aren’t working (for example, add a Notification action to the existing meshbots that are already here)?

Also, is it normal that the scenes I’ve configured in the Vera mobile app (which have “activation events” defined, “action” is empty, but “notify users” is set) don’t notify me?

1 Like

I played with the MeshBot setup a fair amount.

It seems that for most of the bot types (Notification, Interaction Flow, or Automation/Cloud), the trigger configuration is quite limited – a single device (no and/or/xor combinations or grouping), and only a limited set of events per device (arm state, connection state, or name changes?). For Automation/Local however, the trigger configuration seems quite sophisticated.

I have 2 of these Automation/Local type meshbots already, which match the configuration of my scenes, and the triggers look correct. They had no notification set up, but I added a notification action. Even when I try running them with the Play (triangle) button, from either the ezlogic UI or the Vera mobile app, nothing happens.

I create a new empty meshbot with no trigger, and the same action (notify me). This one shows up as a scene (with no action or notify users though) even in the Vera mobile app. If I test it (with the Play triangle in either the Vera mobile app or the ezlogic web UI) I do get notified. Interesting.

There seems to be something wrong with the scenes I created in the Vera app, such that they don’t run properly (either in test mode or when triggered for real), to either run the actions configured in ezlogic, or the “notify users” configured in Vera.

It looks like I can probably use the ezlogic UI to create meshbot automations that do what I want, at the cost of quite a bit of clicking.

Well. I created a new test meshbot, set an action to notify me, tested it, it notified me. Added a simple trigger, tested it, it notified me. Configured the more complicated trigger I actually want to use, tested it, it notified me.

Then I added another family member to the notify settings, tested it, and it notified nobody. All my previous scenes were trying to notify both me and the other family member. It seems like that’s probably the problem; there’s something wrong with the notification settings for that user, which is causing a completely silent failure on all notifications going to to that user (including not sending the same notification to other users)?

It doesn’t help that there’s no way to configure users in the ezlogic UI, and only very very rudimentary config in the Vera mobile app (it shows the existence of users but not their notification settings or addresses, will allow the creation of users with an email address but not a phone number, and after that not even the email address is visible). The full-blown Users configuration is only in the old Vera web UI, which is only accessible to owners of older Vera controllers? (The Users configuration is shared across all controllers in an account, so I can sign into my Vera Plus in the web UI, configure users there, and the configuration I applied is also active for the Ezlo Plus and notifications from ezlogic, I believe.) Is this correct though? What are people who have only an Ezlo Plus supposed to do? Is there somewhere else to configure users that I haven’t found?

Anyway. There seems to be something wrong with the configuration for this user, which isn’t immediately obvious, and is causing completely silent failure for all notifications when this user is part of the notification set.

The user configuration for the family member in question had no Phone Provider set (in Users & Account Info > Other Users > [that user] > Account Info, in the Vera web UI logged into a different controller). The Phone Provider dropdown control was both empty, and completely disabled (it wouldn’t let me select a provider).

I toggled SMS notifications (“Send a text message to user mobile phone”) off, and then the Ezlo unit was able to send notifications (via the test/play button in the ezlogic UI) for a meshbot set to notify me and that user. I then toggled SMS notifications back on, and the UI immediately selected the correct provider (Verizon). I tried running the test meshbot again, and notifications still worked. So it seems all of the notification brokenness I saw in Ezlo was due to trying to notify a user with a slightly broken SMS configuration.

This is curious because

  • notifications involving this user continued to work for my Vera devices (including testing it 5 minutes ago) with that same user SMS config
  • the ezlogic Notify actions don’t use SMS anyway (channels include “push” and “email” but not “SMS”)

So the SMS config may have been broken, but it was breaking only the Ezlo and the Ezlo wasn’t even trying to send SMS notifications.

1 Like

This is a pretty messy bug report because I had no idea what was going on, but in retrospect here are some distinct things

  1. SMS configuration spontaneously broke for an existing user, and grayed out the empty Provider field, so it couldn’t be fixed by choosing the right provider (but could be fixed by toggling SMS off and hitting Save, then toggling SMS on and hitting Save)
  2. With the broken SMS configuration, all Notify actions involving that user did not happen (did not notify even other users supposed to get the same notification) from Ezlo devices, but did happen from Vera devices
  3. Failure to notify from Ezlo was entirely silent (it didn’t tell me it was having trouble, it also didn’t tell me why it was having trouble), making this quite difficult to debug
  4. No ability to see or configure user settings (including the broken one) except from the old webapp (which requires access to an old device?)
  5. Scenes created in the Vera app, for an Ezlo device, set to “notify users”: don’t notify users when they run. That scene is visible as a meshbot automation in the ezlogic UI, and has no actions whatsoever. (Note that it’s not possible to directly create a meshbot with no actions in the ezlogic UI; I need an action before I can save the meshbot. But that’s how it seems to import scenes created in the Vera app, including new simple scenes I create right now). This is 100% reproducible for me; is this perhaps a regression created during the ezlogic work?

I’m able to get working notifications now from my Ezlo device (only) if I

  1. use ezlogic to configure Notification actions for the meshbot (whether that meshbot was created from scratch as a meshbot in ezlogic, or was craeted as a Scene in Vera)


  1. use the old Vera web UI to make sure all my users have Phone Provider set (even though Ezlo isn’t going to send SMS to them anyway and that seems irrelevant)
1 Like

And thanks again for pointing me in the direction of ezlogic, but to my original post: unless I’m grossly missing something here, given the sharp edges about SMS notification configuration that were breaking notifications from Ezlo but not Vera devices, and given that I had to jump between the Vera mobile app, the old Vera web UI signed into a different controller, and the new ezlogic web UI signed into the Ezlo controller, it does appear that the Ezlo Plus product has a ways to go to reach both usability and reliability parity with the Vera Plus. That took me a lot less effort to get working, and keep working.

First of all thank you for all this great feedback.
You are right, we are working on expanding the User configuration capability.
Please do keep your feedback coming, I will get our dev team involved in these discussions so that all your requests are taken into development and executed.

1 Like

If you choose just “Local MeshBot”
You will have all the granularity you need as well as Notification capability

The difference is this is a general MeshBot (which will do the same job) vs the other is pure Notification MeshBot…but it will do the job for now.

The others like (Notification, Interaction, Cloud MeshBots will have these extra capabilities in July).

1 Like


I’ve been following ezlo progress. Your original post has all the same questions I’ve been pondering for over a year. Thank you for posting.

Finding a replacement for my Veraplus that has worked remarkably well has proven to be difficult. Although there are things that are frustrating (engine restarts when making seemingly simple changes is most notable), my testing with other platforms has been much more frustrating. I am coming to the conclusion that, for myself, I will need two systems, and use the most operative functions from each.

To ezlo, please continue working on making what hopefully will become a superior product.


We are 100% continuing to work and release improvements every 2 weeks!
We love Ezlo and we will make the last every home automation system you will ever need.
Soon we have the “Exceptions” coming in “Actions” which means you can now pretty much do any automation you wish (last remaining big item for Automation)…
Its only matter of time…We are also working on Ezlo SoftHub where you can download our hub and run on lets say on Raspberry…and much much more…

We are all on it!


I am a long time VeraEdge user and have set them up in 3 separate houses. I am quite familiar with the hubs and the UIs.

For a new house recently, I went ahead a purchased a Ezlo Secure.

My initial impression was that from a hardware perspective it was an upgrade over the Vera Edge in terms of speed, ease of pairing of devices, and built in battery. The potential for VOI integration with Google home was a significant bonus.

However after after several months, it became apparent that the Ezlo secure was not going to work for me in it’s current state. I was able to find an ebay Vera Edge and have since set this up.

The main issue with the Ezlo has to do do with software.

  1. I agree the Web UI needs to be be improved as discussed above

  2. I use a lot of plug-ins which include to sync my Vera Edge to the rest of my house
    - connection to Honeywell thermostats
    - DSC alarm panels
    - Lutron RA2
    - local weather (to control outdoor heaters)
    - mimoLite for garage
    - House mode plugins
    When I switched back from Ezlo Secure, these plugins were non-existent, meaning that the slick hardware device did not really help me from a practical useability perspective

  3. I could never get the Google VOI to work, despite many communications and weeks with the support team. I understand that there is an issue with the “cloud” team, which is a separate from the technical support team.

For these reasons, I’ve gone back to the Vera Edge. It may be a little slower, but it’s been rock solid for me once I got it up and running.

Perhaps once the Ezlo framework is more mature, I can try again, although, to be honest, I don’t want to go through the pain of setting up all the devices again…An simple upgrade path from Vera to Ezlo would be much appreciated.


Also a long-time Vera user. Pretty basic really. I have some vacation rentals and use the controller to set lock codes for guests and folks needing access (cleaners, maintenance, etc.) and monitor A/C thermostats. I much prefer to do these things on a computer and not my phone. I have not been able to figure out how to add a lock code to the connected deadbolts using the ezlo computer app. I have to use the app. I think ezlo support has been great to work with when I needed it but I still must agree that the ezlo browser app seems far behind the vera app in functionality. I don’t really use notification or web bots. I just want pretty basic stuff and I don’t see it. (which could be related to the actual devices I’m using I’m not sure). Also, I agree that the Vera app should not list my ezlo controller as offline. Please either don’t show it or show it as unsupported

1 Like

@melih thanks for reading carefully and responding; I’m glad my feedback can be useful.

In my version of the ezlogic UI, I see a big difference in the Trigger configuration available for a Local Automation Meshbot (quite flexible) and every other type of Meshbot (including Cloud Automation, Notification, and Interaction Flow: much more limited).

What I see as “flexible”: Ithe device capabilities depend on the device (eg a flood sensor has “water leak alarm”, I can make groups of triggers, and I can specify a set of devices without a group and combine the trigger with boolean logic:

Whereas, all the other meshbot types that I see as “limited”: No groups, no ability to specify a set of devices without a group and combine with boolean logic, and the device capabilities don’t even depend on the device:

Note the missing “add group” button, the grayed out “add trigger button”, and the limited set of capabilities (for the same device as in the earlier screenshot).

The 2nd screenshot is in the creation wizard for “Automation MeshBot: Cloud: Create” but I see that same behavior from “Notification MeshBot: Create” and “Interaction Flow MeshBot: Create”. The only mode that seems to support sophisticated triggers in my version of this UI is the Automation MeshBot, Local.

BTW what version is this… on the main screen in the upper left of the dashboard it says mios 1.17.1 and then if I click the person icon in the upper right and click Version, 0.9.2.

0.9.2 is the Dashboard version. 1.17.1 is the Web UI version.

Hi @warthog99

I am Product Manager from Ezlo and will be very happy to have your feedback on our products. So I wanted to go over your feedback to clarify what you need and we will try our best to improve our users’ experience.

Can you tell more about your use cases / needs about the cases you mentioned:

  • which feature you need most on the webUI ? Is it notification configuration ?
  • Usage of those plugins/devices in your scenarios ?
  • Usage of Google VOI

Hi @mdg ,
The “Automation:Cloud”, “Notification” and “Interaction Flow” Meshbots are cloud meshbots which we are constantly upgrading to match and exceed the capabilities of the Local ones. So its good for us to hear some feedback about all of them. So you can also tell us what other logic/automation rule that you want in our meshbots.
And for the capabilities, all should show the same capability list but there may be bugs like every system. So keep telling us the differences that you find and we will check them in detail. We will check the flood sensor and get back to you on that.

Hi @Osman,

In response to your questions

  1. With regards to the webUI, I actually haven’t looked at at it for a while, as I haven’t needed to since switching back to the VeraEdge

  2. Plugins - Although Z-wave is great, it can be sometimes finicky. There are also other non-Z Wave devices out there that work better than what Z-wave has to offer. However, the ability to integrate these other devices my VeraEdge is very useful for my home. There is a whole library of robust Vera Plugins out there. For example

    a) When I set my DSC alarm, I have a scene that turns off Z-wave devices, lowers the temperature on my Honeywell thermostat, and turns my Lutron RA2 light system to “away mode”.

    b) I use the “Multi Provider Weather Station” plugin to monitor local weather. When the temperature goes below freezing, I have a scene to trigger the heat trace cables on my roof to turn on to prevent frozen gutters

    c) I use the Garage Door Plugin and Mimo-lite Plugin to be able to control my non z-wave garage door via the VeraEdge

    These plugins are not available for Ezlo Secure

  3. Google VOI - this would be a good option to integrate non z-wave devices, but I could never get it to work. Multiple errors Including “command cannot be empty”, “locations were not found”, and for some reason 2 Google VOIs would show up on my Ezlo account. I could not remove/delete them. I was told by support that this was a cloud issue on the Android app. Please have a look at support ticket #265475 .

After several weeks/months of frustration, I switched back to the VeraEdge from EzloSecure, and everything is working smoothly now. I don’t really have any incentive to try again…

Hi @mdg ,

I will summarize your issues here and please comment if anything is left out;

1- Notifications are now only works with Meshbots. So you should use ezlogic web app to create meshbots with notifications. You can either use Local Meshbots with notification actions or “Notification” Meshbots. The SMS option prerequisite seems like a bug on the old platform. But It should not effect the ezlo platform.
The notification actions UI is not updated on the Vera mobile app which we have as a task in our list.

2- User management is missing from ezlogic web app , which is currently in progress and will be released with the next update coming next week.

3- Local Automation Meshbots and Cloud Meshbots currently have some difference since we are developing a more sophisticated Meshbot structure on cloud side, where you will even be able to create your nodes and operators ! So you can let us know what capabilities you use most or you want to see in the meshbot construction logic and we will use your feedback on it.

Thanks for your valuable feedback.