Ezlo Plus devices not working with Alexa

Some Ezlo devices were found by Alexa and do work, but major problems trying to “pair” new devices.

  1. On the Alexa app, under “Devices” / “All Devices” several existing devices show as “New Device”, but indicate “Device is Unresponsive”, or “There was a problem”, and some (routines, not devices) appear functional. Some appear twice with two different icons displayed.

  2. Recently added, “current technology” devices are unable to be “found” by the Alexa app.

  3. The current Vera Control app, version 3.62 (2), does NOT have the same screen options as virtually anything and everything I can find with Google searches, Ezlo Community searches, or even support guidance from Vera Tech Support.

  4. Even the “home.getvera.com” webpage on my Mac, using the pulldown under my name in the top right corner, under “Manage Alexa Ezlo” does not display an accurate list of devices that matches what I see on my Vera app on my iPhone.

Is there an instruction guide ANYWHERE that describes how to “pair” Ezlo Plus devices with Amazon Alexa’s voice control application that is up to date with current Ezlo app versions and current Alexa app versions??? I am at a complete loss!!!

1 Like

I had good luck controlling all my devices with my old Vera Lite controller. Once I switched the the Elzo Plus, I can’t get anything to show up. I have removed the plugin, and re-added it, but nothing. It would be good if this could be resolved.

1 Like

You are meant to use the Ezlo skill not the Vera one in the Alexa app fyi if you are not.

However unfortunately the voice assistant integration for Ezlo hubs is currently broken and not working with some of the issues described by the OP.

The voice assistant integration is currently working for the old Vera hubs however, but that is no consolation.

Ezlo are starting to work on re-doing the entire voice assistant integrations from the ground up I believe with a new development team.

However in the meantime I was hoping that they maybe able to at least patch up the current integration and get it working again, but not sure that will happen?

2 Likes

Thank you to you both! I can deal with fighting problems once I know that it is not something I am doing wrong but that it’s a problem with an equipment or system provider causing the issues. PRAYERS!!! Prayers that they really do get on the ball and have success getting these two players onto the same team!!!

I was under the believe a couple of years back that Vera was going the way of the unicorn and that Ezlo was the way of the future. I made the jump, and it’s been pretty frightful!! VERA Tech has some awesome folks that bust their tails when issues come up. The are amazingly fast, and they are problem solvers, for sure! But this one is giving them fits, unfortunately.

Again, thank you both for your great input! Guess we’ll just have to hang in there for awhile and hope. Cheers!

1 Like

After all, isn’t Ezlo/Vera supposed to be the gold standard in home automation systems? And isn’t Alexa supposed to be the gold standard in voice assistants? Those two should be great partners working together for the good of the order.

1 Like

Looking at CW-KID’s image, I should note that I drank the Apple Kool-Aid about 12 years ago, so I’m using a Mac with the latest OS 13 and an iPhone 13 using the latest iOS 15.7. So the image that he posted is not available to me. CW-KID? Ham operator?? Or country-western music person? :+1:

1 Like

I am having the same issue. I have some devices I added to Alexa months ago working but any new devices I add to Ezlo cannot be added to Alexa as the “Finish” button on the bottom of this page does nothing:
https://home.getvera.com/amazon/alexa/ezlo/smarthome/devicelist

I currently have about 40 Ezlo devices left to add to Alexa that are useless without voice integration working.

Please help!

I need a status or I’m pulling the trigger on Home Assistant. I’ve been a Vera customer for a decade and this fix has taken too long!

Pretty much the same here, MH88. (Unless your name is Rob Reiner, I can’t bring myself to call you “Meathead” :blush:)

I will say that the technical support from Vera, on the EZLO platforms, is second to none!!! They usually get back to my requests for help very soon, sometimes actually in minutes rather than hours!!! I just wish I knew if Vera was going to continue to debug and improve the EZLO platforms. If so, I’m willing to hang in there. If not, maybe I should be looking at the Home Assistant, if it is a good alternative. Especially if my generally routine devices are supported on that platform, as well. Thank you for your input.

1 Like

Uh oh. It looks like they may not know that Apple exists. :cry:

We are here for the long haul!
We are releasing new features, bug fixes, new integrations almost on weekly basis!

The whole Ezlo team is here to support you!

That’s fantastic, Melih. And my comment about Vera support being great was largely due to your attention to requests for help. You’ve helped me COUNTLESS times, and I appreciate you a ton! You are one of those that literally gets back to me in minutes, instead of days!!! Thank you!

And your comment about what’s going on, on an almost weekly basis really does make me happy. There has been a lot of chatter about issues with the Alexa integration, and It looks like all we can do is wait. And it’s pretty much impossible to tell on our end whether the issue is really with the EZLO platform or the Alexa platform. But thank you in advance as well as for all the great help you’ve already given. Yay, Melih!!

Can we please get an update on the issues with Alexa integration?
I’ve got 2 open support requests on this and both admit there is an issue.

I opened the first request 4 weeks ago so its been quite some time, that’s why I’ve used up most patience.

Please, just let us know what the status is.

Thank you @k7jv

The engineering team is working on a proper solution to all “voice enabled” services requirement…
from Alexa to Google including Siri…
We do want our users to benefit from Voice enabled capabilities and we are re-architecting how this should be delivered to our users.

Thank you for you patience, we are on this full time!

I tried to add a new device to Alexa again today at 2:00 PM EST and am still not able to.
The “Finish” button still does nothing.

I’ll let you know again tomorrow.

MH-88, first, I am assuming you are logging on with a computer rather than the mobile app on a smart phone. I have done that, too. I found that when I click on “Finish”, nothing happens, as you noted. After five or ten seconds, I found that if I click on “Finish” again and then wait maybe another half minute or so, the progress bar finally appears at the top of my browser and the action(s) finally complete. BUT, that said, I find that Alexa still doesn’t operate the device(s) that I just added. So the work in progress is continuing, as Melih said.

What you describe ^^^^ is how it worked for me for a while but now no matter what the interval i wait to click “Finish” the result is always nothing.

I tried adding new devices to Alexa today at 3:30 PM EST and the “Finish” button still does nothing.
https://home.getvera.com/amazon/alexa/ezlo/smarthome/devicelist
This page still appears non-functional.

Good morning,
I tried again this morning to add a new Ezlo device to Alexa and the “Finish” button still does not work

Happy Saturday.
I just added a new thermostat for my garage to Ezlo successfully, then went to this page to add it to Alexa:
https://home.getvera.com/amazon/alexa/ezlo/smarthome/devicelist
It shows up, but when I select the newly added Ezlo device and click “Finish”, the page still does nothing.
I’ll give it till this cyber Monday, then I’ll be trying another hub, whatever is on sale.

I hope one of the tech support folks come to your rescue. I started down that path several months back, but everything I looked at made Ezlo/Vera look the most attractive of the lot.

Good luck to you!