Ezlo Plus device confusion

I’m having a couple of (maybe related?) issues with devices on my Ezlo Plus unit - or perhaps the Vera app - and I’m hoping someone can point me to some troubleshooting steps I haven’t tried.

TLDR; In-wall switch always shows “on 100%”. All attempts to remove/re-add have had no effect, and Vera app shows conflicting information about devices connected/failed.

Full story:
It all started when I realized that one of my in-wall switches (GE Enbrighten Z-Wave Plus) wasn’t responding - the app didn’t show any errors, but the app always indicated “on, 100%” regardless of the actual status, and trying to change it from the app had no effect. For example, if I turned on the light manually, then tried to turn it off via the vera app, nothing would happen, and within a few minutes the vera app would “update” back to on. Conversely, if I turned the light off manually, the vera app never updates to show off. It appeared completely stuck.

So I tried adding it again. This, however, had no effect - the Ezlo hub went into include mode, and the Vera app indicated this with the top bar and the countdown timer, but pushing the switch as indicated (and otherwise) had no apparent effect on anything.

My next attempt was to exclude the device. This also apparently had no effect - the Ezlo went into exclude mode, but pressing the switch as indicated had no effect whatsoever.

Next I tried a simple “Delete” to remove the device from the Ezlo. The light on the Ezlo turned red briefly, but the device did not go away - even after a full restart of the Ezlo Plus hub.

I also tried disconnecting and reconnecting from the hub in the app several times throughout the process, in case it was an issue with cached results or the like, but this didn’t make any difference either. The switch is simply stubbornly displayed, and always “on”, at least according to the Vera app.

I also noticed that if I go into the device -->z-wave settings -->Rediscover device, it says “Status pending”. I don’t know if that is relevant or not.

Then I noticed that the dashboard screen was displaying a “1 device is no longer connected” message. I figured this would be the wall switch, but on tapping the arrow and being taken to the “Failed” section of devices, it says “All your devices are working properly” - so which is it? All devices “working properly”, or “1 device no longer connected”?

Finally, as if that wasn’t confusing enough, if I look at the “My Favorites” section of the dashboard, I see a device listed there (my currently non-functional GE remote control), that isn’t listed under devices - so does that device exist on my controller, or not?

So where does that leave me? Am I looking at needing to do a full reset of my controller and start over to “clean up” the issues? Or can things be fixed?

1 Like

power cycle the hub…and relaunch the app…

Yep. Did both of those. No apparent change. Guess I could have been more clear in my description of what I tried!


Comms issues ? How far is this wall switch away from the Ezlo hub? Are there other Z-Wave devices (neighbours) near the location of this wall switch?

I assume you have other wall switches of the same type that are operating normally as expected?

1 Like

Quite possible - the switch is separated from the hub by around 60 feet or so, with only one other z-wave device (that I believe can act as a relay) between.

Edit: Note, however, that the vera app is not indicating any issues with the device.

Not really. I could try adding (or moving) one.

Nope. This one was added to my network more recently than my other switches, and as such is a different model than any of the others. Actually, back when I first added this switch to my Ezlo, I had filed a bug report (ECS-411) about some issues I was having, but that bug report has since been closed as “done”. Only, apparently, the fix broke it completely.

What I find really odd, though, is that I can’t even “delete” (not unpair - delete) the device…

1 Like

Hi @ibrewster

Given the number of factors at play here, I have created a support ticket (259532) to assist you with it. Once and if we find a resolution, I will share it here for others to benefit from it, but let’s troubleshoot this via tech support first. Please make sure to reply to the email I sent you with the information I requested there so we can start working on this.

1 Like

Sounds good. E-mail responded! Thanks!

Most welcome. I’ll start checking on this and update you via email, likely by tomorrow since I’m minutes away from leaving the office for the day.

Ok, that seems to have done it (for that switch). Out of curiosity, how did you manage to delete the switch? Because nothing I tried to remove it - either unpair or just a plain delete - seemed to have any effect.

The only way that worked to remove the failed device was via an SSH connection on the controller, downloading the following custom script to the tmp folder, and running it with the device ID:

wget http://dl.mios.com/customercare/remove_device.sh -O /tmp/remove_device.sh

To run it, it would be:

sh remove_device.sh DEVICEID

This is useful when a device is still part of the Z-Wave network and refuses to get deleted with the usual methods. I probably wouldn’t have to use and you should have been able to still unpair it and pair it with the controller close enough as you did today.

So, if I am understanding things correctly, there were two problems:

• First, the inability to delete the device from the hub, which you somehow worked around/fixed from your end
• Secondly, while the switch may work at the range I have it (perhaps relaying through an intermediate device?), it apparently can’t be included/excluded at that range. Moving the hub closer for the exclusion/inclusion process fixed that.

Does that sound about right?

That’s right, a device needs to be as close as possible to the controller it is being excluded from or included into since exclusion/inclusion commands and packets won’t go through other nodes in the Z-Wave network. They require direct communication for both these processes. As for the first, as explained above it had to be done via the script I referenced. I wish there was another way to force remove a device without having to do this, but there isn’t one at the moment, at least not that we are aware of in the support team.

While I have your attention, any thoughts on the discrepancy between the dashboard (now showing “2 Devices are no longer connected”) and the “failed” tab of devices, still showing “All your devices are working properly”, or the discrepancy between the “My Favorites” tab of the dashboard which shows my “GE Remote Control” device, and the “Devices” list which does not? Since the switch is now working properly, I’m guessing it isn’t related :slightly_smiling_face:

Note the GE Remote control is currently sitting right next to the hub, but as a battery powered device that doesn’t communicate state (as far as I know) it is probably not communicating at all, or responding to polls (if any are occurring). It is also not a currently supported device, so if it doesn’t work that would be 100% expected :slightly_smiling_face:

I see two devices named GE Remote Control and Remote Control respectively in your Ezlo Plus, at least from an Android device:

They are, however, not present when checking from an iOS device, so I figure that’s what you use to access them, and that’s where the discrepancy is. Please let me know if it is ok to remove those two devices from the controller as well. If you want them on the integrations queue, I suggest you create an integration request here if not already:





So in theory, at least, both of those are the same device - and I would think they should at least show up (should I file a bug report on the iOS app about this?), even if they don’t work. Perhaps the best approach at this point would be for you to go ahead and remove both devices “under the hood”, as it were, then I can try re-adding that device as well to see how far it gets.

So yeah, go ahead.

Thanks again for your assistance!

That’s right, they should show up even if failed under the failed devices tab.

I have removed them, this time I was able to do it without having to SSH into the controller, just using a call from the API tool.

If you try to add the GE remote controller again, and it doesn’t show up on iOS, try logging in from an Android device to check if it shows there, if it does and still reads Can’t Detect Device, it could be an integration issue, so if you haven’t at this point, I suggest filing that integration request as far as the GE remote control you have is still a commercially available Z-Wave device.


Cool, thanks. My controller looks happy again now!

Will do. I’m not sure it is still commercially available, however - recent searches show it as out of stock everywhere I have found (although it looks like you could get it off ebay: 45600 GE Z-wave Remote for Wireless Smart Lighting Control for sale online | eBay). That said, in another thread @melih offered to work on integrating such devices if we were willing to work with you guys “remotely”, or send in the device, and I mentioned to him that I would be interested in such for this device, if it’s not a problem. So presumably that’s already in work. Not a big deal to me either way :slight_smile:

I couldn’t find an integration request open for the GE Z-Wave remote 45600, so I created it for you:

Hopefully, it can get integrated into the Ezlo platform.

Glad to read this!