EzLo House mode emulation not arming sensors

I have a new controller that setup quick with 3 door sensors, motion sensor and two cameras. I used the Vera Mobile app for all new devices creations.

I can set the house mode but the door sensors never arm. I can arm them manually in the app and that is all.

I was advised by support that “house modes” is not a freature of the new Ezlo and not supported at this time, however, I have another controller it works fine with, same type of sensors/controller.

Even if I make a virtual switch to activate the “house mode” option to “away”, the devices are not available to arm. I think this is my problem but dont know.

Why do some actions in that rule say device not found ?

House Modes on the Ezlo platform is kinda half done and is not as fully featured as the one we had on the old Vera system.

However a Meshbot rule such as that should work OK I would think.

In my Vera mobile app on Android whilst connected to an Ezlo Plus under House Modes and Away I armed some security sensors as you can see in this screen shot.

When I then put the Ezlo Plus in to Away Mode those sensors were NOT then armed as I expected they should be. So maybe it is broken then.

Also note I had no Meshbot rule at all involved.

I tried this with virtual security sensors initially and those did not get ARMED at all.

However I just tried it with two real motion sensors and then when I put the Ezlo Plus in to AWAY mode only one of those motion sensors was actually armed OK. The other did not get armed for some reason.

And then when switching back to HOME mode the one that got armed was then disarmed.

I have no idea why one motion sensor seems to work and get armed / disarmed OK when switching to Away and then Home, yet the other motion sensor does not work at all.

The working motion sensor is a Hank the one that does not get armed is a Fibaro.

So it all seems a bit janky and buggy to me.

Using a virtual switch and your meshbot rule might be the better idea for now.

However having said that, I have issues in the Meshbot rules action where some real security sensors do NOT appear in the list of available devices, so you can set their Armed capability, those devices are just missing, whereas some other real security sensors do appear OK in that device list. So there seems to be no consistency for myself.

For example the Hank motion sensor does not appear as a device in the Meshbot action but the Fibaro motion sensor does appear. Why is that ?


Also if you are going to use Virtual Switches instead and Meshbot rules and you have a virtual switch for each “House Mode” I would recommend in your rules actions to set all the other 3 virtual switches to false when triggering one as true like this, so your virtual switches don’t get out of sync and only one of the 4 switches should be ON at any one time.

You can also select the “House Mode” node and actually put the controller in to Away mode also if still required.


I did create the virtual switches as described however, the logic only operates on the built in “House Mode” changing it to “Home” or “Away” in the meshbot action.

The actual arming/disarming off sensors is done automatically (by luup?) but the “House Mode” is something that is built into the meshbot ‘action’ so…
why it works great on one controller with the PSM08 sensors and arms them but not in another identical setup makes me think my controller is broken. It got bricked while trying to fix the RTSP issue.

I also heard from support that currently House Mode is not officially supported.

I do see it as an action and a trigger in my meshbot logic. Here is my “away mode” switch it has that action to change “house mode” to away and turn off the virtual “Home” switch.

Support created this meshbot to workaround it on the broken system but looking at the bot its missing data and it arms the sensors each not using the built in House Mode at all. These are Philio PSM08 Door/Window sensors.

I’ve never really used House Modes properly on an Ezlo controller, as I am still using my old Vera Plus mainly.

However from my quick tests today.

  1. Using House Modes (no Meshbot or virtual switches involved) I had mixed results, some real security sensors would ARM OK when switching to Away mode others did not ARM at all for some reason.

  2. When looking at if I could use Meshbot rules and virtual switches instead, I found some of my real security sensors were just missing from the device list in the rules action for some reason. I have created a ticket for the devs to look in to this.

This house modes in one EzLo Plus works as expected and the mobile app shows the sensors, all of them. The other system almost identical has the sensors showing in the “Configure” house modes showing they are in the armed position but it just doesnt happen.

That’s probably what I would of done, if using a Meshbot action instead, would of been to have an action for each security sensor I wanted to ARM. I tried to do that, but as you saw some of my sensors were missing from the device list.

I think you’re correct. Unit 1, the sensors are not available to be “armed” in meshbots at all but show up in house modes on the mobile app as armable? The bot techsupport created (screen shot above) has some red fields where I expect the PSM08 contact sensors to be if using a bot to arm them,

In unit 2, I made a bot action is “house mode” away and it works just fine with the same sensors. Maybe they didnt add correctly?

Are both controllers on the same firmware version?

That’s similar to what I saw in the House Modes area of the Vera mobile app. I could see my sensors listed in there and I selected some of them to be armed. But not all of them actually got armed when switching to Away mode, only some of them ended up actually being armed. I am at a loss as to why that is?

Good point, I did NOT even look until now.

The working Unit is on
Screenshot 2024-02-01 104006

non working is on
Screenshot 2024-02-01 104043

Interesting so the working unit is on much older firmware !

As I see it there are 3 possible ways to go about doing this, assuming each option is currently working which does not seem to be the case from my experience today.

  1. Use “House Modes” setup in the Vera mobile app and nothing else. In there select which sensors you want to be Armed for Away mode. When you put the controller into Away mode those sensors should then be all armed. And when going back to Home mode they should all be then disarmed.

This seems to work for some of my sensors but not others, so there seems to be some issue here for me.

  1. Create virtual switches and use them as triggers in Meshbot rules, then in the rules action arm or disarm each sensor as desired.

This should work assuming all your desired sensors appear in the Device Node list, not all of mine did and some sensor devices were missing.

  1. Similar to number 2 but you could instead of adding individual actions for each sensor, you could maybe use the “House Mode” node in the rules action to set the controller into Away. The advantage being you could also do other logic stuff in the rules action, that just using the bog standard “House Modes” feature on its own cannot accomplish.

So when using just “House Mode” feature on its own, no meshbots or virtual switches involved, none of your selected sensors armed at all right? When you switch the Vera app in to Away mode.

And when I tried the same also, some of my sensors armed but others did not.

My controller is on firmware version

Yes it seems possible in many ways, in my case the mobile app is deceptive.

I have this screen for option 1

but the sensors do not arm after the countdown!

Option 2
The door sensors Do not show as sensors to arm in either unit so that is out.
Non working unit

working unit

Option 3
sensor dont arm If using a bot to change the “House Mode” to Away .

The only way to arm them is manually in the mobile app.

Option 1:

In my test I selected two real motion sensors in that “Choose sensors to arm” list.

After the count down one armed OK the other did not and remained as disarmed for some reason.

I had the same problem some of my sensors are just missing from the Meshbot Action Devices list.

Option 3:

That is kind of expected if “House Modes” feature is not arming the devices when you switch it to Away in the mobile app then doing the same via a Meshbot rules action also won’t be working.

House Modes in Ezlo controllers still seems half done to me and not fully developed or working.

So seems we have two problem here.

  1. House Modes feature is not fully working and does not arm all sensors when switching to Away. Or in my own case it armed some but not others.

  2. Missing sensor devices in Meshbot rules actions.

Problem 2 I have already reported to them and created a ticket.

Problem 1 I need to test some more and maybe create another ticket for that.

As I would like this all working when I start using it properly myself.

Yea, its a mystery for now why one unit with the same sensors and cams vs another.
Neither unit shows the devices as actions. (added screeshots above)

I would love to roll back to older firmware to see if it fixes this. Maybe related to the whole RTSP camera problem that unit also has.
If that old unit firmware updates it may break it,keeping fingers crossed.

Yeah I don’t think us users can roll back to an older firmware version. Support might be able to do it.
And yes if that other controller updates it may then break on there also.

I don’t think this is related to the Camera RTSP issue however.

Hope you are correct. I really dont like blasting support with two or three tickets in one day but this same unit armed and disarmed fine back in Oct. now it has several quirks.

I can’t confirm if it worked in the past? But if you say so then it did. There must have been something that broke it from working properly in the later firmware builds.