EventWatcher some temperature readings are not being watched while others are

Hi,I’ve installed Eventwatcher and it’s more or less working as I would expect(great plugin) it too except it’s not watching some Temperature variables while it is watching some others. The type for both working and non working is the same = TemperatureSensor. The tree shows the non working ones as Blue while the working ones are shown as yellow.

Anyone any ideas? The device that isn’t working are my temperature probes connected to the Z Wave Universal Sensor by Fibaro.

Anyone any ideas?

EventWatcher works by selecting different device categories. Some devices may not install with the correct category. It doesn’t matter to EventWatcher what the device type is, or what services it provides, it simply classifies on the category.

So, first check the category under the advanced tab for the device in question and see if it is correct for a temperature sensor.

The field device_type says urn:schemas-micasaverde-com:device:TemperatureSensor:1. This setting is the same for those devices that work and for those that don’t.

Not the [tt]device_type[/tt], but the [tt]category_num[/tt] which is an attribute, rather than a variable… should have the value 17.

Spot on… it says 11 for those not working and 17 for those that do.

so that’s DEVICE_CATEGORY_GENERIC_IO code O, correct? I’ve added group O and it still doesn’t work.

No, it’s not going to work like that. Category 11 (“O”) is “Generic IO” and doesn’t have a temperature service. Interestingly, I added a temperature sensor (Everspring ST814) to one of my systems yesterday and it classified it as “Generic IO” also. The thing to do is to change the category_num for those temperature devices which are incorrect to 17.

right updated category_num to 17, recyled. It’s still not working. Don’t I now need this device to have a sevice called urn:upnp-org:serviceId:TemperatureSensor1 now? Beginning to drift outside my comfort zone here.

Maybe I have to do something to the parent device?

OK, I think we’re fixing the wrong problem.

Initially, I understood that you had several temperature devices, some with the wrong category. Now I’m hearing that the category 11 ones are, as they should be, Generic IO devices ???

Can you fully describe what these devices are (and they seem to be child devices of some parent?)

As mentioned previously I have a Z Wave Universal Sensor by Fibaro. Connected are 3 DS18b20 Waterproof Temperature Sensors.

OK, I don’t have experience of these, but it seems to me that the child devices should be cat 17 and actually temperature devices with a temperature serviceId and CurrentTemperature variable. If not, how do they report their readings in Vera?

Well they work just fine. See screen image. I have 3 of them.

I read them as follows:

S1_temp_l = luup.variable_get(“urn:upnp-org:serviceId:TemperatureSensor1”,“CurrentTemperature”,S1)

Indeed, they’re right - Temperature devices with the right service and variable.
The only thing that’s wrong then, as we discovered, is the [tt]category_num[/tt] for these child devices (not the parent).

[ul][li]and you are saying that changing these to 17 didn’t work?[/li]
[li]you, said ‘recycled’, so that’s a Luup restart then?[/li]
[li]did you wait long enough for an update?[/li]
[li]did you refresh your browser page?[/li][/ul]

If so, then I’m right out of ideas.

None of the TemperatureSensor child devices of the WUG plugin on my system get reported despite having category_num = 17. Does EventWatcher classify them according to the type of the parent?

No, it doesn’t do anything with the parent - it simply scans every device in the device table for particular categories when constructing the watch list.

Do you, in fact, see these ‘missing’ devices when viewing the report given by this ?

Do you, in fact, see these 'missing' devices when viewing the report given by this ? Code: [Select] :3480/data_request?id=lr_EventWatcher&rep=env
Yes, they show-up there as TemperatureSensor1 devices.

Actually, I got it all wrong. I’m not logging “T” anyway - to avoid being buried by logs of every variation in outside temperatures. My temperature logging is coming through type “K”. Sorry to add to the confusion…

Well, thanks anyway! All this difficulty with categories is exactly why my dataMine replacement eschews them.

They appear to be working now. I’m not sure exactly why… by setting to them 17.

Thanks for your help.

[quote=“mbaker171, post:17, topic:179734”]They appear to be working now. I’m not sure exactly why… by setting to them 17.

Thanks for your help.[/quote]

Bingo! Delighted it’s working for you now.
Hopefully this thread may help others in the same situation.

Actually, this this has been a really useful observation, because I’ve noticed that it’s true for my WUG devices too! I think it’s just a problem with the tree map display, not the underlying EventWatcher logic.

Thanks Rex!

Hope it’s not a problem posting to an old thread … I have just installed the Horstmann HRT4-ZW which shows as urn:schemas-upnp-org:device:Heater:1

Is there a way I can track temperature changes with EventWatcher? The category_num is 5.

Any help much appreciated.