Disabling Events in Activated Scenes

So I’m going to guess I already know the answer to this, but is there anyway to have the activation of a scene deactivate events that another scene activated? Here’s my dilemma…

I have a scene called “Away” that I activate when I leave my weekend home. It turns on the motion sensor, and also enables two events - one is when the motion sensor is tripped, and the other is when the patio gate (Schlage lock) is opened. These events work fine, although as expressed elsewhere in this thread, I’m finding that I receive giant batches of SMS messages at once, rather than immediately when the event occurs.

But when I’m here, I activate a scene called “At Home” which Bypasses the motion sensor. However, both of my events are still enabled from the other scene, so I’m still setting off notifications every time I move through the living room or open the patio gate. I understand the latter - you can’t “disarm” the Schlage lock. However, why is the motion sensor still tripping events if it’s set to “Bypass?”

So I’ve really got two issues - motion sensor tripping events when set to Bypass (which I’ll post separately) and wanting to have the activation of a scene deactivate events previously activated with another scene.

Any ideas?

So how does one do this? I also want a “HOME” or “AWAY” scene. The HOME scene would override all the other security based scenes I want when Im away.

I believe you will need to use Luup Events and a virtual device to store your “Home” and “Away” state. See this thread: http://forum.micasaverde.com/index.php?topic=2138.0

Other discussions on the same topic: