D-Link IP Camera Setup Issue

It really is on port 8082. My url I gave you maps that to the right port. I am using DynDNS. If you hit port 80 you will get my DSL router. What is the format for the URL field? I just put in /jpg/image.jpg

Sure. That’s external. So I’m definitely connecting to 8082 at your external IP. But it sounds like you changed the port in the camera as well?

Yes in camera settings.

[quote=“aschwalb, post:9, topic:167509”][quote=“Daniel MCV, post:7, topic:167509”]Try using ‘image.jpg’. See if that works and let us know.


No it does not… I did go through the list of URL’s in the wiki and couldn’t get any of them to work. I have also searched on the Airlink website and they do not mention anything. You can see my camera if you want (looking outside, not much fun)[/quote]

Nice weather there Aschwalb! Just a security warning… not only can one see your cam, also the log is available

The log immediatly shows that several streams are available and accesible (before NTP kicks in and solves your antique CAM ;-)), question is what the links should be. I saw video at index.asp (yes youre on port xxxx)

Hope you dont mind me butting in like this…just trying to help a bit.

@oTi@ anything i can do to help?

@oTi@ & @aschwalb

I’ve tried these direct links:


Both work.

Looking at the log your internal address would be:
192.168.1.xxx (internally im sure its on port 80, so i agree with @oTi@ not to specify it)

The correct format in your generic plugin would then be:

IP 192.168.1.xxx URL jpg/image.jpg Dont specify the MAC username/password as stated Timeout 5

You could try and play with the timeout with values between 2 and 10

Hope this helps…
On the bright side? Your cam works fine and the weather is fine there!

@oTi and @Henk

Thanks guys got it working. I had to delete the device, installed the Panasonic PTZ thinggy created a new device and entered the data and it worked… Not sure why this didn’t work with the Generic device though…

Thanks for everything. If you guys are up north and want to see sunny florida I can keep the log in active :slight_smile:

Great! If you feel like it, you could retry with the Generic camera plug-in. That’s how I have it running with your camera. I did install it from scratch, as I only had the Panasonic one installed.

Now that it is working, I would edit the previous posts and remove/obfuscate the domain names, port numbers and other stuff that is specific and not relevant.



Now all i need to do is get my streaming to work :frowning:
anyone feel up for some troubleshooting?!?

[quote=“Henk, post:22, topic:167509”]@oTi@
Now all i need to do is get my streaming to work :frowning:
anyone feel up for some troubleshooting?!?[/quote]

if you guys feel up to a challenge, heres my info:

if needed ill set up a test account so you van acces it.

Replies to my challenge please in the appropriate (posted) thread

I have the following:

I have the following:

Url /image/jpeg.cgi
Username admin
Password xxxxxx

I still get “Trying to get image from camera”

Let me know what else to try.

[quote=“Dana_CMGI, post:24, topic:167509”]I have the following:

I have the following:

Url /image/jpeg.cgi
Username admin
Password xxxxxx

I still get “Trying to get image from camera”

Let me know what else to try.[/quote]

If yours is a D-Link like @aschwalb, you could try these;

Mine is a DCS-920

Hi Dana_CMGI,

Let’s try a few things on your DCS-920. Change one thing at a time, and then re-test, so we know what, if anything made the difference.

This is exactly what I’ve got (but check there are no spaces at the end of the text).

Username admin Password xxxxxx

This differs from what I use (I have added a user on the camera’s web management at Maintenance > Device Management > Add User Account), but I tested it with the admin password and it seems to work.

MiOS isn’t good at correctly escaping HTML-special characters, so if your password has non-alphanumeric characters, it might be sending the password wrong. Set your password to just alphanumeric characters while you do your testing.

I have the MAC address field set to empty. I don’t see how it could be interfering, but blank it out just in case.

Try displaying the image using a web browser on your computer: — does this (prompt for your admin user/pass and) display the image?

On the camera’s web management page (Maintenance > Device Settings), I have User Access Control = Enable; Snapshot URL Authentication = Enable. See if changing those settings one at a time makes any difference.

Hi Futle, im trying to setup my DSC 942L, do you know if this camera will works. Ive been trying several configurations with no luck. Any tips? Thanks

No idea, sorry. Probably it does, you will just have to experiment.

When you setup the 920 did you use dinamic DNS? O just the regular configuration?

Definitely not dynamic DNS. Either DHCP with a reservation at the router, or a static IP.

Futzle did you forward some port, or use upnp?

No, and no.

From the questions you are asking, you look like you think that my cameras are accessible from outside my LAN, over the Internet. They aren’t. My D-Link cameras are only visible on the LAN. If the 942 has Internet-enabled features then it isn’t anything I know about.

DDNS and Port Forwarding allow access from your camera on the internet.
DDNS helps you find your house. A Hacker does not need this. But Port Forwarding opens up a hole in your router. The problem with that is it’s trivial for hackers to find your device with Port Scanners.

In the US, I regularly see someone port scanning my IP looking for vulnerabilities.
Once they get past your router … it’s very easy to get at anything behind it.

IP Cameras, Your Router, (as does Vera) have a mini Unix Kernel. Many of these devices have default passwords or their default password is tied to their MAC ID which is visible to an Internet Hacker. From any of these Unix enabled device they can launch, or be controlled as part of coordinated attack on someone else. At that time all of the evidence points back to you!

What I am trying to tell you is that if you use anything less than an SSH or VPN tunnel to allow access to a device Inside your Home from Outside your house it’s like leaving your house door open with a sign outside that says free money, drugs, and bullets.

If you do not know what SSH or VPN mean … than you should definitely not be doing any of this!