cp.mios.com can't detect my Vera2 (1.1.1047)

My new Vera2 is starting to confuse me pretty much right now. When I first installed it with the older UI it was detected at findvera.com. Then I did the firmware update to 1.1.1047. I’ve read in this forum (lack of official manuals) that from now I have to use cp.mios.com, but it won’t recognize it.

“I didn’t detect a unit on your home network. If you have a new unit, please connect it as shown and when the Z-Wave light is on solid click ‘Continue’ and I’ll try to find it.”

Now I’m using the Vera as the first and only gateway. If I run “Troubleshoot network” in “Net & Wi-Fi” everything is just fine.

Anyone have a clue what’s the problem is? I would love to be able to remote it from outside my home. Thanks in advance guys!

Can you connect to it locally, meaning open the UI from the browser typing IP in the address bar?

Yes I can. Pretty much everything is working well locally. I can even remote control it with the android app Home Buddy through local ip-address . But I can’t get cp.mios.com to recognize it. No firewall/router/gateway in between. working just fine.

did you create a mios account?
Are you logging into Mios from the same IP as Vera? You must do this.
I don’t work with android. do you have access to a PC running windows I would try that.

I have created an account. I use the Vera as my gateway and my laptop have IP 192.168.81.x so it’s on the same network as the Vera. I even did a factory reset but can’t get it to work.

I’m now on another network and connecting to Veras external ip (80.xxx.xxx.xxx) and get full access to the Vera.

But still I can’t register the Vera at cp.mios.com when I use a computer on the same network as the Vera.

“I didn’t detect a unit on your home network. If you have a new unit, please connect it as shown and when the Z-Wave light is on solid click ‘Continue’ and I’ll try to find it.”

Update: Tried to solve the issue by disable the firewall, that’s why it was accessible from outside by it’s external ip.

did your vera come with firm 1047 or did you go to the site and do the upgrade?

I upgraded at ra2.findvera.com. Before the upgrade I was able to find it at findvera.com.

are u sure u are runnig 1047?
I thought a new VEra 2 were being shipped with UI-4 and UI-4 does not work or point to findvera.com

If you go to http://micasaverde.com/vera2
what happens Does the site find your vera2?

What isp are u using? is it DSL or Cable
What type of modem do you have?
IF you go into advanced , then network/ wifi do you have any errors?
What browser are u using?
This information is essential as I have not heard of this issue before.

Thanks for your fast replays. I will provide you with some screenshots etc tomorrow tuesday when I’m home.

I went home earlier so I could provide some more info and screenshots about my problem. My network settings seems fine. I have no clue why my Vera won’t be accepted at cp.mios.com.

Maybe I could try with a total reset again, but I can’t find any good documentation about doing that. Docs.mios.com just contains a blank page about factory reset and the procedure described in the wikipages have I already tried.

Screen1: My local ip from Vera dhcp server and a ping to www.google.com
Screen2: I click “my Mios” then “click here”
Screen3: Shows my problem

My Network troubleshoot log:

=== IP Configuration ===
br-lan Link encap:Ethernet HWaddr 00:C0:02:9F:90:10
inet addr: Bcast: Mask:
eth0 Link encap:Ethernet HWaddr 00:C0:02:9F:90:11
eth0.0 Link encap:Ethernet HWaddr 00:C0:02:9F:90:11
eth0.1 Link encap:Ethernet HWaddr 00:C0:02:9F:90:11
inet addr: Bcast: Mask:
inet addr: Mask:
wl0 Link encap:Ethernet HWaddr 00:C0:02:9F:90:10
Interrupt:2 Base address:0x5000

External IP:

=== Testing Gateway: ===

=== Testing DnsServer: ===


=== Testing External Servers ===



ts2.mios.com TUNNEL CONN:OK

fwd1.mios.com TUNNEL CONN:OK
== DONE ==

Have you tried a different browser to connect to Mios.com? Firefox as an example. AOL will not work.

UI4 will connect to the Mios server and not the FindVera server.


Your network seems good. The AOL thing should not be your issue as you were able to upgrade the unit. DO try using Firefox as the Web Developers write the script to conform to firefox first,then troubleshoot to other browsers.

I still wonder about the following?

  1. did you create a account at cp.mios.com . If you set an account at Find vera .com it will no longer work once your run the Newer UI-4 which is what you have.

  2. Is this a new Vera 2 never registered at MIOS? if this unit has been registered to another account it probably will not work with your new account. Call Micasaverde or set up a ticket.

  3. you can create a ticket by going to Advanced tab as you had before. then click on Tech support , fill out the problem. send.

Good luck

Let us know

I did send a ticket through my Vera2 as zmistro described in tuesday but still no reply :frowning: I’ll come back to you guys when I hear from them.

What have you tried so far.

what browser are you using. Use firefox

Did you create a user account at http://cp.mios.com ?.

Let us know

Just as Mhjens, I have the same problem: although Vera is accessible from direct IP, it is not detectable otherwise (not from cp.mios…, not from iVera, not from SquareConnect, not from the UI4 upgrade URL).

This is also happening since upgrade to UI4 (before which detection was ok…because I had followed the upgrade link that had detected by vera2…)

Have you created an account at http://cp.mios.com ?

Are you using the same internet IP that your Vera is using to log into Mios.com?

What browser are you using.

What type of internet connection are you using? Cable /dsl?

What modem

What provider

Is there any firewall settings , try releasing all firewall settings.

I have now created three accounts at http://cp.mios.com in desperation to get this to work. I have tried both through cable and wireless. Using my Vera as gateway/router who is connected directly to Internet (ETH1).

I have tried through Chrome, IE 9 and Firefox, same result (See previous screenshots) I have a fiber connection, so Vera is connected directly to the fiber converter via static IP.

Still no response from Micasaverde regarding my ticket :frowning:

Are either of you located outside the US?
I wonder if your ISP is blocking something. Have you contacted MCV?

I’m in Sweden. Did sent a ticket to MCV through my Vera. Did it monday or tuesday and still no reply. Will send an e-mail to them as well.