Correct usage of IP Device Generator plugin?

I have a digital photo frame like device I created that can be controlled by HTTP requests, so I figured this was a perfect usage for the IP Device Generator plugin. After installing the plugin, I went to “Create New Configuration” ad created a template for my device, which appeared to work well.

But now I’m stuck. No device was created, clicking the “+” symbol under “Create device” just pops up a window saying “There is no device created by this plugin”, as does clicking “Edit”.

So, how do I actually create a device with this plugin?

EDIT: I also do not seem to be able to delete a template - clicking delete, or publish for that matter, causes the buttons above the “Private IP device templates” header to disappear, but otherwise seems to do nothing. The template is DEFINITELY not deleted…

Wello @ibrewster,

Thera are some bugs related to this plugin that were reported to the dev’s team during this week and are being worked on, not being able to edit, create or publish devices as well as not being able to delete the template are some of the issues related to the bug.

The issues are currently open, and the dev’s team is working to fix them as soon as possible. We don’t have an ETA for when the issue will get fixed, so please stay attentive to the forum and the web UI.

Have a nice weekend and let us know if you require additional assistance.

1 Like

I noticed the latest ezlogic update fixed the issues with creating/deleting/etc devices using this plugin. Thanks! I am able to create a device now, and it shows up under Settings–>Devices, however I’m not seeing it on the dashboard so I can control it.

I set it up as a switch, so I was expecting it to show up as such. Did I do/expect something wrong, or is this a remaining bug?

Once you have created the IP Device Generator device, a switch in your case it should appear on the dashboard. Try deleting your browser cache or delete the actual dashboard database. You using Chrome ?

Also there is an old video guide about the Wifi Device Generator plugin if your not sure about how to use it fully? The UI may have changed a bit since it was recorded though.

Thanks for the suggestion, unfortunately it didn’t help. I wasn’t using Chrome, but rather Safari, so I went ahead and tried Chrome (which shouldn’t have had a cache, since I hadn’t used it for this), but it didn’t show up there either. I then (still in chrome) tried a shift-reload, as well as following the directions in that other thread to delete the dashboard database, with no luck.

Then, back in safari, I tried a) a shift reload, b) empty caches and reload, and c) deleting all entries in the “storage” section of the debugger, again with no luck.

Not sure then. In past when I last tried it the new IP device just appeared in the dashboard.

You have created the new device right ? Not just created a template.

Yep. As I said, it shows up under Settings–> Devices, just not on the Dashboard. :man_shrugging:

Which would seem to indicate that this is another bug (unless it is still working for other people, just not me), perhaps related to whatever made it impossible to create a new device or edit/delete templates.

Course, when I try it now, the dashboard isn’t loading at all… I’m sure that’s temporary though! :grin:

1 Like

Hi @ibrewster

Let me walkthrough the usage again:

1- First visit the plugin page from the Integrations menu

If the plugin is not installed in any of your controllers then you will see a page like this.

2- Install the IP device generator plugin from marketplace

3- Now re-visit the “IP Devices” page under Integrations

And now you can Click “Create Device” Icon next to the template you want to use.
In this example I will use “Shelly1” template, which allows you to create a switch device controlling a Shelly1 switch in local network.

4- Configure IP address and port numbers . Unnecessary fields from this page will be removed in the next version of the plugin.

Click “Create Device”

5- You should see the device created in your Devices page

And since this is a standard switch device, it also appears in the dashboard as well

Ok, so I completely removed the plugin and re-installed from scratch. This time through, though I could swear I did exactly the same thing, it worked as expected. Maybe it just needed a clean start? :man_shrugging:

In any case, thanks for the suggestions/guide!

Follow-up question: how can I periodically get the status of the device, such that if it changes due to other means (such as direct HTTP calls), the device status gets updated? Is that something I can add to the template?

I’ll do some more digging there, see if I can figure it out as well.

Thanks again!

Hi @ibrewster

the device category and subcategory selections(1) only apply to device UI on mobile and dashboard.
And the capabilities list (2) is independent. In the capability list all capabilities other than the switch capability are sensor device readings and they all have poll interval option

Unfortunately I was unable to figure this out. I looked over the list of capabilities, and thought maybe power was what I was looking for. However, that seems to be related to power usage not power state. So I’m not seeing any option in there to poll the device for current state.

Specific usage: I have a home-made digital photo frame type device that I would like to be able to put to sleep/wake up. I can accomplish this using the “switch” capability to send the proper HTTP command to sleep/wake the device.

This works well, but I also need to be able to poll the device to see if it is currently awake or asleep in order to make sure the virtual switch matches the current state of the device. For example, if I used the virtual switch to wake up the device, but then used some other method (not ezlo related) to put it to sleep. The virtual switch would still be showing “on” even though the device is “off”, meaning that I would need to first turn it off on the ezlo dashboard before I could turn it on for real.

This is where I am currently stuck: how to check the current state of the “switch” to update the virtual “switch” correctly.

Surely the photo frame would need to be able to support a http command to query its current power status and for that value to then be stored in a variable in Ezlogic or something ?

Or maybe you can use a ping / wol instead to determine if the photo frame is awake or not ?

Sure. Since this is a home-grown device, I can make it support any/all http commands I want it to - including one to return the current status. That’s easy.

Sounds reasonable - how? Presumably at that point I would just set up a meshbot to set the value of the virtual device to match the value of the variable (unless there is a better way?)

Perhaps “sleep” is a bit of a misnomer here, I guess. Only the display sleeps, so it still responds to pings/network requests - that’s how you wake it up, after all - by sending a http “wake” request :slight_smile:

Hi @ibrewster
you are right, we definitely need a polling feature for switch capability for that.
We have the polling for sensor type of capabilities bu not for switch. Let us add this as well shortly.

1 Like

Created ticket for you Log in - MiOS

1 Like

Perfect, thanks.

BTW, thanks also for making this plugin. I’ve been controlling the device by using HTTP requests in the actions section of scenes/meshbots (depending on what device I’m controlling it from), but this plugin will make things much cleaner/easier. Kudos to the development team!


Not sure if there are other ways to do this, but here is a Meshbot rules action that runs a http command to get my WAN IP address and it stores it in a variable called “myIP”.


Ah, perfect. Then I can just set this meshbot to run periodically, with another meshbot that watches the variable, and sets the virtual switch whenever it changes (unless there is a way to combine the two, such that a single meshbot runs the http request, gets the value, and if it’s changed, does something in addition to storing the value? That’s probably asking too much… :crazy_face:).

Sounds like a reasonable workaround until they get polling implemented for the switch capability. Will mean that if I put the display to sleep elsewhere, that it will get an extra “sleep” command as this meshbot fires off, but that won’t hurt anything :slight_smile: