Controller Offline ? ? ??

So ever since the update a couple of weeks ago, my controller now says Offline when I try to log in on my computer. I am still able to use the app on my phone to control everything and my scenes are still working for the most part but now I cannot add any other scenes etc. Tech support responds to my emails about every 5th day so that is getting frustrating, then they didn’t call when I asked them to so again…FRUSTRATING. Figured I would post here and hope for some help. Their original email told me to go to the IP address and see if I could reach it which I did. They then asked me to enter a couple of lines of code at the Test LUUP but it would not accept any commands. They also asked me to enable the customer support control but it would not change to enable from disabled. I tried the commands in the web browser to change it to enabled and that also would not work… I have unplugged and re-plugged numerous times hoping that one of these times it might come back online but still nothing… Any suggestions would be greatly appreciated. Thanks.

Hi, Will.

I’ve asked the team to make sure they are on top of this matter. Thanks.
They’ll get back to you ASAP.

Any updates on this? I cannot upgrade my controller (and access backups) until I can login to my controller.

trust me I have seen it all and I have been through it all. so the symptoms are synonymous with what happens when my Vera runs out of space. Try running these under develop apps > test luup code

–Clear Memory run one at a time
os.execute(“rm -r /overlay/etc/mios_backup.info.old”)
os.execute(“rm -rf /overlay/etc/cmh/ergy* && rm -rf /overlay/etc/cmh-firmware/mios* && reboot”)

1 Like

you may have to do a factory reset the do a restore

if you have a vera plus extroot it

I am kind of an amature when it comes to this. I love tech, but I only know just enough to be dangerous with the stuff… I tried doing the Test Luup stuff advised from VERA support and it would not even accept any commands. I ended up having to do a phone support with them and giving them control of my computer in order to basically wipe/reinstall or at least while I was watching, it looked like that is what they had to do. Now it is back to perfect working order, actually it is now working better and more reliably than previously. Thanks for the help though.

no worries, but yeah it seems like it was a space issue

Got some help from customer support, turns out you’re right. This “controller offline” is a huge red herring since it’s not able to make a connection largely due to a file that needs to be created to establish the remote connection.

For some reason they decided this critical file should reside on the same shared volume as plugins, so you can pretty easily fill the 128 megs with plugins like ALTUI.

vera extroot … run it on an external ssd - it will change your life

1 Like

I also have the “controller offline” problem in my Vera Plus for some days already.
What is “Vera extroot”?
I don´t understand the words: “run it on an external ssd - it will change your like”
Help, please. creyes

Hi there,

I highly suggest contacting our Customer Care team first, to have a look at the “controller offline” issue.

They can be reached via email, toll-free phone call or web form: https://support.getvera.com/hc/en-us/requests/new

I got this “controller offline” situation as well and mobile app just says “controller is busy updating data”. Running the latest firmware on Vera Edge and this problem seems to coincide with setting up USB logging

usually boils down to space

well, I have still 3.7M space left on rootfs

Thanks Sorin. I´ll do as you suggest.

How do you run this if you cannot connect to your controller (i.e, “Controller is offline”)?

connect locally

Seems I have a similar problem, the getvera portal portal alternates between “controller offline” and “connection ok” . It cycles between offline or online every 30 seconds each time the web page refreshes as the portal is “checking controller status”.
I can login using the local ip address and vera is good locally, but the portal just alternates online then offline then repeats every 30 seconds.
I have run these commands to free up memory, and the problem remains.
os.execute(“rm /etc/cmh-firmware/mios*”)
os.execute(“rm -r /overlay/etc/cmh-firmware/mios*”)
os.execute(“rm -rf /overlay/etc/cmh/ergy_cache_paired_devices.conf”)
os.execute(“rm -r /overlay/dataMine”)
os.execute(“rm -rf /overlay/etc/cmh/ergy*”)
os.execute(“rm -r /overlay/etc/mios_backup.info.old”)
os.execute(“rm -r /overlay/etc/cmh/alerts.json”)
os.execute(“rm -rf /www/dm/”)
os.execute(" rm -r /etc/cmh-zwfw/*")
os.execute(“reboot”)

Any ideas of what I can do next? I’m running the latest firmware. This problem is interfering with Alexa, the vera phone app, and remote access.

These codes are to free storage space on the vera and have nothing to do with your problem and not effective/needed on the latest firmware. What you are seeing are likely either network outages or cloud server overload/outages.

I thought it might be the server, but tech support told me to clean the memory.
The getvera portal has been alternating between connected and offline on a 30 second cycle for the past week, so it doesn’t seem like its going to resolve itself.
Locally, vera is on a solid uptime fiber network, so it’s unlikely the problem is with the local network. I’ve rebooted vera (several times), cleaned memory, restarted the local network routers and switches, etc. The problem seems to have started when I updated the firmware.
Is there any way to force vera to change servers? Any ideas at all are appreciated.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules