Can't Arm my HSM100 Sensor through Findvera

Ever since leaving my weekend home today, I’ve been unable to re-arm my HSM100 motion sensor through Findvera. The command blue swirl continues for about 15 seconds and then I receive a “Returned Empty Reponse” error. Anyone have any ideas what might be going on? The sensor was functioning just fine before, and I’m able to use Findvera to control all my other devices with no problem.

Hard to say but just reviewing the basics, how long has it been working before? Are the batteries tired? is it in a cold area (reduces battery capacity) ? is the distance to nearest relay marginal or close? Is it correctly reporting other data (temp/light/motion) Many (including myself) have had similar problems when the sensor is not in vera’s direct range though (knocking on wood) mine have been working quite reliably for some months now (only one is out of vera’s range)

Mine seems to do this randomly and currently I can’t even Arm it locally (it shows ARM but the “Green dot” is red)
Try EXCLUDING and RE-INCLUDING, but Im still struggling with getting this to work perfectly. It’s all hit or miss and Im really not sure what the issue is. Can someone that has this working perfectly upload a screenshot and all their advanced config settings?

If you’re not on location, you won’t be able to move the sensor close to Vera, which is my personal cure-all for these things. Here’s my config which arms and disarms both manually and in response to a scene timer. I hope it helps.

My sensor is within a foot of Vera, now that vera is in wifi Client mode, I moved vera closer to the sensor and still shows a RED LIGHT 100% of the time.

thats just the problem I used to have (light would stay red once tripped) even though the LEDs on sensor seemed to indicate that it was resetting normally, dont know why but they are working great now ???

Thanks for the settings screenshot, but Im more looking for the device settings (wakeup time, polling time, and Advanced Z-Wave flags you set for the device, such as parameter#2 set to 5 (min), etc

I excluded, re-included, tried ALWAYS ON mode, tried wakeup of 6 min and no matter what, my sensor seems to be stuck in always on mode and just NOT working. Any advice from someone at MCV or someone that really knows this sensor would help. I did notice last night that when I reincluded it and setup a scene to turn on some lights on motion, it was green but not tripping. I clicked the blue button and the scene activated when I did this, but its never gone back to green since!

Right. The “parameters” (Express Controls terminology) are shown in “Variables” (MCV terminology). Here’s the variables jpeg from my other sensor. Hope this helps.

Thanks, that helps but can you post your CUSTOM Z-WAVE SETTINGS screenshot for this device?
I’d like to see how your variables look in this screen and try to replicate. Mine works fine when I remove and re-include, but as soon as I try to add a CUSTOM Z-WAVE setting for Always ON or other option it stops working

One for each of my HSM100s.

Seems like every since I put my HSM100 in Always Awake mode a few weeks back that its been screwy ever since. No matter what I do I can’t seem to get rid of this setting. Any idea on how to reset it completely? I’ve excluded and re-included and each time I do this it seems to trigger a scene ONCE and then the light on the arm/disarm never goes back to green.

If anyone out there knows this sensor and all modes that would be helpful, the manual has all the variables but Im not sure how to get it back into NOT Awake (default) mode. Powering off for an extended period and excluding and re-including isn’t doing it for me!


did you post your custom settings so we can see them?

I had the listening flag set and it was in Always awake mode, it just doesn’t work with Vera in this mode, so I’d avoid it. Once I set the parameter 5 to 0 and configured the sensor, it worked again.

Has anyone gotten this working in Always Awake mode? It never seems to rearm with a green light, but it’s very useful for getting temp and light readings every 60 seconds. I guess I’ll have to live with every 6 min

My settings are now

parameter 2 5
parameter 5 0 (default)

I’ll mess with sensetivity and other stuff now but staying away from parameter #5

thanks for all the help!

Not exactly sure how or why, but my HSM100 is now functioning again. I was finally able to arm it through The only thing I think I did was I poked around in some settings for the motion sensor, without actually changing anything, but enough to make it ask me to “SAVE” my changes. When I did so, it tried to configure the HSM100, which it managed to do after a few minutes, and now it seems to be fine. So perhaps all it needed was to be configured to snap it back into shape. Who knows…sometimes I just give up on figuring these things out :slight_smile:

Sorry to bring this month-old topic up, but this same confusion been popping up around the forum too often lately, so I wanted to clarify:

The green/red dot next to Arm/Bypass buttons IS NOT the indication whether the sensor is armed or not! It shows the current tripped state of the sensor - Green=Idle, Red=Tripped.
The only indication whether the sensor is armed or not is to check which button (Arm or Bypass) is highlighted in blue.

Pretty much all sensors go from green to red (i.e. tripped) almost instantly - motion detected, door/window open, water leak detected etc.

But going back from red to green (i.e. “untripped”, reset or go back to idle) is another story. Some sensors need to be manually reset (water leak sensors, like FortrezZ), some get untripped instantly (door/window closed) or some take time to idle-out (motion sensor when it does not detect motion for some period of time, like 20 minutes by default in HSM100)

Would be nice to put it somewhere on the Wiki, so new people don’t get confused…