Button Press event - WDHA-12?

Happy new year.

I just purchased a Wayne Dalton WDHA-12 gateway. Looking around on the forum and elsewhere, I see the note that ‘Vera needs to be configured so that it interprets the WDHA-12 as sending “Button Presses” instead of “Scene Activation” events.’ but I don’t understand how to do this. Can someone provide the steps necessary?



with new firmware that is no longer necessary, very will automatically configure the scene controller/gateway properly. Just add wdha-12 to vera, add button triggers to the scene you want them to activate then usually you have to tell vera to add zwave controller again and tell ur wdha-12 to become 2ndary controller. Btw Vera will still show your wdha-12 with red cog, (unable to configure) but the buttons will trigger appropriate scenes. After that you can usually add new scenes and they will work without re-adding wdha-12 but if they don’t tell tell Vera to add zwave controller again and go through the process of making wdha-12 a 2ndary controller again.

Thanks Axan. I’ll try that. How did you know this?


it was posted when one of the new luup firmwares came out + I actually have wdha-12 plus few other controllers (Ha07C, HA09C)

I haven’t tried adding the WDHA-12 with the latest firmware, but search the threads for how to do this. I had to add it twice to get it to work. Don’t know why, but it’s a common occurrence.

most controllers need to be added at least twice. No idea why but that was the case with few I use.

Well I haven’t been successful but I may still not be doing the right thing.

First off, I do know that WDHA-12 and Vera are working together because I have also hooked up a WD zwave light dimmer and that works fine. In this scenario, I am using Vera to send a command -to- the WDHA-12 to turn on/off/dim the light. All good.

The scenario where I’m having trouble is the reverse where I’m trying to get WDHA-12 to send a command -to Vera- for my Schlage lock. I don’t know how to do this. I have WDHA-12 showing up as a scene controller and I have also created a scene to lock the Schlage. What I don’t understand is how to have the WDHA-12 trigger the scene on Vera. Descriptions as to which specific screens and what do to on them would be very helpful.

Thanks again,

Charlie, I may be doing this backward, but this is what I do.

I build a scene called ‘Button 1’.
I added an event called ‘button 1’ with device ‘scene controller’ and event type ‘a scene is activated’
When it asks what scene number, the buttons are scene 1 or 2 or 3.

(I found the hard part was syncing the buttons in my car to the WDHA-12.)

Then I added the commands for that event.

I don’t have the lock (yet), but this turned on my Christmas lights when I pressed the button.

Hopefully there is an attachment that makes sense here.
update with attachment.


The error saying that folder is full was resolved. It should be enough for 1000 <= 192kb pictures/attachments.

Hi all,

Since I had so much trouble getting to the point where this was working and I got valuable help here, I’ve drafted some detailed instructions that others may benefit from…and it would be great if someone here would review them. Any takers?

After review, is there some way to get them posted on the Wiki?


[quote=“LVince, post:8, topic:165346”]…

(I found the hard part was syncing the buttons in my car to the WDHA-12.)


I’m not clear on the WDHA-12. Sounds like i CAN use it to take ‘homelink’ commands form the garage door buttons built into my car and translate them into z-wave scenes.

I’m i understanding it?

I thought i needed their X10->zwave bridge but sounds like i can just use the WDHA-12?

Yes, the WDHA-12 is a gateway between any homelink controller and Vera. Homelink sends a command to WDHA-12 which in turn forwards it as a scene activation command to Vera.

ohhh- i NEED that. ;D

just dont tell my wife…


Nice job on the write-up on the wiki. Very clear and professional.

Thanks @charlie for the writeup, I just ordered one of these to attach a “startup” scene to the 2nd button in the wife’s car for when she gets home.

For anyone following the threads, the Wiki page is located here:


thanks for the wiki page- was GREAT.

anyone know why this is? (the red cog - unable to configure)

vera bug specific to the WDHA-12? vera bug with all secondary controllers? or something wrong with the WDHA-12?

exellent job, this kind of documentation is so helpful! 8)

Has anyone been successful getting this to work in UI3?


The red cog is a normal finding… it remains red in Vera because this is a battery operated device that does not get polled on a regular basis. This would drain the battery if it was getting polled all the time.

I think it is a problem with all the secondary controllers because they do not pair correctly with Vera. All of my previously created scenes (Via UI2) still work fine in UI3…but I can’t seem to get it to program new scene associations…hoping MCV gets back with me on my open ticket here soon.

Hope this helps!