Hi Richard
great work on the updates! it is so much more stable now, and working well.

i see you added broadlink support and i’m excited about that since i have a couple of broadlink devices
is there a how-to section on that yet?
i tried to press the button for discover broadlink devices but its not finding my broadlink rm3 … is it because its on a different subnet? is there a workaround for that?

also, is it possible to shorten vera concierge to vera? it would be so much easier when giving commands.


Broadlink uses UDP datagrams and UDP broadcast protocols … so you need to be on the same subnet.

My Plugin has not been accepted yet … until that is accepted (submitted early last week) you will not be able to use Vera to send commands.

My Vera Plugin is now available.
My plugin works with the Vera Concierge Local Server.
You can now Record your IR (and maybe RF commands) via the RM
And use them in scenes or actions in PLEG.
The next step is to add voice commands to Vera Concierge.

will it work as a stand alone with VC?

I am not sure what you mean by working stand alone.

My plugin requires the Local Concierge Server to be running.

Do I need to be using VC with Google Home/Mini to access Broadlink?
As I don’t have a google whatever (yet), I’m not sure if it is needed to make your Plug In work.

  1. With just the Local Concierge Server (no other compoents) you can:
    Via the Local Concierge config page:
    Goto the broadlink page.

    You can discover RM devices, Learn Codes, and Send Codes.
    I have not tested learning or sending RF codes because I do not have an RF device.

  2. If you want to use these in a Vera Scene or PLEG:
    a) Configure the Account Information in the Config page of the Local Concierge Server
    b) Do the connectivity test.
    c) You do NOT need to update the Cloud information, that’s only needed for Google Home/Google Assistant functionality.
    d) Install the “Broadlink Vera Concierge” vera plugin.

When you want to send commands to an RM device using an Action from the above plugin you need 3 arguments:
a) The Broadlink Device Name (set from the e-Control mobile App, i.e. something like “Living Room”)
b) The Folder Name (from the Local Concierge Server Broadlink page, this is a collection of codes i.e. something like “Samsung TV”)
c) The name of the Code (from the Local Concierge Server Broadlink page, this is something like “Volume Up”)

Thanks for the detailed explanation.

just got a broadlink rmMini3 to try out this capability but could not connect to my wifi network due to a 32byte password length & no special char limitation.

Does anyone know if the RM2 Pro has this same limitation or not?

(Note: same question was cross-posted to the broadlink plugin thread, but that’s cybrmage’s, not Richard’s plugin)

UPDATE: Question answered in another thread - RM Pro has the same severe wifi password limitation.

Hi Richard,

First off all, thank you for creating such amazing plugins! I’ve got licences for Vera Proximity and PLEG and loving them to bits…

Am trying out Vera Conceirge now, am able to control devices via Google Home and learn/send IR commands using the broadlink. I am however unable to see the device created by the Broadlink plugin in Vera Scenes (I do see it in PLEG tho)

Configure the Account Information in the Config page of the Local Concierge Server - done!
Do the connectivity test. - successful bi-directional
Install the “Broadlink Vera Concierge” vera plugin. - also done. I went as far as to restart engine and rebooting vera but still don’t see the broadlink device in Vera Scene (as trigger nor action).

Am I missing something? Appreciate your kind guidance please. Thank you.

You would need to use the ADVANCED mode in scenes to use this functionality.

Now I see it! Will give this a try… Thank you!

or just use the luup code

luup.call_action("urn:rts-services-com:serviceId:BroadlinkVC", "Send", {RMDeviceName="<blockquote>**Device Name**</blockquote>",RemoteFolderName="<blockquote>**Folder**</blockquote>",CommandName="<blockquote>**Command**</blockquote>"}, <blockquote>**device  number**</blockquote>)

Advanced editor in scenes worked fine for me as well. Some notes:

  1. Initially I had not named my RM PRo via the e-Control app, and when it was discovered by concierge it came up all question marks - gave it a name and ran discovery again and that was fixed,
  2. I found commands weren’t working from Vera, but when I clicked on 'Remote Control Panel" I found that there was nothing there (well a folder but no commands). I had recorded one remote control, but had a second I hadn’t saved commands to which I think was confusing things. I deleted the folder with no commands in it and suddenly the remote control was populated and my scenes worked.

FWIW I setup a virtual switch, and have two scenes (on and off) that are triggered by the switch.

…and FWIW I am now experimenting with RF control. I had found that on discovering my device, it recorded it as “DevType 9863” and not supporting RF. I just edited “BroadlinkDevices.json” to say

"SupportsRF": true

and then the Learn RF button appeared, but although it appeared to be trying to learn it was not able to save RF codes from my remote (maybe it’s not doing the full “sweap frequency”?).

I was going to give up then, but decided to try a little harder. So I then used the ?e-Control" app (not ?eWeLink?) to record the codes from my fireplace remote. Tested to make sure that they worked from the app, and I then used ?share? in the app and, ?share to other phones in WLAN?, and then opened a web browser to http://my mobile address:48815/ to download the data. I then got the python script from, installed simplejson on by raspberry pi (apt-get install python-simplejson), copied the script and e-Control data files onto the pi and extracted the codes. In my case they were (to turn my fireplace on):




to turn it off.

I then created a fireplace folder, temporarily recorded two commands using IR, then edited the BroadlinkCommandSets.json file so that “Type” was RF and changed the code to match the code that I’d discovered, and… didn’t work. Ah well, worth a try. :wink:

yeah its not learning any RF codes

…so got my second RM Pro and now I have two devices - one (433 only with temp sensor) DevType 9863, and the new one (433 and 315, no temp sensor) DevType 9885. Both are showing SupportsRF as false. I can manually change that to true, but it resets if I do a discover devices.

Have now tried to control 433 and a 315 devices by manually editing the BroadlinkCommandSets.json file, with no luck. Works fine using e-Control. Interestingly with the current (2.029) version of Concierge, after modifying SupportsRF to true the record RF button doesn’t appear any more.

My best bet is that the Broadlink device is not being identified properly (hence not supporting RF) and thus it’s simply not working. Ah well. As Richard has said before, RF support is a ‘work in progress’.

so the Record Rf button appears after modifying the file but doesnt work - it puts the RMpor into rf search permanently i have to reboot the unit in order to get it to work again

Just got a Broadlink RM Pro-e today and ran into some issues when trying to get it up and running via Vera Concierge, so I figured I’d sign up and leave a comment to let others know what made it work for me.

First, the Issue:
I connected the RM Pro-e to the e-Control app on my phone, created a remote and recorded some signals to test that it worked. It worked fine with the app but when I added it to Vera Concierge and pressed “Record IR” nothing happened, the LED that indicates that the RM PRO-e is ready to learn a signal didn’t light up and eventually I got a timeout message in Vera Concierge.

I can’t say for sure what of the following was the fix but this is what I did; I went into the e-Control app and renamed the device from the default name which for some reason hadn’t shown up in Vera Concierge (it showed name as ? ? ?). Then I rebooted the RM Pro-e and pressed “Discover Devices” again in Vera Concierge and when it showed up this time it had the correct name and when I asked it to record IR the LED on the RM Pro-e lit up and the signal was recorded, Success! :slight_smile:

the same thing was happening when I just got mine but I actually went into the JSON file and manually renamed it – by default it comes named with some Chinese name – renaming it probably was a good thing

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules