Beta feedback Ezlo Atom v2

Hi guys,

The Ezlo Atom v2 are on their way to some of the Beta testers and is time to create the space fo gathering the feedback.

Please use this post to report any bug, improvements, problems etc. you encounter with the Ezlo Atom v2.

Happy testing!


Hello Ioana
Thank you for the current shipment of Ezlo Atom V2
I can’t read the Beta Test Guide Atom.pdf document in Anna’s email.
Can you publish the URL of this document here?

Thank you so much

Ezlo Atom V2 arrived today.
First issue unable to connect to Atom , i have connected to it access point but that’s all no other buttom to press and the screen does not change once connected.!


tried with another device, now i am unable to login with any controller, as it seems the new system only allows 3 attempts then locks you out of all controllers.

open settings opens

not wifi.

Beta Test Guide Atom.pdf (62.5 KB)

Hi @ElCid. Could you please share your phone’s Android version? Did Vera app asked you location permission?
For the Atom Discovery to work, the app needs High Accuracy location permission. Please set in Settings → App permissions, location permission for Vera to the highest possible one, and turn on Location to High Accuracy, and try again please.


Adding the Athom2 to a new account worked fine. One thing I noticed using the API tool is that the location information is not stored correctly. That values are way of my location, not even in the same continent.

As before starting the App takes quite a bit of time looking at the rotating wheel (15-30 sec). Last in the Device view it takes long before the devices show (with only one or two devices), and the app becomes unresponsive (no response when trying to change the view (Room/type/list). This may also be an issue with the latest App version .464 as it now happens with my Linux Edge too (not with Veras’), and I did not see it before.

Including supported device types works fine. With one I had to add as generic not so.

Cheers Rene

the android version is 8 and the device is a tablet asus

the image i posted is of the window that opens when you press open setting button.

i have enableed high accuracy and connect to access point still no further

Ok @ElCid , it’s a weird behaviour for the “Open Settings” to open the location settings, we will look into that. After you press the “Open Settings” button and it opens the location settings, could you please go to Wi-Fi list and connect to the Atom v2 Wi-Fi, then go back to the Vera application. It should detect that it is connect to the Atom Wi-Fi and present you with the Wi-Fi list detected by the atom.

Yep i already tried that multiople times and in different ways.

No luck

So,after you go back to the Vera app, what does happen? Can you try another Android phone to do the onboarding?

Maybe you could add a button to open wifi selection manually?

This is my main device that i wish to use as it has the biggest screen , As i said earlier when i tried to login on another device(wish i could have the password of my choice) i could not remember my password so can not login. If i goto forgot password i would have to change my password again, and possible lose the only device that is currebtly logged in.

Ok,i’ve checked some code, it will open the Location Settings in case the location mode is not set to GPS/High Accuracy. Please change the “Mode” from “Battery saving” to the next one.

As said before i have set high accuracy (note this device does not have gps)

OK @ElCid. Understood, then there is a bug in our app. I will pass it to the QA team and we will fix it asap.

i will attempt with my phone if i can recall the password

Managed with phone but device restricted.
Controller led flashing blue once/second.

I can not remove controller even when i select yes to permanently remove the controller.

I have to say at this point if i purchase this device, i would be returning it from whence it came.

Well, that’s the whole point of a beta, of course - to find issues like these so they can be fixed! :slight_smile:

Thank you for informing me what a beta is for.

Managed to connect, but now stuck here

Device is still flashing 1 per second.
Will attempt a restart of the Android device now, and then try reinstalling.

edit/ Ok restarting did not help.
Uninstalled and reinstalled did not help.
Still stuck on the choose controller page.
I can choose the vera and all is good, but unable to choose the atom.

@oleg.macovei still can not get past choose controller. I have delete and factory reset multiple time. I can not test further until i can connect to controller.