[Another] VeraPlus bricked after firmware upgrade...

I just joined the club of Vera users that have a bricked unit after trying to upgrade my VeraPlus. I was hesitant to upgrade but Vera Support provided the procedures which I followed. Was trying to upgrade from 1.7.1786 to 1.7.4001.

Very Frustrating! Really Vera?

I am guessing the VeraPlus is continually rebooting as I am able to ping it successfully for about 10 secs every ~40 secs. Unfortunately, the VeraPlus is not stable enough to be able to ssh into it.

Anyway to reflash the firmware?


Welcome to the club.

Hello Joe,

I’m really sorry to hear about this :-\ . However, you should be on good hands with our colleague that is currently handling your ticket with us.

Mine is not bricked, but it might as well be as I cannot add or delete zwave devices. Everything was working just fine until the system starting dropping devices for no apparent reason. I was having the most problems with an Everspring temp/humidity sensor do I thought I would delete it and rea-add. Apparently that was a really bad idea. When I tried un-pair the device Vera deleted the entire zwave network. I was able to recover the system from a backup, but the problem recurred every time I tried to add or delete, so I opened a ticket with “Customer Care”. The following is reply/explanation I received from Vera “Customer Care” in response to my support request:

Thank you for contacting Vera Home support.
I?ve checked the unit and I was able to find the root of the issue and the unit seems to use these Z-Wave settings :

HouseID/Node: House: d0977eb3 Node 1 Suc 9
Role: Master SIS: YES PRI: YES

In order to have them correctly you must do a Reset of your Z-Wave network (this will wipe all your Z-Wave devices and all thats related to the Z-Wave chip only) and the you?ll have to pair the device back one by one. This situation happens whenever you transfer from an old version of Vera unit (2 ,3 and Lite ) and the unit keeps the settings from that unit. It will be in your benefit to do this also because you will gain a fresh Z-Wave mesh.
Please bring the device closer to the controller , we suggest within 2-3 feet , and set the controller in Exclusion mode first ( Devices > Add device > Generic Z-wave device > Next > Next (wait 5 seconds) > Retry ) , then do the exclusion procedure on the device ( you?ll find the steps in the user manual or on the manufacturer site ).
After that please set the controller in Inclusion mode ( Devices > Add device > Generic Z-wave device > Next > Next ) and do the same steps as for exclusion ( but you can find the steps to be sure on the user manual too)
Please know the fact that if the device is too far away from the controller the range of communication is affected and if there are walls or other devices which can interfere the controller will lose the communication with the device.
Have a great day!

I don’t necessarily accept the explanation because I upgraded from Vera3 to Plus “long ago” and successfully added and deleted many zwave devices until this recent issue occurred. I have 30+ zwave devices, many of them “hard-wired”, making a complete rebuild of the system a big/all day job. I explained my situation via email and the rep agreed to “escalate” my issue. After not hearing back from support for several days I opened a follow-up request via the web and re-enabled remote access. Apparently it was unreasonable for me to expect to “hear” from support before they undertook any potentially destructive work on my system. When certain devices were not working I went it to check and found 4 devices were now"zombies" - generic I/O with no room assigned. I was upset that no one had contacted me, but I had a number of items on my calendar that prevented me from calling support. When I had a minute I checked again only to find I now had 11 “zombies”. Having spent 30+ years in IT, including more than 20 as CIO, I cannot believe a technical support group would access a customer’s system and make destructive changes without ever consulting with the customer. Since I have critical functions that depend upon the Vera, I reloaded a back-up from a couple of weeks ago. I have the system back, but still cannot add or delete zwave devices. I still have not heard anything from support. Next step is to contact support and ask to speak with the manager.

Definitely not the way to run a railroad or a customer support organization.

@retireditguy - I’m really sorry to hear about what happened. Our agents always create a backup before they do any changes and after and they can always revert but as you reported, with the original settings, you have your devices back, but you cannot add any new devices.

And that’s because of the migration you’ve made a while back when you’ve upgraded from Vera 3. We are trying our best to restore your setup given certain limitation between platforms and z-wave versions. Sometimes works like a charm, sometimes issues like your pop-up.

Please re-enable customer care remote access as requested by our agents in their last reply two days ago, so they can attempt restoring your z-wave settings.

We look forward to hearing from you.

Sorin -
I owe you and your staff an apology. After you indicated your staff had sent me emails, I checked the email SPAM filter. For some reason addresses that were previously being accepted without issue were suddenly being stopped by AT&T/Yahoo’s filters. So it appears it was AT&T/Yahoo who made changes without notifying its customers, NOT Vera Control. As I noted I restored a previous version in order to get Vera functioning again. I believe I took a backup of the “broken system” before I did the restore. If your staff wants to me to restore that backup, please let me know. I will enable remote access and place the access code in an email back to Cristina.

I really appreciate your reply. Thanks.

I’ve been holding off with replying here because I am stilling dealing with issues with the VeraPlus. A very frustrating experience [a lot of us know what it’s like from personal experience].

It turns out the VeraPlus is not bricked. Although, Vera Support thought it might be bricked and had to escalate. While waiting for Support to respond I was able to get the VeraPlus stable by successfully applying the latest firmware. Since the VeraPlus was continually rebooting, the new firmware has to be downloaded and applied before the next reboot - repeat the download and applying the fw until the new firmware is successfully updated. Support could not apply the firmware remotely for over an hour of trying, so I tried on my own and had success by putting the fw on a local web server (download was very fast so had more time to apply the new fw).

Now the VeraPlus is not rebooting and on latest firmware, but is having zwave issues. If I add/include a new zwave device, then VeraPlus loses ALL the zwave devices - no zwave devices show up in the GUI. Reset factory defaults, restore from a backup to get the zwave devices back. Ultimately, the problem still exists even after the factory reset and restore. Support says it because the backup is corrupt.

Vera Support says all my backups are corrupted and don’t have zwave configuration. Therefore, it’s starting to look like I will be completely starting over by wiping the VeraPlus. Like to know why all my backups are corrupted? There should be checks put into place to ensure the backup is valid.

This is my first experience using Vera Support. I must say that what others say about Support is true. Slow to respond - sometimes days to respond.


Joek -
Your situation sounds very similar to mine. After reloading a backup the system is stable but I cannot add or delete zwave devices. When I try to add or delete Vera wipes out all zwave devices. Acts very much like Vera is resetting the zwave network/chip. I have over 30 zwave devices, most of them “permanently” installed so a rebuild will be very time consuming. Hopefully Support can figure this out. It surely appears to be a software/firmware problem.

Sorin -
I have not heard anything back from “support” regarding my problem - inability to add or delete devices - since December 26. I sent several emails asking for updates, but never received a response. I checked email SPAM folder to ensure any responses are not being trapped. Would you please check on this and ask support to respond?

Hi there, so sorry to hear about that. Giving the guys a heads-up.

I have been using a Vera Edge for some time, but am awaiting the delivery of a Vera Plus which I just ordered. However, I just stumbled upon this thread that gives me much concern about following through with the upgrade. I have a large number of Z-Wave devices, of varying brands mostly all hardwired, as well as multiple scenes configured. Does the sum and substance of this thread mean that if I try to upgrade to the Plus model I will need to totally reset and reinstall all my Z-wave devices and scenes? Any advice on this issue is appreciated, and absent some assurances that it can be efficiently accomplished without a reset and reinstall , I will most likely return the device rather than take a chance.

@mpress, quite an old discussion here. Most of the issues that have caused VeraPlus to go haywire after the firmware upgrade is with setups migrated all the way back from older Vera platforms like VeraLite and Vera3. If you’ve started with VeraEdge and just want to upgrade to VeraPlus, it should be a matter of restoring a backup from your VeraEdge to the VeraPlus. If you have concerns about the process the support team can do it for you if you log a ticket with them.

It seems I’m a little late to the party but mine also bricked after the firmware update. Customer care hasn’t been able to help me get it to respond to any commands and they nicely offered to fix the box that they ruined. However, they need a receipt, which I don’t have any longer. I upgraded to a VeraPlus not so long ago because I thought all of the issues I was experiencing was because the Veralite was just too old - that didn’t work out too well for me. This is beyond frustrating.

What is the LED light state on your Vera? Are you able to ssh into the device? I “bricked” one of mine a long time ago and of course, in that state, Customer Care couldn’t access it remotely but I was able to ssh into the device and nudge it enough to bring it back online to fully recover.

I have a similar problem. After upgrading from Vera3 to Veraplus, bizzarre lost devices. So I did what support said and started from scratch and have now rebuilt over 50 nodes. Guess what, I cannot exclude devices again without loosing my entire zwave network. Support says I have a corrupt zwave network and the only clean/good version is from months ago when I had only 2 devices attached to my vera plus. Not wanting to start AGAIN from scratch, I have since discovered that I can exclude devices by using the physical buttons on the vera plus and not lose my entire zwave network. Using the GUI (UI7) does destroy the zwave setup. So I have a work around as the physical buttons work where the gui does not.

Looks like I am joining the club twice over. I have 2 Vera Plus boxes in vacation rental homes (I know…poor me). I hesitate to do any upgrades since I am not on location. Since I was here for other maintenance issues I decided to upgrade both. Turned both into bricks. Have not heard back from support and I have to leave in a day. I take it phone support is non existent? Sent an email a few hours ago but still no response. Can anyone tell me what the usual response time is?

Phone support is actually pretty good:

USA Toll Free: +1 (866) 966-2272
International: +1 (702) 487-9770


1 Like

Hi @gwdodd

I’m so sorry to hear about this. I see that you’ve managed to sync with the CC team.

Got two plus’s, first upgraded when I got it and it bricked… 2nd was bricked when I plugged it in. Not real promising, even for a (savvy) fan!! Support replied at midnight a day later :confused:
Just post the Tech side of how to ssh and fix it… I dont want to deal with some support tech who is reading a procedure anyway!

I have also joined the club with now two bricked veras with difficulty getting the appropriate support. I had a Vera edge setup running all my system and upon trouble shooting and error with Vera support “cannot write user data system error” we managed to brick the device (an offer was made to replace the device but I can get no response from the technician after providing him with requested information). Luckily I had a backup so I purchased a brand new Vera plus and performed the restore of the Vera edge back, now the Vera plus web interface never fully load and is stuck in a constant spinning circle attempting to load. Vera support have asked me to issue several http commands, none of which work but I test ssh and this is still responsive and have asked Vera support if possible to perform a remote session but cannot get a response. I have also tried pressing the reset button on the Vera plus and it looks like the unit goes through the restart process but the end result is the same continuous spinning loading circle. Any path forward?

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules