Android App takes a very long time to display devices

Hello. For the full list of devices that are integrated with the Ezlo platform, please always check:
-Z-Wave Full List
-Zigbee Full List
-2 Gig Full List
Kind regards!

Still the same issue. Slow display of all dashboard items. Extremely slow display of devices when going to devices under the menu section.

1 Like

Apparently Ezlo have a new lead Android developer who has come onboard recently and will be making sure the Android version of the app catches back up with the iOS version.

As it seems to me the iOS version is much faster.

Although day to day I don’t use the Vera mobile app as I never liked it much. Currently using Home Remote with a Vera Plus.

1 Like

Anything we can do to encourage the expediting of this process - i.e. high priority on the Backlog list?

IT IS PAINFULLY SLOW! I have been waiting patiently for months, there is progress but seems to be as slow as the loading of the app and adding devices.

Hello guys,

We are working on the problem and will make it faster as it’s supposed to be very soon.

1 Like

… or there will soon be a new MiOS app and the old-fashioned Vera app will retire:

both will continue for now…
You will have the Vera app as well as a brand new MiOS app.

Is it a brand new app the Mios one?

The Mios app I have on my phone just looks like a rebranded Vera app with blue colour theme and some slight differences in the GUI.

its not available in Android yet.

So the “new” / current Mios app for Android has been abandoned now?

This “Mios” app that is a re-skinned version of the Vera app, that has a different menu system.

It hasn’t been updated to new MiOS app…
IOS has been updated to new MiOS app…Android is yet to be updated…

Is there an eta on when this will be fixed?

I don’t know what changed, but the app is fast again since two or three days now. In addition there appeared a device called “PAASAuthentication” where you can type in commands as in alexa. Any information about this?

Currently I can’t use the app at all. In the app my Vera Plus looks offline. But via web it’s working and according device it’s all working…

Android or iOS? Local or Remote connection?

Try clearing the cache and data for the Vera app and log back into it.

Also the Android app has been much faster the last several weeks.

Devices for me now load pretty fast.
Ezlo improved somethings on their cloud backend apparently that fixed it.

1 Like

Thanks. Data erase fixed it. I did try cache only before…
Thanks again!


I have exact same problem, devices load extremely slow. Does anyone have any idea as to why and how to fix it?

Hi Jessica, could you please give us some detail? Do you always face this problem or sometimes? If the answer is sometimes, it might be important mostly when and where it occurs? Please give us a detailed description to fix this latency problem. Thank you!