Alexa with ezlo plus

Hello everyone.

I am linking my ezlo plus to my alexa account and I am choosing the devices I want to use. I think it is wrong that they select to all the devices, at least more than 100 selected appear to me, I think it is exhausted to deselect each one. It is not more favorable to create a button that indicates all or that designates all.

All these devices and scenes in the Web portal page for Alexa should not be automatically selected and exposed to the Alexa platform

It should be down to the user to choose and select himself which devices and scenes are selected.

I’ve said this for years but it has never changed.

Funny that for Google Home integration this does not happen and they are not automatically selected and the user does have to select them himself.

All of the voice assistant integration with both Vera and Ezlo hubs is a mess and has been for years.

1 Like

Absolutely, it shouldn’t happen this is so difficult and boring

A chap called Valentin Grigoras is the sensor dev responsible for all cloud stuff.

All enquiries should be directed to him regarding voice assistant issues.

Not sure if he is a member on this forum however.

1 Like

Someone else on the forum should take this into account. For customers who have many devices and want to link these with alexa they will hate that process

Believe me I have tried my best for you guys and myself having issues with voice assistant problems.

I’ve taken it to the very top of the Ezlo company and never had any real response or commitment from them to resolve and try to fix these issues.

1 Like


Thank you for your suggestions and your feedback.

We are aware of some flaws that we have in voice assistants pages. We are planning to implement new pages in the new Web UI.

These items have been added to our to-do list (backlog) for approx. Q2 / Q3 2022.

1 Like

Same problem.
EzloPlus, I tryed to relink alexa also with Ezlo Skill, I have about 1 hundred real devices, now the lists of devices is infinite, the same devices are duplicate x 10 times, so now I have thousands device to check and uncheck and the page is also not reactive. Impossible to do this.
Verahub is connected to Vera skill and a lot of devices are not on the page.

Does anyone have any luck with using alexa commands from the ezloplus? Originally I had it setup using an older app version on my phone, but even that seems to have been broken recently.

What commands are you using?

Hi, just the usual commands, open curtains, turn on
… Etc


Would you mind checking once more and let us know, we have retested this feature and it is working correctly when it comes to detecting and managing devices, please let us know if you have a specific test environment.

Hi, on
elzo plus firmawave v.

the Skill Ezlo for Alexa continue to show duplicate devices X10 or x100 times, impossible to count them and to connect the skills because I have to change name to all of them to resolve this error:

You have one or more selections with the same name. Please correct this by using the custom name fields and try again.

on this link:

and plus, this night at 1.20 am Rome time, ezlo plus went blinking orange, so off line for a lot of hours until this morning.
With Alexa is there a progress?

Thanks in advance

1 Like

Thanks Max, that is the first time we have had any official confirmation on the future of these Voice Assistant web portal setup pages.

1 Like

I saw that same problem also.

1 Like

Hi Leonardo,

The use case I’m trying to implement, is using an Alexa command as an action, but I don’t see the Alexa device as an action entity. This is happening on both android and ios devices.

If you can provide details on how to resolve this, it would really be appreciated



Checking this evening, I find that my Amazon devices are not linked. I’ve re linked them, and despite being advised that the link is working, the Amazon device isn’t showing under Ezlo VOI. I’ve tried several time from both iOS and android devices.


Any news on these issues with Alexa?

I can no longer edit the devices that Alexa sees. Is this normal?



Finish button still not clickable ? On the “Manage Alexa Ezlo” page on the portal.

So cannot select which devices I want exposed to Alexa or not.

EDIT - Same on the “Manage Google Home Ezlo” portal page, nothing happens when you press the Finish button at the bottom of the page.

1 Like