Alexa TTS (Text-To-Speech) [and more] plug-in for Vera

Same here, stopped working after new files uploaded

No errors in log. All files in storage/alexa. l

Ok, I will need more time to test under beta. Unfortunately I’m out of town at the moment and I can only test with openluup (where it’s working ok).

1 Like

Take the time, I think it is awesome already!

1 Like

Hi, had any chance to look into?

I’m busy at the moment, but I’ll try to find some time tomorrow.

Struggling to get this working on my Vera Edge latest 1.7.4832 (7.30) firmware.

In the /storage/alexa folder I can only see the alexa_remote_control_plain.sh file present

None of these other files are being generated.

.alexa.cookie
.alexa.devicelist.all
.alexa.devicelist.json
.alexa.devicelist.txt

I entered my Amazon username and password in the variables tab of the device in Vera.

Also if you are in the UK do you need to change the “AmazonHost” to amazon.co.uk rather than amazon.com ?

And the “AlexaHost” from pitangui.amazon.com to alexa.amazon.co.uk ?

I tried this anyway but makes no difference.

I also tried manually creating my .alexa.cookie using the Firefox cookies.txt add-on as previously described and copying the file in to the /storage/alexa folder, but again made no difference, the Echo Dot never speaks the TTS message.

Thanks

How are you seeing what’s in the /storage/alexa folder?

I have
layla.amazon.co.uk
as the Alexa host and
amazon.co.uk as the amazon host

C

Just using Winscp on my Windows laptop could they be hidden files or something ?

EDIT: In Winscp you can press Ctrl+Alt+H to turn viewing hidden files on / off.

I turned it on and there is only the .sh file in the /storage/alexa folder.

Same using Putty and SSH I just checked the /storage/alexa folder and there is only one file in there the .sh file

in putty the command is ls -a

So I suggest you change the Alexa host then copy your cookies text to a file called

.alexa.cookie

The preceding period is important.

Try again, but let us know what lua you’re using (I assume you’re testing in the develop apps lua window?)

C

I’m not using two factor authentication on my Amazon account as far as I know.

Also should my username and password that I enter in to the fields in the Variables tab of the device, actually be written in to the .sh file ?

In the section where is says the following? As the .sh file contents do not change and do not have my own details added to it.

SET_EMAIL=‘amazon_account@email.address’
SET_PASSWORD=‘Very_Secret_Amazon_Account_Password’
SET_MFA_SECRET=’’

something like:

1234 5678 9ABC DEFG HIJK LMNO PQRS TUVW XYZ0 1234 5678 9ABC DEFG

Yes I am using that to test my line of code.

luup.call_action(“urn:dlna-org:serviceId:DLNAMediaController1”, “Say”, {Text=“Hello from Vera Alexa”, Volume=50, GroupZones=“Living”, Repeat = 3}, 58)

Just done that, I renamed the AlexaHost to what you suggested, I added my .alexa.cookie file back in to the /storage/alexa folder and then I reloaded the engine in Vera.

Tried to run the line of code again for the TTS but nothing and still no extra files appearing in the /storage/alexa folder.

OK
No your user / pass shouldn’t be written to the .sh file

Do you have a Zone called ‘Living’
Is your Vera TTS device 58?

Personally I’d keep it simple:
luup.call_action(“urn:dlna-org:serviceId:DLNAMediaController1”, “Say”, {Text=“Hello from Vera Alexa”, Volume=50}, 58)

Have you created the cookie file?

C

In the Vera log file I don’t see any errors.

08 01/21/20 18:46:43.617 JobHandler_LuaUPnP::HandleActionRequest device: 0 service: urn:micasaverde-com:serviceId:HomeAutomationGateway1 action: RunLua <0x74397520>
08 01/21/20 18:46:43.617 JobHandler_LuaUPnP::HandleActionRequest argument id=lu_action <0x74397520>
08 01/21/20 18:46:43.618 JobHandler_LuaUPnP::HandleActionRequest argument serviceId=urn:micasaverde-com:serviceId:HomeAutomationGateway1 <0x74397520>
08 01/21/20 18:46:43.618 JobHandler_LuaUPnP::HandleActionRequest argument action=RunLua <0x74397520>
08 01/21/20 18:46:43.618 JobHandler_LuaUPnP::HandleActionRequest argument Code=luup.call_action(“urn:dlna-org:serviceId:DLNAMediaController1”, “Say”, {Text=“Hello from Vera Alexa”, Volume=50, GroupZones=“Living”, Repeat = 3}, 58) <0x74397520>
08 01/21/20 18:46:43.619 JobHandler_LuaUPnP::HandleActionRequest device: 58 service: urn:dlna-org:serviceId:DLNAMediaController1 action: Say <0x74397520>
08 01/21/20 18:46:43.620 JobHandler_LuaUPnP::HandleActionRequest argument Repeat=3 <0x74397520>
08 01/21/20 18:46:43.620 JobHandler_LuaUPnP::HandleActionRequest argument Text=Hello from Vera Alexa <0x74397520>
08 01/21/20 18:46:43.621 JobHandler_LuaUPnP::HandleActionRequest argument GroupZones=Living <0x74397520>
08 01/21/20 18:46:43.621 JobHandler_LuaUPnP::HandleActionRequest argument Volume=50 <0x74397520>
50 01/21/20 18:46:43.622 luup_log:58: VeraAlexa: TTS added to queue for 58 <0x74397520>

Sometimes in my experience recreating the device helps. I was having no errors in my logs but I couldn’t get Alexa to talk. Deleting the device and recreating it fixed the issue!

Yes I created the cookie file and added in to the /storage/alexa folder.
Yes 58 is the device ID of the device in Vera.

I don’t know LOL about a Zone, I only have one Echo Dot speaker in my living room, we have Google Home speakers through out the house.

In Vera on the device in the variables tab, I changed the field “DefaultEcho” from Bedroom to Living that’s why I had “Living” in my line of code.

I have just tried your simplified line of code and it passes and says its run the code, but again I don’t hear the Echo speak out.

I don’t know why I have those other files missing from the /storage/alexa folder though.

Thanks

The zone is the ‘room’ your Alexa device is in on the app. Default echo is the name of the Alexa device itself. So if I have a echo dot in a room called ‘Kitchen’ and the dot was called ‘Pabla’s Dot’ I would Input the zone as ‘Kitchen’ and default echo as ‘Pabla’s Dot’.

if you read the last few post (158 on ),the latest version does not work on veraplus i have, might work on other vera’s. try installing version 1.3.

Looking in the Alexa app on my phone and going to the “All Devices” section of the app, the Echo Dot is named “Lounge”.

I’m not sure if its in a room or if I even have any rooms.

Sorry I’m a Google Home guy and don’t usually use the Alexa stuff.

There is an “Everywhere” speaker group that I can see, it has the “Lounge” Echo Dot and my Fire TV stick in that group.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules