Alexa integration "Device unresponsive" flaky command response

My Vera - Alexa integration was solid for years until just recently. Alexa is displaying the “device unresponsive” message for most light controls via the Alexa app. And device commands are really slow to respond or just fail. It’s about a 50 percent failure rate. Any suggestions on how to troubleshoot?

1 Like


At this moment I see the same. I guess this are delays in “the cloud” again and we have to site through it until Ezlo or who else clears them. In my experience you should not start to change things at you end. unless your whole internet experience has slowed down of course.

Cheers Rene

Same here alexa voice commands on vera have been flakey for a few days .

Same here I am seeing the same issues as described here. Been like that for more than a few days however.

Since I know you all guys have another raspi/PC running, take a look at ha-bridge: GitHub - bwssytems/ha-bridge: Home automation bridge that emulates a Philips Hue light system and can control other systems such as a Vera, Harmony Hub, Nest, MiLight bulbs or any other system that has an http/https/tcp/udp interface. This is a compact impl to run on small format computers. This is impl started from this project

I’ve switched and never looked back. 100% local and you can send whatever HTTP command you want, not only Vera’s one. I integrated a couple of things I’ve build HTTP endpoints for this way and WAF is extremely high, since I built a couple of routines to bypass the need of scenes. Highly recommended.

EDIT: I can control roller shutters position (not supported by the skill) and colors, too.

1 Like

I actually use Google Home speakers round the house and only have one Echo Dot for testing some stuff.

But I agree for Alexa its better to run the Java HA Bridge locally for Vera / Alexa integration.

HA Bridge also worked with Google Home at one point but no longer does.

Yep, Google changed something, as they always did, and broke everything. The history repeats, since they did the same with Nest.

I am actually running HA Bridge on my Raspberry Pi currently for Logitech Harmony integration with Vera for the “Home Control” hard buttons on the Harmony remote handsets.

I moved my most used devices to node-red-contrib-amazon-echo, similar to HA bridge, The only thing left on the vera skill is the goodnight routine, which one day I will move to node-red, when it annoys me enough.

1 Like

Another nod for HA Bridge. I started using it long before there was a Vera skill for Alexa. Works great, local, and allows things the skill does not!

It is very clear the performance will remain horrible using the vera skill. Time for me to move back to HA Bridge as well. The real sadness is how 3rd party solutions are beating native vera features in stability and reliability, and vera/ezlo doesn’t appear to be bothered by it in the least.

Hello, I am presenting the same problem, could you please give me a more detailed information about this process?

node-red-contrib-amazon-echo is a node that can be installed on a Node-red server

You would need to run a local Node-red server, Node-red will run on many devices, that run node.js.

Once you have a server running you use your internet browser to create flows from nodes, This is low code based. You can install many different nodes, to link multiple systems.

I appreciate your answer, I am a home automation integrator in Colombia, I have little knowledge in programming, it is very complex to get to use this tool. I would like to learn but I want to obtain a quick solution since it is to deliver a client’s house

Install it and see, it is design to not be to complexed. The design is flow based and low code. Obviously there is an initial learning curve, best take a look

Thanks again, I have already checked node-red, I managed to make alexa detect the new devices created in node-red, and I can through the http request node turn off or turn on one of my devices really.

turn on

to turn off

But the condition for when it is to turn off send 0 or turn on 1 will not be added.

http is the only way or is there another way


There is a mios node to.

Everything went great until it wasn’t. The HA bridge came right up. Added my Vera IP address. Devices and scenes populated. I run discovery on Alexa app and no devices show up. Any hints? (I tried the entire troubleshooting guide).

Be sure your routes doesn’t block discovery traffic. enable verbose logs in ha bridge and look at them.

EDIT: also, be sure to add them under “brigde devices”.

I fiddled more and it started working. What’s the story with dimming? Should that work?