Alerts stopped working with Vera Alerts! (UPDATED - WORKING AGAIN AS OF 10/24/16

A few days ago I stopped getting alerts with Veramate. The thing is nothing changed in my settings.

When I check the dashboard for my Vera I can see that vera alerts is sending the alerts OK but they are not getting to the Veramate app. I tried deleting Veramate completely and reinstalling but I am still getting the same problem. My problem is different than the other post just recently because if I try and do the test send of I love veramate it does not make it.

This has been working fine for years and I haven’t changed anything and now all the sudden I can’t get it working. The one thing I noticed is when I try to enable the alerts in the app it gives me the error in the attached screenshot.

If anyone has any ideas if you could get back to me as soon as possible because I have a driveway alert that I use this for as well as my doorbell if I am away and not getting notified now is frustrating

Same here, see the post below there are others reporting it too. Trouble is that the developer often goes MIA from this board so who knows when a fix may be worked on.

I just noticed that actually and added a message to that thread. The way I see it the more post that get up the more likely The problem will be seen and hopefully fixed.

I have noticed the same thing with the developer. I opened a support ticket over a week ago maybe even two weeks now and have yet to get a response.

I like this app but I need to have the push notification alerts so if it isn’t fixed soon I might have to use something else. The question is what?

Here are the attached images…

Same here. No alerts for the last few days and I’m getting the exact same error that Spudz72 posted. I actually find VeraMate to be pretty responsive. Has anyone sent him a troubleshooting email via the app yet? I find that he responds to those faster than the forum here. He has any amazing app and normally it works great so this may be an issue with something that MiCasaVera changed with their server protocols or something like that. I’m sure he’ll be able to fix the error with the push notifications.

I have not put on a support ticket for this one as t says if it is urgent to post here, and the last support ticket I sent it in was almost a month ago and still no reply. I did send him a message through the Veramate Facebook page as well linking to this thread so hopefully he will see it soon and respond.

Ok. I entered a support ticket… I’m sure we’ll get a response on this soon.

I hope so. I have some customers who I setup the same system and they have contacted me saying they are not getting alerts also.

Let us know. Thanks!

No word yet unfortunately :confused: I’m only running my own personal home system on a Vera Edge but I could see how this is definitely bad news for paying customers relying on VeraMate.

Hope we get some word soon…

Guess you all probably saw this by now when you last opened VeraMate. They’re working on the problem. Hopefully it gets rectified by tomorrow!

Thanks for posting this. I was not aware of this as I had an internet outage for over the whole weekend as it turned out a truck hit my cable internet line outside my place so the app was useless anyway. Hopefully it will be fixed soon and glad they at least are aware of it now.

Push Notifications are working again for me! Phew… lol. Everything is back to normal for me at least; I’m getting all the notifications I should be again. How about for everyone else here??

Thanks for the notice. I just checked and my driveway alert is pushing the alert to my phone with Veramate. So all good here now also. Nice to hear.

Now if only Veramate would support attaching an image to the push notification like Vera Alerts support I would be all set. I would like for my driveway camera to send a snapshot with the push notification.

That would actually be a pretty neat feature to have a snapshot attached to a push notification… especially useful for scenes or alerts fired by camera motion or something to that effect.

Not working for me but I have a different issue. The VeraMate part of the solution is working now as you say. I’m having issues with the Vera Alerts plugin passing notifications over to the VeraMate plugin. This has all worked for a very long time but broke about 5 weeks ago, long before the recent issues with VeraMate.

I now have alerts via VeraMate working again and wanted to share what my issue was just in case others have a similar scenario. First off in Vera notifications are actually scenes but they are not visible as scenes in the UI. Richard Shaffer’s Vera Alerts plugin add’s LUA code to to these pseudo scenes so that when the notification is fired the notification data is also passed to his Vera Alerts plugin. Like all LUA code, Vera encodes it and if there is any non-standard characters used in device names, message overrides etc the encoding process will not work correctly and that breaks ALL notifications getting passed to Vera Alerts. In my case it was the iPhone Locater plugin that was creating odd device names based on what it found in iCloud, the result was device names that had “(*)” in them that would not get encoded correctly breaking everything. This is also the cause of the blue banner error noted in many posts here that says “ERROR LUA error in scenes and events”.

The root cause of all this is a firmware update many weeks ago that had a bad encoding routine that was incorrectly handling non-standard characters.

Old topic but VeraMate Alerts stopped working yesterday - over a week after a firmware update.

Messages are getting from VeraAlerts to VeraMate Alerts and if I close VeraMate and open VeraMate, all of the notification show up but nothing is pushed to the phone. I tried reinstalling VeraMate Alerts. I do not want to reinstall VeraMate because I do not want to setup the icons again.

Anyone having a similar problem? If we are all are then it may be VeraMate’s servers. If it is just me, I may have to reinstall VeraMate.

I do miss my notifications. My wife and I do not know when the other comes home.

If the have some type if registratration action … you might unregister/register again. (This resets an internal token the Google Play app uses, which does the actual delivery from the Google Servers to the Phone).

You might try to turn on/off your Wifi (i.e. to make the software thing there is a network change) this causes many network related software components to re-initialize.

I did not see any sort of registration so I ended up uninstalling and reinstalling the app but it functions the same. And I leave my wi-fi and go cellular a lot with no change. I turned off wi-fi, checked VeraMate to see if it detected I was on 3G/4G, which it did, turned on wi-fi, and it detected I was on wi-fi.

A VeraMate alert is sent to VeraMate from Vera Alerts just fine but it is not pushed to VeraMate. If I close VeraMate and reopen it, I see the alert.

Attached is a screen shot of Alerts after turning on and then off a nightstand light. No alerts/ When I close VeraMate and reopen it, the attached screen shot shows the 2 alerts but they were not pushed to the phone. I am thinking the issue is on the VeraMate server side.

Still not working. I opened a ticket in VeraMate Support Sunday and as of today, no contact.

In the meantime, I created a Pushover account and Vera Alerts is pushing to my phone once again. I have converted all of my alerts to Pushover and purchased a license today. I will probably continue to use Pushover even if VeraMate starts to work again.

One positive that I see I can remove the VeraMate Alerts plug-in and free up some memory.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules