Aeotec LED Strips with Vera plus


I’d like to know if someone was able to add the Aeotec LED Strip on the Vera Plus controller?

The template isn’t available as is and I’m looking for a way to add this device to my setup.

Thank you

Bumping this thread, as I have the same question as @mike0203

I have not, but for the cost you can get the same result with the Fibaro RGBW controller a power supply and the superbrite LED strip that is over 16 feet in length for just over half of the cost for the Aeotech. This is what I use and it works great.

Aeotec LED Strips are not yet officially integrated but will work just fine at their full capability with the following changes:

By default it’s detected as a generic dimmer and you will have to change Device_file to D_DimmableRGBLight1.xml and device_json to D_DimmableRGBLight1.json

Hope this helps.

I just acquired the Aeotec LED strip, and successfully included it into my network, then made the two parameter changes indicated in this thread. It worked great, for 4-5 times. When I first installed it, I was able to change the colors using the selector. Now, it will only light up white, no matter what color I select. I’ve double-checked the two file specifications - they are still there. But the strip has stopped responding to other color selections.

Any thoughts?

Bumping this thread, hoping someone out there successfully using the Aeotec LED strip has some advice for me…

When you say “superbrite LED strip”, appreciate more detail on make and model LED strip that you purchased. Thanks kindly.

Sorry for the delay, Super Night (brand) 5050 RGBW LED strip lights 12 or 14 Volt any from amazon will work. if you look this up should get you to it SUPERNIGHT LED Strip Light, 5050 16.4ft RGBW Non-waterproof LED Flexible Lighting

I figured out what’s causing the issue, although I have no solution for it. If you include the Aeotec RGB LED strip, and make the approrpriate device file and device json changes as described below, it works fine. You can change colors without a problem. However, if you attempt to use the other selector, for color temperature, that seems to break the functionality, and you’re left with only white light, and no longer the ability to use the color selector. You can only restore functionality be excluding/re-including.

So, for whatever reason, the color temperature selector is what breaks it. I’ve just stopped touching that in the control panel, and it’s been working fine.

Clearly a know issue with this device and yet nothing gets resolved - same issue, follow instruction on the Aeotec support site and all you can do is turn it on and off.

Instead of deleting and re-adding the device you can change the Device_Type and Device_Json back to the original (or just delete) then “Reload Engine” then set them back to the ‘new’ files and “Reload Engine” again.

Does anyone know if there is a better way to add the Aoetec RGB strip?

Admin: Any timeline for native support?

Have we gotten anywhere with this? I’d love to know if you guys made any progress yourselves or if you just got fibaro…

UPDATE: Finally got the thing installed & working. Two tricks…(1) install as an Aeotec Smart Dimmer 6, to get around the “Trying to get manufacturer” issue, and then change the Dev File and Dev Json designations; and (2) when controlling the light strip from the Vera UI7 interface, after clicking the box that opens the RGB panel, and then selecting your desired color, click somewhere outside the panel (not back on the box) to register and send the color-change command. Even though the color will appear to change in the little square where you click to get the full RGB panel, it won’t actually send the command unless you click somewhere outside that box on the page, while the RGB selection panel is still open/displayed. Bizarre. And remember, NEVER click on the color temperature box or you’re hosed, and will have to start all over again. >:(

I just got another one of these, thinking I’ve got the technique down to make it work, so it shouldn’t be a big deal.

I’ve now had to exclude/re-include this RGB light strip six times. Unfortunately, for me, just changing the Device_File and Device_Json designations back and forth didn’t fix the problem - I could only get the RGB functionality back after doing a full exclude. And even now, I’m finding that I cannot control the colors in the web interface - it only seems to work from iVera on my iPhone. And then I accidentally tapped that color temperature bar and had to start all over.

And now I’m getting a “Please wait. Trying to get Manufacturer” error. I’ve factory-reset the AETEC strip a couple times. This is beyond frustrating. I have one of these working in my other home - it was also a pain to install, but following all these steps worked and it’s presently working fine. I can’t seem to get this one going.

I’m not understanding why Vera isn’t natively supporting this device - it seems fairly straight-forward. Is this an AEOTEC issue, or a Vera compatibility issue?