AD2USB suddenly started showing "Connection Down"

I installed a AD2USB (and the proper plugin) to be able to have communication between a Vera3 unit and my Ademco Vista 20P panel. The system had been working properly for the past 3 - 4 months, and now I am suddenly seeing error messages telling me that the connection to the alarm panel is down.

No changes to the Vera unit; already checked all cabling to make sure that nothing has come loose. Even though the AD2USB reports the connection being down; I am still able to ARM/DISARM the system using he plugin, so there is communication (at least one way) between Vera and my Ademco panel. I capture the logs from vera, and this is the only thing that I see:

50 11/04/13 21:25:43.100 luup_log:62: (VistaAlarmPanel::checkConnection) CONNECTION DOWN <0x2c997680> 50 11/04/13 21:25:43.101 luup_log:62: (VistaAlarmPanel::task) Connection down. <0x2c997680> 50 11/04/13 21:26:02.617 luup_log:62: (VistaAlarmPanel::requestArmMode) Request new arm mode: 'Disarmed', device #63. <0x2dfc4680> 50 11/04/13 21:26:02.617 luup_log:62: (VistaAlarmPanel::requestArmMode) partNo = 1 <0x2dfc4680> 50 11/04/13 21:26:02.618 luup_log:62: (VistaAlarmPanel::getPinCode) Using the stored PIN code. <0x2dfc4680> 50 11/04/13 21:26:02.618 luup_log:62: (VistaAlarmPanel::requestArmMode) Current arm mode = 'nil'. <0x2dfc4680> 50 11/04/13 21:26:06.075 luup_log:62: (VistaAlarmPanel::processIncoming) Incoming data = '!Sending...done'. <0x2e1eb680> 50 11/04/13 21:26:06.075 luup_log:62: (VistaAlarmPanel::processIncoming) ERROR: Invalid message. <0x2e1eb680>

Can anyone point me in the right direction to determine what could have happened to the Ademco plugin that is now reporting no connection? I guess Vera (the Ademco plugin) has lost the ability to receive messages, but I am still able to send commands and the alarm panel receive those message and execute them properly (ARM/DISAM, etc).

I have tried removing and installing the AD2USB plugin already, and the issue still persists. One thing that I have noticed is that the plugin version shows 2.45 on the actual Alarm Panel device; but it shows 3.0 when I go to the APPS tab of my Vera unit (seems like a version mismatch, but I do not remember if it has always been that way).

Any help will be greatly appreciated

That is strange, the connection down sounds like you lost your serial port configuration, so check that if you haven’t already done so, the being able to arm but not receive feed back sounds like a keypad address problem, either the wrong address in the ad2usb or not enabled in the panel, or maybe a duplicate with another keypad.

If none of the above is it i would try controlling the ad2usb with the nutech software directly from a pc to rule out a problem with the ad2usb

Checked the serial port configuration and all values are set exactly as the plugin instructions. To rule out a bad USB port on the Vera, I tried both USB ports and both gave me the same result.

I did verify that the keypads have no conflicts, so I have 2 alpha numeric keypads, one with address 16, one with address 17 and the AD2USB with address 18. All three keypad addresses are properly enabled on the Ademco Vista 20P panel.

I have not tried the software from nutech, but I think I am going to have to do that to rule out the AD2USB being the one causing the problem. I also verified power, data cables going to the alarm panel, and so far everything checks. Very strange issue, but I guess it is a possibility for he AD2USB unit to go bad as well (mounted on a equipment rack, with full battery backup and surge protection).

Seems like I experienced an issue with the AD2USB devie, but I must say that NuTech was very responsive in helping troubleshooting and providing a replacement unit. I just thought I will update this threat for anyone else that seems this problem.

I have the same or a similar problem. My serial port configuration for AD2USB disappears after a while and sometimes randomly shows up again. I plugged it into a Windows PC and watched the same thing happen in the device manager.

Mark… i seem to have the same problem. I just randomly get “connection down” messages. This morning, i reloaded and it went away, but i still can’t get my dashboard to control the alarm at all. Usually a reboot helps… which leads me to believe the AD2USB isn’t the problem. I/O is all there and correct.

Did you ever figure this out, and/or did the AD2USB help?

Just my 2 cents but I have just recently started having the connection down message. I quickly checked here on the forum which led me to the serial port configuration which had defaulted back to some odd stuff. I set it back to the correct information and it is working fine. Today I was testing to see if I could use a USB hub to run both my ad2usb and a thumb drive for the logs. After I disconnected my ad2usb from the vera lite, I found that the serial information had defaulted again. I have to problem if this is a known step if one ever disconnects the ad2usb cable from vera and only mention it in case someone else that thinks their unit is broken might check to see if they have also recently disconnected the cable.

Also, I would like to know if this is a sign that the ad2usb unit is starting to fail. I don’t think it is a year old. Otherwise, I am still amazed at the ademco plugin!

I have found that if you change the USB connections at all… like adding a hub, thumb drive, etc… you’ll have to go in and reset the serial port for AD2USB. Otherwise, if you are just unplugging in (to add a device e.g.), then plug it back in and power up, it will still be there.

I am having the same “connection down” problem with my AD2USB - about once a day. Sometimes a reload on the Vera 3 will take care of it - other times I have to unplug / plug the USB cable on the Vera 3 and then reconfigure the serial port again. I contacted NuTech tech support and they had me me verify that the AD2USB is working by connecting it to a laptop for several days. They told me to contact MiCasaVerde about the problem (since they did not write the Vera 3 software). This looks like some type of software issue on the Vera 3 / or the Ad2USB App. Any ideas from anyone on what to do with this would be greatly appreciated…?? Thanks!!

are you UI5 or UI6?


I have been using the AD2USB for years. I used to have to reset the serial port settings on the vera3 every time I rebooted it. On the vera lite at my office I have not had to do this ever.

The AD2 USB. Is pretty solid. Are you using a powered USB hub ?

No USB hub installed - however I did try one and it didn’t make any difference. I am using USB over CAT5E extenders so I can keep the AD2USB located in my alarm cabinet in the basement (my Vera 3 is mounted on the wall upstairs in my hallway coat closet). I used the same USB extenders when I did the extended test with a laptop and Alarm Decoder software - with no problems at all. Just for grins I changed the “connection down” parameter from 180 (default) to 360. Apparently this is the amount of time that can go by (in seconds…?) without the plugin hearing from the AD2USB unit before it reports “connection down”. So far so good - but it has only been one day plus…

The use of a USB extender in your setup would def. be of interest in trouble shooting … I agree they work well… most of the time.
Because most things they are hooked to don’t complain as readily as Vera would… they would just retry.

The above is a nice way of saying … I bet your right!

I have the same issues now. Had the AD2USB working for over 7 months, without any issues. Have disconnected the unit many times to include devices and corrected the port parameters every time. However, last week I disconnected the unit to include a switch, corrected the parameters, and nothing. I get the “connection down” message. The parameters are correct. I have connected my laptop to the AD2USB using the keyboard GUI and everything works. Even called Vera support and they confirmed the USB port is working.

Is this a plugin issue? Should I uninstall and reinstall? What am I missing?


Just in case, I sometimes get disconnected and fail to choose the correct ademco device. It shows two in the selection list and I can never remember which one is right.

Yes, it can get confusing, as it shows both the panel device and the partition device. However, I have always gotten it to work by picking the panel device. Therefore, I don’t think that is the issue. Thank you

Fixed it. The how: uninstalled the plugin, rebooted, and then reinstalled it. Of course, had to redo all the configurations and parameters. Wonder what happened…

Well, spoke too soon…it worked for 24 hours and it died again. Any suggestions?


Would love any other suggestions here as well. All was working fine and then I used battery pack to add a device and now am seeing a connection down error. So frustrating–this is one of the plug ins I use the most. I’ve re-entered all the serial port info, since this was lost on the system, but still not working