Zigbee dropping with the last firmware

Since the upgrade to 7.21, I am getting an intermittent event where both of my zigbee switches drop off the vera at the same time. It looks like the Zigbee stack is crashing. A reboot seems to fix the problem. Have never seen it with previous firmwares. Anyone also observing this?

Yes, most of my devices (7) of them that are on the support list located in my office keep crashing as well. According to customer care there is nothing in the logs. I have to reboot my vera at lease twice a day.

Not Zigbee, but Z-Wave devices dropping off and then come back in a day or two since the latest update. Not having good experience since moved to Vera Edge two years ago, but the latest f/w appears to be the worst in term of drops.

Have been doing a lot of testing on this problem:

  1. It is not an RF environment issue. I have scanned the 2.4GHz spectrum and found that the channel my Vera Zigbee is on is very clean in spite of all the different 2.4GHz traffic I have in my location.
  2. It is not a Zigbee chip problem: Normally when my devices lose zigbee, they blink to say they lost contact with the controller either because the zigbee chip crashed or because they are out of range. Not with the Vera problem. On the vera, it appears only the UI7 loses control. The other devices seem to communicate to the zigbee chip on the vera just fine.
  3. I have narrowed down the issue to the Luup engine. I am able to recover the zigbee functionality by reloading the Luup engine. It sometimes fails within seconds of the luup reload, sometimes hours.

The problems have been getting worse over time.
I first saw the problem on 7.0.19. It occurred twice right after the firmware upgrade and then disappeared for months
On 7.0.20 same experience, occurred twice.
beyond 7.0.21 I could not get rid of it and the frequency increased.
After trying to upgrade to 7.0.23 and now downgrading to 7.0.20, I am still having the problem about 2-3 times a day.
It appears the increase in number of devices contributed to the problem. I am now trying to remove plugins, startup lua code and scenes to see if I can eliminate the problem.

It appears that the problem is solved.

It is definitely a Luup engine loading issue.
After removing a number of plugins and attached devices, the problem is no longer occurring on 7.0.20 for the past 13hours.
The last plugin removed was SONOS and had to lower my Zigbee total device number to 8. I am still running 11 plugins and a total of 268 devices down from 290. I have kept all my zwave nodes(~130).
The biggest factors appear to be plugin and zigbee device numbers. Memory is far from running out. It is peak CPU utilization for the Luup engine thread which is limited.

Offloading a large portion of the setup to Openluup and iobroker has been a lifesaver.

Thanks Rafale77 for posting your solution. I had been struggling for a while now with my zigbee devices all dropping off and been thinking I had some sort of rogue device stealing all the signal. I had setup a scene to reboot the Vera almost every hour and still had devices dropping off.

After I deleted just a few plugins, none of which I was really using, everything is now solid 100% for more than 48 hrs. I don’t have the Sonos plugin, so for anyone else troubleshooting, I don’t think it’s a specific plugin, but rather a larger issue with the luup engine as you said. I have 14 plugins working and under 70 devices (some of which are virtual).

I had submitted a help ticket a couple of weeks ago, and they replied with “our development team is aware about the issue that our customers are encountering the zigbee devices, which are losing the communication with the controller. They are working a fix which will resolve this, but for the moment I don?t have an ETA”.

For those suffering from this problem, it appears that 7.0.24 finally fixed it.
7.0.19-7.0.23 all had this problem to an increasing degree.