Xiaomi Aqara stuff Works Natively

yeah for some reason any Zigbee device creates a device GenericIO_ which coresponds to the 0000 cluster, im not sure why that is but it is not needed @rafale77 do u know a way to get rid or hide the main device

The safest way is to hide it by using setting invisible attribute to 1 if you don’t need it. Otherwise what I did with the Halo was that I actually made the main device the smoke detector as it is reporting the end points by changing the device type manually as you know…

Changing the value of the variable “configured” from -1 to 1 stopped the configuring proces. Do you know any way to let the parent show the battery level? I can’t see the “batterylevel” variable i normally see on my zwave devices. However i found “PowerSourceLevel”, maybe that could be the Zigbee equivalent.

As mentioned by @rafale77 you can hide the main device by the invisible attribute. But i rather would want it to show the batterylevel :slight_smile:

yeah that was a question i had tried to figure out

You can search how I did this with the keen smart vents I posted somewhere. I think it is just about configuring the right endpoint but I can’t be sure with these Xiaomi devices.

Following the tips from the first post I was able to install https://pt.aliexpress.com/item/33048890656.html?spm=a2g0o.productlist.0.0.3b2534fdlvrGrH&algo_pvid=7e9eb8d2-df6a-431f-bd5e-b1fbad420613&algo_expid=7e9eb8d2-df6a-431f-bd5e-b1fbad420613-2&btsid=c8d54f6c-3a6f-411e-b529-9c24a1178b7a&ws_ab_test=searchweb0_0,searchweb201602_3,searchweb201603_52 and temperature devices. With the temperature device I can not read the pressure, only temperature and humidity.
I was unsuccessful with device https://pt.aliexpress.com/item/33025003138.html?spm=a2g0o.productlist.0.0.17aa3b02U2J4M8&algo_pvid=f35b8463-8223-4e6f-8260-9fb800ad1987&algo_expid=f35b8463-8223-4e6f-8260-9fb800ad1987-2&btsid=4fca2954-9461-4ac2-ac51-020e7e59d293&ws_ab_test=searchweb0_0,searchweb201602_3,searchweb201603_52. Even changing xml and json, the device does not display status information. information.

On no device could I display the battery, even following @rafale77 orientation.

local devnum = **your keen device id**
luup.variable_set("urn:micasaverde-com:serviceId:ZigbeeDevice1", "SupportedOutClusters", "0019", devnum)
luup.variable_set("urn:micasaverde-com:serviceId:ZigbeeDevice1", "PowerSourceLevel", "100", devnum)
luup.variable_set("urn:micasaverde-com:serviceId:ZigbeeDevice1", "ReportAttrib", "0001:4c00=1;0006:0000=0;0008:0000=1;0402:0000=0", devnum)
luup.variable_set("urn:micasaverde-com:serviceId:ZigbeeDevice1", "VoltageRate", 25, devnum)
luup.variable_set("urn:micasaverde-com:serviceId:HaDevice1", "BatteryLevel", "", devnum)
luup.variable_set("urn:micasaverde-com:serviceId:HaDevice1", "BatteryDate", "", devnum)

@richie.digital, did you succeed completely on xiaomi devices?

nah my Vera plus died … trying to revive it atm

I just got one of these door sensors and had no trouble at all. Added it as a generic zigbee device using the standard “Add device” way. Works flawlessly (so far) to trigger scenes, etc.

The only problem is that it keeps reverting back to the device name “Generic Zigbee Device”, but that doesn’t bother me too much.

It likely does this during a reconfig upon luup reload. Try disabling auto configuration for this device to see if it stops it from changing the device type on its own.

I should have said that I had already tried turning off auto configuration as well as setting configured to 1, but it still renames itself to Generic ZigBee device.

This is odd. I have not had this problem on my non supported zigbee devices. Yours somehow says it is waiting for the device to wakeup to configure. It could be that I don’t have any battery operated zigbee devices so I don’t really know what that means. Did you try waking up the device?

based on my experience u have to move the endpoint to the main device and delete the child device

most of the manual configuring of stufff on vera … will have a gereric device as the main endpoint and the actual device and an endpoint that is what i have found

    local devnum = *Main Device Number*
    local endpoint = *Endpoint*
    luup.attr_set ("device_json","D_MotionSensorWithTamper1.json",devnum)
    luup.attr_set ("device_file","D_MotionSensor1.xml", devnum)
    luup.attr_set ("device_type","urn:schemas-micasaverde-com:device:MotionSensor:1", devnum)
    luup.attr_set ("category_num","4", devnum)
    luup.attr_set ("subcategory_num","3", devnum)
    luup.attr_set ("no_child_sync","0", endpoint)
    luup.attr_set ("altid","", endpoint)
    luup.attr_set ("id_parent","", endpoint)
    luup.variable_set("urn:micasaverde-com:serviceId:ZWaveDevice1", "NoChildren", "1", devnum)
    luup.variable_set("urn:micasaverde-com:serviceId:HaDevice1", "ChildrenSameRoom", "0", devnum)
    luup.call_action("urn:micasaverde-com:serviceId:HomeAutomationGateway1", "Reload", {}, 0)

: under settings uncheck embeded reload luup and now u can delete the child device

if anyone know the code to uncheck embeded and remove/delete a device then it could jut be one code

Unfortunately not. Probably because the battery is reported as “PowerSourceLevel” instead of “BatteryLevel”. I think you need to create custom device files to support that field.

If it is only for monitoring, you can maybe use luup.variable_watch to monitor the battery level field and trigger some alarm if it goes under a certain level.

copy it with a watch to another variable is safe. something like this should be enough for Vera to show the icon:

function updateBatteryInfo(dev_id, service, variable, oldValue, newValue)
	if tonumber(oldValue) ~= tonumber(newValue) then
		luup.variable_set("urn:micasaverde-com:serviceId:HaDevice1", "BatteryLevel", newValue, dev_id)

luup.variable_watch("updateBatteryInfo", "urn:micasaverde-com:serviceId:ZigbeeDevice1", "PowerSourceLevel", dev_id)

dev_id is the device ID. Add to your startup code and you should be good.

1 Like

Ah, nice and elegant solution! Didn’t think of this yet, thx! Will implement it later.

BTW so far I’ve a working temp sensor and 2 working door sensors. I assume all other Aqara devices will work as well. Anyone can confirm or already tried other devices?

Did you make any progress with the Xiaomi temperature, humidity and atmospheric pressure device and your EU Vera Plus ?

Don’t think you were asking me, but I’ve got my EU Vera Plus working just fine with 2 temp/humidity sensors and 2 door sensors. See post above.

Great I might give some of these Zigbee devices a try then.


1 Like

These are the ones here right?

Yes, those are the ones!