WWN (Nest) Plugin? Google broke it and tells me Vera has to fix it

What’s the deal with the WWN plugin? I’m on with Google support because they seem to have broken compatibility. They tell me Vera has been invited to update to the new program, but haven’t accepted.

Does anyone know what the real story is on the Vera side of things? Thanks!

As far as i can tell Ezlo is not interested in updating any Vera plugins. They are doing firmware for Vera, but it seems only to integrate Ezlo back end/server compatability.

There was a discussion in another thread as well about this. Apparently they try to shift the responsibility to Vera but I don’t have exact information either.

Nest was bought by Google, and the developer API was migrated to a new platform. Google invited all existing devs to join the new platform, but evidently Vera hasn’t done so. I blame Google as much as Vera here, but there is no changing Google. I don’t know what the deal is with Ezlo buying Vera, but I’m getting pretty effing tired of spending money on things that are then rendered useless by acquisitions.

The plugin still works for me. I think migrating to Google which I was prompted to do in the past would have broken it but I never migrated. New nest installations may not have a choice.

Hi Guys,

Could anyone advice. I have 2nd. gen. Nest Termostat working fine with Vera Plus and I am planing to purchase 2nd. Nest unit but now 3rd. gen. my question is “is this now possible to integrate 2nd. Nest due to above issue?”

If you don’t migrate your account, you’ll be fine.

1 Like

I have not migrated my account. I still log in with my Nest credentials at nest.com.

This still doesn’t work. I’ve tried it in Safari and Chrome, just in case it was a local browser issue. I get all the way through the Nest authorization flow, log in, click “Allow,” and then get “Oops! We’ve encountered an error. Please try again.”

I am having the same problem. I have not migrated my nest account and have added a new nest to my account. When I try to authorize the plugin I get the same response to the “Allow.” Is this going to be resolved for the vera platform or is it time to start looking elsewhere for a solution? I’m pretty invested in the platform so moving to something new will not be easy, but I need some way to integrate my thermostats into the system.

1 Like

I’m getting the same error. I had to do a factory reset (well, not me, HVAC contractor came in and did work, Google told him to do a factory reset). My account has not migrated. I contacted Google, and they are blaming Vera. I call Vera, they blame Google. I think it’s both of their faults, but the WWN plugin for Vera isn’t being maintained by Ezlo, so if they would at least maintain it, the Ooops! message would go away.

1 Like

Old post I know, but as I’ve not migrated my Google account, and it seems the WWN Nest plugin still seems to be working for me ?

Yes, it will work until google leaves their server online. It’s a cloud integration, but not using ezlo cloud.

WWN seems very slow to update to Vera and sometimes not at all as of late. Is this related to the cloud issues that Vera has been experiencing?

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules