Whisper database location

Hi, new to all this. Took the time to looked around in the forum but did not find the answer, so here is my question.

Can the Whisper database location be on an external NAS on the same network as the vera or the Vera USB connector is the only way?


Absolutely. I used to use a NAS in preference to a USB. So long as you can mount the drive to somewhere in the Vera file system, you are good to go. You just need to set the path in the DataYours device variable LOCAL_DATA_DIR.

Thanks for the information.

Has the mount command format changed with FW 7.31? I have tried several variation of the following without any success:

mount -t cifs //IP/share /mountpoint -o user=xxx,password=xxx

The answer is always the same with the mount options suggesting that I have the sintax wrong.


Given the kernel changes I wouldn’t be surprosed.

man mount

You might want to try SMB over CIFS as well


Thanks for the information.

I finally get it up and working and it is what I was looking for. The problem was on my NAS side. Once resolved the mount worked as I indicated it above.

@akbooer. In another thread, you provided screen capture showing graphical information using Grafana . I have read all that I could find in the forum and on the net however, I came to the conclusion that unless you are a software developper and welling to write some kind of plugin for Grafana to querry datayours it is not going to work. Am I correct? Did you ever get it to work with whisper? If so how?

Is there an easy way to have a decent graphic engine that would be using the whisper data?

Thanks for any information you can provide,


1 Like

I don’t have anything that runs on the Vera, but I do have a Grafana server for Whisper files which runs as part of openLuup. Actually, it might be possible to run the openLuup server in a minimal configuration on Vera! But is your NAS something which can run other programs? People have certainly run openLuup on Synology servers. All you need is something which can access the Whisper files and which can run Lua (most things can.)

Thanks for pointing me some solution path. I will work on this but I am starting from quite far I am afraid.

Does it means that an Openluup version of Grafana server is required?


Just a plain Grafana installation works fine. openLuup itself contains a Graphite/Whisper Data Finder which Grafana can access directly.

Thanks looking at it.

Back to my NAS share, how can I make it permanent across reboot?


There’s this Lua Startup code I shared in 2014. Think it’s still good, although you may need to change the details of the actual mount command…

Super. It is still working like a charm.

Too good for me. :+1:

1 Like