When opening with IE goes to Firmware page

I had to downgrade from 1.5.408 to 1.5.346. But now whenever I open vera it opens to the Firmware page instead of the dashboard. Real annoying. Anyway to fix this?

This is what it says on the firmware page:

Testing connection to: download2.mios.com … OK

There is a newer version of the software available, and it’s highly recommended that I upgrade my software now.

Running Version

Latest Version


This is normal. If you need to stick with the older version, just ignore it and use the UI as you wish. Why did you have to downgrade?

  • Garrett

After upgrading a few of my devices stopped responding. Also, many icons dissappeared including my Trane Thermostats and Ademco Security lock icon. I tried everything including clearing the broswer cache. Nothing worked. So after reverting back to the old firmware everything works again. However, I never had The webpage go to the firmware page before until I did this downgrade.

Anyway to stop it. The normal thing would be to go to the dashboard.

Not that I know of. Maybe MCVFlorin can chime. They have made some changes to the icons for plugins etc. But this should not have caused the z-wave devices to loose their icons (e.g. Trane Thermostat). For the Ademco icon, this would need to be updated in the plugin. Not sure who the developer is of the Ademco plugin.

  • Garrett


The Ademco plugins haven’t been updated to use the new state_icons tag, but the Trane thermostat should show the correct icon, unless you uploaded a modified Json file for the thermostat. If you go to Apps >> Develop Apps >> Luup Files and look for the D_HVAC_ZoneThermostat1.json, how many times it’s displayed?