What is the quickest way to remove Altsteon?

I’ve fully installed Altsteon and it is not working out (no or difficult X10, intermittently requires restarts). Hard to explain to the wife that the buttons that worked yesterday don’t work today because I’m using an alternative Insteon implementation that allows 2-way traffic and it sometimes requires restarts :slight_smile:

Can I do a factory reset via the MCV UI, or do I need to back out the changes made individually?

Or can I just delete all my Altsteon devices and turn standard Insteon support back on?

Thanks - djm

As you can see from the number of posts I am pretty much a newbie too. However I have tried the Altsteon implementation myself, turned it off and back on. Right now I am working with Altsteon - without problems so far.

If you don’t mind the ‘clutter’ on your Vera file system from all the Altsteon files you simply turn off Altsteon by NOT having it start at boot time (remove the Lua startup code in the ‘Apps’ → ‘Develop Apps’ → ‘Edit Startup Lua’, if you put it in, power reset the box).
Without this code snippet Altsteon won’t come up and your good. You only need to turn back on the Insteon implementation in Vera.

Hope this helps and I’m not totally off the track.


Did you delete the devices from when you were using native Insteon support?

If so, once you disable the startup of the Altsteon daemon, you will need to add the devices back in.

If you don’t, they will still try to communicate with the Altsteon daemon which isn’t running anymore.