WDTC-20 network reset?

I am trying to setup a Wayne Dalton WDTC-20 thermostat on my new MCV Vera. My problem is with the thermostat, and since I haven’t received a reply from Wayne Dalton, I figured I’d try here. I started to set the WDTC-20 up a few months ago but ended up not using it yet. At the time I got it joined to the network, but never deleted it, and I no longer have the remote it was joined to. I need to somehow reset the network association so I can join it to the new network. I have searched all over and cannot find a method to reset the network association. There must surely be a way to do this, does anyone know how???

Do you have a Vera or 2?
I think you can exclude with a different device than the original and thus for the Vera 1, you should be able to put the dongle in exclude mode, go to the thermostat and press the include button i guess and then once done put the dongle into include mode and then do an inclusion? I guess its similar for the Vera2 anyway.

More instructions here:


Be sure when adding to thermostat though to make sure you only press the inclusion button on the WDTC-20 very quickly!!! If you press it too long i think it can get paired with basic functions.

Thanks Strangely! While I had tried this several times and had read about not pressing the bind button too long, I noted your remark and tried again, and it worked. I was then able to successfully include it. When you say press it quickly, you’re not kidding. I would even not say “press”, it really had to be more of a quick tap. All that headache for not pressing the button quickly enough…