WDC-20 Thermostat Problem

This isn’t really Vera specific, but I thought I would ask if anyone has run into this before. I have two Wayne Dalton WDC-20 Thermostats that are tied into my Vera. The upstairs one is working fine, however the downstairs one is acting up.

I came home yesterday, my downstairs was hot and my heater was still running. I took a look at the Thermostat and it read 68 degrees and had an amber light on. I knew that wasn’t right, so I hit the reset button hoping to knock it loose. The unit restarted and came back up reading 84 degrees. The heater turned off, and I went about my business.

Later that day I checked it, and it still read 84 degrees, so I tried pulling it off the wall and resetting it by taking the batteries out and reseating them. It came back on, now reading 74 degrees. I also noticed that I can no longer change the set point on it. It seems to be stuck at it’s last setting of 70 degrees. The amber light is still on, and I’m not quite sure what to do.

I’ve voicemail with Wayne Dalton, but haven’t heard back. They’re support line says they are open 7 days a week from up to midnight eastern, but I can’t seem to get anyone there. I am probably going to try them back on Monday if I can’t get this figured out. Does anyone have any experience with these units, that could maybe point me at something I am missing? I’m really not looking forward to possibly RMA’ing it because I really don’t want to have to re-wire up the old thermostat.

How did you wire the thermostat? Did you use a Black “common” wire to get 24v to the thermostat? I ask because I’m wondering if you are running off of battery power only which will quickly drain the batteries.

Yeah, it has the common wire run. It’s been in place for about 4 or 5 months. From what I understand the battery runs down pretty quickly if it doesn’t have the 24v line. The upstairs one has been in place for the same amount of time and is operating normally. I decided to just try changing the batteries in case for some reason it wasn’t getting 24v, but that didn’t help either. Still have the amber light, and it’s still stuck at the temp after reset. Thanks for the suggestion though, at least that wasn’t something I hadn’t tried.

Maybe try switching the u/s and d/s stats to see if you can isolate it to the unit itself? But then again the thought of removing each unit from that flimsy base and reseating it gives me the willies…

I found their tech support to be good.

Good luck,

Agreed, I can’t stand that base. Really am tempted to pick up those Trane t-stats off that Radioshack sale. I’m pretty sure it’s the actual unit. It doesn’t update the temp even when it’s off the wall running on batteries. It’s also been having the habit of switching over to Celsius instead of Fahrenheit randomly, which is a jumper setting, so shouldn’t change. I also tried to unbind it from the Vera unsuccessfully. I am still not able to reach Wayne Dalton support. I sent an E-mail to SmarthomeUSA who I bought the devices from. They offer free tech support for the products they sell, so going to try that route. Thanks for the help.

The instructions that came with the WD Tstat should have a toll-free number somewhere in the booklet. I have called that number several times (even on a Sunday) and have always reached a support person who knows a lot about the thermostat. Did you call the toll-free number in the instruction booklet?

Yeah, three times now. Every time I wait on hold about 10 or so minutes and it goes to a voicemail.

I did finally talk to Wayne Dalton support and they said that they think it got hit with static electricity and got fried. They said that I would have to go through Smarthomeusa.com to process a replacement as they don’t handle that directly to the consumer. I’ve already got an RMA open with Smarthome for the unit. I guess I’m going to have to re-wire up my old stat for now.

My downstairs WDTC died last winter and replaced it with the Trane. I just bought another Trane, so if anyone wants a WDTC-20 let me know.

How is the Trane compared to the Wayne Dalton. Obviously you like it better as you have switched to it. I’m thinking of making the jump to the Trane while they are on sale at Radioshack. I can’t really afford it right now, but at 50% off, it’s easy to make the case. If it’s that easy to kill with static, it’s a bit worrying to me. Static is pretty common in a home environment, so if it’s that vulnerable, I’d almost rather replace it.