WD500Z-1 will not Pair to VeraPlus


I have my 2nd VeraPlus. The 1st has some sort of communication problem.

My system is very small, a WD500Z-1, a GE A19 link, and a GE plug in dimmer.

All three were working with the old controller (before the communication went haywire).

Not, The GE linked find (after I reset it by 3 sec on / 3 sec off or 4 times)

The GE plug in dimmer fought hard but finally connected.

The WD500Z-1 will not connect. I have tried over 15 times. Often with other changes (rebooting the VeraPlus, opening the breaker on the WD500Z-1 etc). If the issue is the WD500Z-1 is still in love with the old controller then I don’t know what to do. And if that is not the issue I’m still lost. I have read some posts talking about resetting “nodes” but I cannot find such an entry type in UI7.

Any help would be appreciated.



You need to exclude the WD500Z-1 and include it again. Start Vera in exclude mode and then double tap the WD500Z-1 to exclude.

Thanks Zwaver but if I understand you correctly I tried that a number of times.

When I go to add a device in UI7 it asks me to pair the device. When that fails and I “try again” it goes through a few screens then asks me to “double” tap to exclude the device. I think this is the same as you are saying?


Vera support called and helped me out. The issue is solved (or at least fixed). I was able to exclude and then pair the WD500Z-1 by pressing on the TOP of the switch. Originally with the previous VeraPlus (different controller) I was able to add this very same WD500Z-1 by pressing the bottom (as stated on the Linear instructions and the Vera On Screen instructions).

When I asked, the Vera tech did not have history with the WD500Z-1 needing to pair using the top of the switch but he has seen this in the past.