Wayne-Dalton WDHA-12R not working

I know there are other similar posts, but I can’t find one that quite applies right to my problem. I am trying to setup the Wayne-Dalton WDHA-12R zwave-homelink gateway. I have a VeraLite controller, and the WD gateway seems to pair just fine. I can create scenes to lock and unlock my door, and can run them just fine from the Vera interface when I try to run that scene. But when I push the button on the gateway to test a scene, nothing happens… I’ve tried for the life of me to get it to respond.

I tried following the instructions on this video: Wayne Dalton Homelink to Z-Wave Gatway Setup with Mi Casa Verde (Vera) - YouTube

But that is for the old UI, but I still tried to follow as best I can, but no luck… any tips?

Did you see the original wiki how-to?

There was also a lengthy discussion about configuring the WDHA-12L (not the R) that may be helpful.

[quote=“Z-Waver, post:2, topic:186566”]Did you see the original wiki how-to?

There was also a lengthy discussion about configuring the WDHA-12L (not the R) that may be helpful.[/quote]

Yes I followed both of those as well as I could (I’m on the new UI of the Veralite, where these are on an older version) and I seem to be doing everything correctly, but when I push any of the Scene 1, 2 or 3 buttons on the gateway, the Veralite never seems to respond in any way. I’ve tried holding the gateway and veralite next to each other and etc too… no luck.

I followed the instructions as best I could again… and still no luck. They say to add the gateway under, “Devices > Add Devices > Advanced Z-Wave devices”, but in the new UI I do not see that option.

On the new UI, I see under the add device wizard “Additional Devices > Other Devices > Other ZWave device”

Is that the correct way I should add the gateway? If so, it pairs fine, and acts like it is ok, and I can assign scenes to the buttons, but nothing happens, unless I manually run the scene from the vera, not by the trigger of the gateway button.

Your pairing method is fine. As to why this gateway does not work in UI7, I cannot answer.

Did you try assigning the buttons to control lights instead of locks? I know for some time, Vera restricted you from controlling locks from certain devices. Because of the age of this device, it may have never made it off that list.

Good question… No I have not yet… I’ll try that… Thanks!

I tried this on a Zwave power outlet. Still does not work with the buttons from the WD gateway. I can trigger them fine from the web interface though. I’m really at a loss, since I have tried following every sort of directions I could find.

I’m pretty sure this is broken since around UI6. I would love to hear differently, but I think a change in security for secondary controllers left this old device out in the cold.

I opened a ticket and the Vera tech support tried but could never get it to work…I gave up and it appears so did Vera as they have not responded to my last ticket in over twp months :frowning:

I am working through the same issues right now, I am starting to think that the issue is more related to the fact that it needs to be a secondary controller and this functionality has been removed since version 3.2 upwards…

Can anyone confirm? I cant even see a way now to revert back since my Z-Wave is on Version:3.67 L:1.

Hope this helps.


Anyone successful in using the gateway on UI7? I have tried multiple times, followed all the instructions, still not able to make it work.

Very late response, but I have really only had luck by including the devices directly to the WDHA-12, as opposed to assigning the devices to the scene buttons through the Vera. I have homelink button 1 in the car controlling the garage door opener, homelink 2 associated with scene button 1, which turns on all garage lights, and homelink 3 associated with button 2 which turns off all garage lights. The response time is instant, but the Vera doesn’t know the lights are on until it polls the light nodes, which is fine for my needs.

Does anybody know if Wayne-Dalton WDHA-12 will work in Europe?

I suppose that if it uses Z-Wave US frecs it will not work. Is that right?

You are correct, it will not work.

It works on 908.4MHz(US) and will not communicate with the European 868.4MHz Z-Wave frequency.

Any alternative?

@JAnguita … You’re not missing much though because in the UI7 I have not been able to get this to work period. I have opened two tickets with support and each time the assigned tech seems interested in getting it to work and then abandon the process when they couldn’t.

I’m still using UI5 because some plugins I need appears to work better on this version.

About HomeLink integration in Europe, anybody knows any other way to do it?

@ JAnguita

I used to have a homelink module (car2u Wayne Dalton device) that I added to my older garage door. It had a wired output that rather than wiring directly to your door, you could perhaps either wire to something else like a scene controllers button (soldering involved), or either a spare zone on a security system connected to Vera, or to a zwave door/window sensor that has an external input connector to replace its on-board reed switch (some brands have this).

You would only get one action from it versus the 3 from the gateway, but I guess you scale this is up by buying additional parts.

So something like the below perhpas that handles 3 actions (You’d need to find european equivelents):

and a few of these:

I only need one trigger to activate/deactivate the home security system. I think that your idea could work.

Thank you