Virtual Outdoor Sensor (VOTS) seems broken

While checking my datamine graphs I noticed the VOTS temperature not being updated since January 3rd. on reloading zwave engine it will diplay an error “VOTS failed to update values”.

There is also no weather information in the dashboard.

I don’t use this information in scenes so no problem to me. Anybody else noticing these issues or is it just me?

Yes, I have noticed that while I can get Lup to reload without an error, the temperature has ‘frozen’ at 1 degree for the last few days. Not sure how to fix it or if there is an alternative. I understand options are limited with Weather Underground no longer a choice if you don’t already have an API key.

Hello Ranneman.

Please know that I have created a support ticket for this issue.

Check your e-mail and let us know so we may check this and see what may be the cause.

Thank you. :slight_smile:

ranneman, Radu B

Please could you update the forum on how to resolve this issue. Further to my previous post I can confirm I have exactly the same issue as ranneman. Thanks.

Correct, it’s not working for 2 days or so and when you login as well to the temperature isn’t displayed at the top right of the screen either. I was just about to post about this but figured someone might have reported it as well.

Talisker, I have provided information to Radu on the error (log file and location information). As this seems to be a generic issue, easy to reproduce, I will not open my Vera unit for more analysis by Radu.

I also am not seeing the temperature, and I used it in a PLEG action to set my thermostat to heat. As long as it gets fixed in the next few weeks, I should not miss it too badly.

Same here, stopped working on Jan 3rd. Following to find out what the fix is

I have asked Radu to reply in this thread on the status and progress for a solution.

This is the response I received this morning from Vera Tech Support:

“I would like to let you know that we have reported this matter to our developers which are working on restoring the functionality of this plugin.
Basically the issue is related to the fact that the Yahoo API for the weather as changed and because of this also the weather in the upper right corner of the units interface.”

If you want to control your weather (!), I’ve posted a couple of recipes in the SiteSensor wiki to grab weather data from some common APIs that still have free access (as of when I last used them)

[quote=“rigpapa, post:11, topic:200370”]If you want to control your weather (!), I’ve posted a couple of recipes in the SiteSensor wiki to grab weather data from some common APIs that still have free access (as of when I last used them)[/quote]

+1. So far it appears I still get data from Weatherunderground and I will be looking for options soon.

Weather Underground has reported they will also be discontinuing their API at the end of this month.

I was thinking it was the end of December.

I’m hoping for a fix because I have a Gen 1 Nest that I use the VOTS and Nest humidity to intelligently control a relay to call my HVAC humidifier.

VOTS started working for me yesterday.

Mine is still not working. I have uninstalled and reinstalled. The temperature data still not showing up!

I am getting the following error in the log:

50 01/19/19 14:26:07.506 luup_log:0: VOTS::GetTemperature> Get temperature with URL: <0x76cbe520>
01 01/19/19 14:26:07.506 luup_log:0: VOTS::GetTemperature> Failed to decode weather response with error: no valid JSON value at line 1, column 1 <0x76cbe520>
01 01/19/19 14:26:07.506 luup_log:0: VOTS::UpdateValues> Failed to get temperature <0x76cbe520>

Looks like mine must have just started working as well. Nothing in my weather logs yet but shows up in the vera dashboard now so had to have been fixed in less than 24 hours ago for me

Working here as well.

Works fine here after deleting and recreating the device.

Thank you Sorin and crew!