Virtual HTTP Light Devices, supporting RGB(WW), Dimmers, Switch and much more (Tasmota, ESP*, Shelly)

I just published my virtual files here: vera/VirtualDevices at master · dbochicchio/vera · GitHub

Feel free to grab them.

There’s support for:

  • RGB(WW) Lights
  • Dimmers
  • Switch

all based on HTTP calls. 100% standard services, so 100% compatible with mobile devices.
Every action correspond to an HTTP call.

This can be used for remote valve (ie: irrigation based on ESP* or Tasmota), just be sure to change the sub category number.

It’s working OK for me, and it’s covering all the basic needs.

Feel free to post your question here.



What would be the correct call to turn off
A switch (Vera device creates #944)
luup.inet.wget(‘http://I.p address/cm?cmnd=Power+off’)

@therealdb How do you sync the state of the device in Vera? Vera now can’t tell if it’s off or on.

It depends. In case of Shelly, you can define an url to be called when a button is pressed. You can compose a special url and update your vera:


I seen that in you wiki where do you put the url. I’m familiar with the http call just not sure where to put it so Vera can update the state.

Look under actions, then button switched on/off.

Sorry forgot to mention the unit is flashed with Tasmota. Is the action on the Tasmota or Vera side? TIA

It’s on the device side. If you only control the device from the Vera, you will have no problems and this is not needed.
AFAIK, Tasmota has no way to call an URL when a button is pressed (it’s based on MQTT). Your option is to setup a light MQTT bridge for Vera (or use the Vera-MQTT plugin, but I never used it) and relay the commands to the Vera. I have a similar setup (MQTT bridge) for my Wifi led strips and it works very well. I truly hope future Vera firmware will support MQTT natively.

1 Like

Thats what I’m missing. I guess the state is not that important if I use the toggle http call it will trigger no mater what the state is showing on Vera. Great work thanks for the HTTP integration now I can use Sonoff and other wifi device with my vera.

1 Like

Hello friend,

Your efforts is highly appreciated, are those files and app working and compatible with shelly 2.5?
Many thanks;)

Yes. Just be sure you get the right http call in place.

HI guys, I have a two light globes in a Lounge room, both are running Tasmota, one is RGB the other is binary. Both perform perfectly using HTTP calls manually but when Virtual HTTP calls to turn off the Binary dimmable light it does not turn off, it actually turns on. I have done some traces using wire shark and the only difference i find in the HTTP get command is some reference to http 1.1


Is the command case sensitive? what’s your exact HTTP call? I have a version on development to specify different endpoints for on/off command, that may be the case for you.

Thank you for having a look at my problem and awesome work with this app.
I have proven that the set power URL is not case sensitive

The non working one Setpower URL variable is
The working one is
Both globes run the same version of TASMOTA Firmware

Both globes respond correctly if i manually enter these commands into a web browser (Interchanging %s with on or off)

Actually I have to apologise, i am sure that during my hours of trouble shooting that one of my first tasks would have been to recreate the device from scratch. However I just did that exact move and the problem is solved. Thank you for your time

Can you describe how you are using an MQTT bridge. I have Mosquito set up in a docker container, with my Tasmota devices pointed to the Mosquito broker. Home Assistant allows one to then use the MQTT broker for status messages, and it works well. But I’d like to keep as much automation as possible in the Vera ecosystem. How are you doing this with Vera?

It’s basically a generic mqtt bridge I wrote in C# running on .net core on Linux.

I have a bridge translating messages into http calls for the Vera. If you want to avoid code, I think the Vera plugin for home assistant could help, but I never tried it.

I installed the app but it prompted “System error : Device: 276. Fail to load implementation file D_BinaryLight1.xml”. Please advise how to proceed.

Many thanks for developing the app, looking forward to use it on my system

If you are on open loop, you have to copy the xml files from a real Vera.

i am unfamiliar with open loop, but i installed it on a vera plus through the apps section on the vera webpage