VeraSecure Migration - Kwikset 914 not configuring

I recently migrated from a Vera 2 (UI5) to VeraSecure (UI7). All of the devices restored from the backup but a Kwikset 914 failed to configure. Re-pairing the device doesn’t work. I’ve also tried deleting the device, but it remains visible in UI7 with “Please wait! Getting secure classes” message.

I’ve also removed the batteries to see if the nightly heal process would fix the issue. It hasn’t.

I’ve also tried to re-add the device, but the controller doesn’t find a new lock to add.

In one thread that discusses migration the recommendation is to factory reset the controller and then add every device vs. using the backup to restore the zwave network. I don’t have a lot of devices on the network (~25) but would like to avoid this process if possible.

Any ideas?

After you unpair the lock, make sure you reboot Vera before including it. I have heard this cleans up remnant files.

Thanks Don. I decided to factory reset the new VeraSecure and re-add all the devices.