VeraPlus and Fibaro FGSD002 smoke detectors not working

VeraPlus and Fibaro FGSD002 smoke detectors not working

I have had a VeraPlus and three Fibaro FGSD002 smoke detectors working in my house for some time. When I first installed them I tested them by pressing and holding the test button, this triggered my “Fire Alarm” scene as expected.

I also routinely monitored the three room temperatures via the IomperiHome app and also used them to trigger emergency heating whilst away if the temperature fell below 10C.

I recently noticed that the reported temperature of one sensor was stuck (i.e. did not change). I also noticed that all three sensors reported very low battery levels even after a battery change.

When I pressed and held the test button each sensor it responded locally but did nottrigger an alarm on VeraPlus (nor did it trigger my “Fire Alarm” scene).

I have now removed and added back all three sensors. They were all recognised as

device_type: urn:schemas-micasaverde-com:device:SmokeSensor:1
manufacturer: Fibaro
model: FGSD002
device_file: D_SmokeSensor1.xml
device_json: D_SmokeSensorWithTamper1.json

All three sensors now report the temperature correctly and battery levels of 100%, they are all “armed” however pressing and holding the test button does not trigger an alarm nor trigger my “Fire Alarm” scene. Any help would be appreciated.

Having read several related threads it seems that some people suggest that the manual test button should not trigger an alarm. This has not been my experience and the manufacture’s manual says:

When the self-test is triggered manually the Fibaro Smoke Sensor
sends control command to the Z-Wave network controller. The
procedure will be performed at least as long as the B-button is not
released (will be completed in up to 10 seconds after releasing

I am running firmware version 1.7.4453

Huh, coincidence!

I just mailed a huge issue list to Vera and I added this one as well! BUt yesterday I had a “REAL” (probably dust gain?) fire alarm. The whole house woke up :frowning:

Fibaro smoke sensor #0-911 detected ( **false** , **but nevertheless** ) smoke yesterday evening! It did trigger Vera due to there is logging… I have “a scene ID53, which should trigger: BUT NOTHING HAPPENED!


I have two Fibaro smoke sensors in my home. I’ve disconnected both for a while until I figure I have to lower sensitivity. These sensors trigger without any smoke in the middle of the night, I guess because of dust in the atmosphere? This is NOT triggered by Vera. Vera does not have any capability of doing this.

The issue reported by @ZenSlo should be of a different nature, maybe range related and I strongly encourage him to check with our Customer Care team for diagnosis.

Sorin, never said Vera triggered. The smoke sensor did and vera saw it because it’s in the alert list. But scene was not kicked off!

Oh alright, great. My experience with these was not so great, but the Fibaro support helped sort it out.
Now, if it’s something that can be sorted on the Vera side, our guys would love to help as much as they can.

Just to clarify the “range” issue, I have checked that all three sensors are within range using the method detailed in the Fibaro instructions:

The Fibaro Smoke Sensor has a built in Z-Wave network main controller’s range
tester. Follow the below instructions to test the main controller’s range: …”

Two of mine are “green” (“Visual indicator glowing green - Fibaro Smoke Sensor communicates with the main controller directly.”) and one is (as expected) “yellow” ("Visual indicator glowing yellow - Fibaro Smoke Sensor communicates with the main controller through the other modules.)

All three detectors update their temperature without apparent problem.

It is not that my problem is intermittent, all three reliably don’t work even two metres from my VeraPlus.

My problem is now solved.

I raised a ticket with support who asked me to Exclude, Manually Reset and Include my smoke sensors again. This I did to no effect.

After logging into my system support mentioned that the firmware in my sensors seemed to have been updated to version 3.3 (I was not aware that this had (or indeed could) happen without my intervention.

It now seems that contrary to what it says in the instruction I received with the sensors and my past experience the test button no longer triggers my VeraPlus or runs my “Fire Alarm” scene.

However when I trigger a “real fire” (with a smoke spray) everything works as expected.

1 Like


I’m new in this community. I got Fibaro smoke FGSD002 and VERA PLUS. VeraPLUS recognized like a generic I/O the FGSD002. Paired and unpaired the sensor several times, always the same.

Some trick that I could apply.

After I found that my three original Fibaro FGSD002 sensors did work with “real” smoke I decided to buy an additional fourth Fibaro FGSD002 sensor. I expected this sensor to be included correctly as the first three (2017) sensors had been.

However, my fourth (2019) sensor was reliably included as a generic temperature sensor and a generic switch! Even though I had selected Fibaro FGSD002 at include time.

The only way I could get the new sensor to work was by updating:

device_type urn:schemas-micasaverde-com:device:SmokeSensor:1

device_file D_SmokeSensor1.xml

device_json D_SmokeSensorWithTamper1.json

The 2019 model might have a different z-wave product number which is not in Vera’s database.
Reporting this to our Customer Care team will have it added to our integration list.

Hi I got the same problem as described in this tread with 2019 model Fibaro FGSD-002.
After changing the advanced option parameters I still can’t see them in the configure preset modes. They can be armed as showed under devices but they to not appear on modes. Any idea why is that ?

Solved my own problem by changing to additional parameters in the advanced config. The category and sub-category from generic to smoke detector.

Categories are listed at the following link:

Hi all and @Sorin,
do you have any ideas if this issue was solved in the Vera plus latest firmware ? I myself is looking for adding such device to my Vera plus, but it is detected as a regular switch…
Thanks for the update !