Veramate and UI7 not working

Ever since I upgraded to ui7. Veramate will not work. I log in but it keeps saying refreshing. Anyone else having this issue?

I know of some users that have had a problem immediately after upgrading. I’m not sure if this is a problem with VeraMate, or a problem on the vera box. If this is happening, I would recommend using the “reset on next start” which should clear out any cache in VeraMate that might be impacting this (though, it shouldn’t as VeraMate should request all applicable configuration after you log in the next time).

I am having this issue also. I have two Vera’s (home and vacation property). I upgraded the one at home first and started using Veramate. This was working fine for both my wife and I (each have iPhones). A few weeks ago I upgraded the Vera Lite at the vacation property and since then Veramate has not worked for either unit on either iPhone. I tried resetting (many times) and this did not help.
Both are working fine and work with the Vera UI7 IOS app, but I prefer the Veramate and to get that working again.


I’m experiencing a similar issue with veramate and my veralite with ui7. I cannot login to veramate. The VeraLite is working fine itself and with other remote apps like homewave. Really interested in trying out VeraMate but can’t get past this problem. Sorry for the double post in the other thread. Saw this one and thought it was more applicable.


I’ve been able to get some diagnostic files which I can see VeraMate is getting invalid sessions id’s (which is part of the authentication process). I’m stumped as to why this has started occurring, although the last time this happened Micasaverde change the way the sessions worked. I’m not sure if this is the case…

I think I might need to look at some UI7 boxes where this is happening directly. Please PM if you (or anyone else) could give my account access to your Vera. Thanks

Mine randomly works. Sometimes it hangs at the “Loading or Updating” message comes across the top.

Sometime if I close out the app and reopen it, it will work.

If you want to see my setup, PM me.