Veralite "forgets" devices every 30-40 days

Has anyone else had an issue with their Veralite forgetting devices? it seems every 30-40 days my door sensor and dimmer switch get knocked off my devices list. It doesn’t forget my 2 other dimmers or my 2 outlets, just these 2 and on a fairly regular basis. If I take the vera over to the 2 missing devices and remove them and add them again everything works for about 30-40 days then happens again… I live in a 1 bedroom apartment and not one of the zwave devices are more than 10 ft from the next, so I can’t see distance being an issue… any ideas??

I had this problem with my Vera3.

Firstly you should raise a support request to ensure it gets investigate thoroughly.

I would be curious if there is a space issue on your Vera which resulted in a corrupted user data and subsequent roll back to an older one.

Thanks I’m just back from vacation so I throw it out to Vera support and see what they think. I’ve also noticed that sometimes my devices take, and exactly to the count, 30 seconds to activate after a command is send. doesn’t happen every time, but more often than to be thrown out as a glitch…

just had a similar issue on my veralite.
A sensor which has been happily working for several years decided to forget its device ID a few days ago.
the problem is not reassigning it back to the network, which then appears as a new device, although that does mean having to update all automation that uses the device which is a pain in the a$$. ::slight_smile:
The big problem is going through all my coding that references this device ID and updating all that code to the new device ID.

This is not an easy task and it would be good to either manually assign a device it ID number (which i understand is not possible as vera does this itself) or to use some kind of alias whereby the device ID can be updated quickly in one place. Though this fault should never arise so may be pointless to write this code as insurance against something that should never happen in the first place.

anyone care to share tips or advice on this issue?

does edge and plus also share this problem?

fantastic! another device has just forgotten its node number.
conveniently, this is the horseman ASR2-ZW device that has 3 device ids, so to reassign back to the network will be triple the fun.
whoopeee i cant wait to spend hours re-coding unnecessarily

looking for reliability in a system, any one help…?

rant over…

seriously though, what could possibly cause these issues?

follow up to the last message, it appears (fingers crossed) that a restore of a recent backup has got things back to how they were, so it appears to me that it is vera who is “forgetting” the device IDs, not the devices themselves.

Is there any way to tap into vera’s internal tables to check/alter these values?

If you are talking about your LUA coding, you could use global variables for your device ID:

gKitchenLight = 123

Place the above (variable initialization) statement in your LUA start up code section. You can then use the variable gKitchenLight instead of the number 123 in your subsequent LUA coding. And now, you only have to change the one statement should your device ID change.

Using the device name above also makes the code easier to read.

It just happened to one of my four Dragon Tech WS-100 switches on Vera Plus. The other three are fine.

In an attempt to “catch” vera when it loses devices from the system, i run this bit of code to get a log of a “good” working config:

local DataToSend = "retrieve all divice iDs<br>"
local Count = 1

for deviceNo,d in pairs(luup.devices) do
	if ~= "" then
		DataToSend = DataToSend..Count..")"..(string.format('[%03d / %s] %s \n', deviceNo,, d.description)).."<br>"

-- Now do something with DataToSend which contains the info we need...

I retrieved the “working” info the other day and, soon after, one of my devices vanished from the network again. I run this code again and it gave exactly the same information as before the fault. This makes me think it is something deeper than this “look up” table.
A backup got things back to normal, so its within Vera and not a fault on the device it appears.

Anyone able to comment?