VeraLite 1.5.622 to VeraPlus, do I have to upgrade the VeraLite to UI7

I just bought a VeraPlus and want to upgrade to it from a VeraLite running 1.5.622 , do I have to upgrade the VeraLite to UI7?


Should not be needed. See Vera’s FAQ [url=][/url]

Cheers Rene

perfect, that’s what I’ve been searching for, for days now.

mostly went well.
all the AEON Door/Window sensor say “Waiting for wakeup to configure device”
1 light switch says “Can’t Detect Device”

so how do i fix the failed devices? search is not particularly helpful

For the waiting to configure you should go to the device Advanced settings and open the Commands tab. Hit the Configure node right now and wake up the device per the instructions in its manual. That should do the trick. If not exclude and include again is the only thing I can think of.

The can’t detect device probably needs to be excluded or have a factory reset and be included again.

Cheers Rene

A lot has changed from UI5 to Ui7 in therms of z-wave meshing. On UI5 z-wave routing was done at software level by Vera, in UI7, routing is done by the z-wave chip itself. So there is a chance some devices will not work correctly or not work at all after migration.

If Rene’s indication does not work in your scenario, then those devices will have to be completely excluded and re-included.

I had to remove and re-add two light switches.
the aeon door sensors are working but I think they all have a battery problem. one doesn’t seem to be working at all. I have a pack of batteries riving tomorrow. we’ll see

the aeon 4 in 1 that I added new showed up as a dimmer switch. it took many many tries to remove it. will re-add later.

My garage door Aeon sensor was going into “can’t detect device” mode a lot even though it worked fine. Front door sensor is still doing that. Today, I changed the garage sensor battery, and once I reconnected it to Vera, the error went away. I read in another thread to remove the battery to help z-wave reconnect with Vera. I can say it worked well for me.

looks like new batteries resolved the issue with the door sensors… so far…

I think you will suffer many strange problems doing the upgrade path.
My kind of worked … but lots of strange problems kept popping up …

Many folks, my self included, did not get to normal behavior until we totally rebuild our system from a factory and z-wave reset.

spoke too soon, all the sensors are back to “Can’t Detect Device”. they all work but have this message.
including the new one I added this morning to replace a bad one.

If they are battery devices, especially Aeon door sensors, I get that error a lot. But the sensors are probably still working, as least in my case.

Guys, when doing a transfer, Vera’s node id changes from 1, to something else. Since battery operated devices are in sleep mode, they will not be able to pick up Vera’s new node ID. Some z-wave device do not even have the ability to transmit to a master controller that has node id different than 1. Hence the issues with battery operated devices after transfer.

In my case, it was not a transfer. Brand new Vera 3 4 years ago, added devices over time. First time I added battery door sensors was last August and I have the “can’t detect device” error all the time although the device work as intended.

the issue happens with the new aeon sensor also. setup only on this veraplus

all the aeon sensors show as failed “Can’t Detect Device” but are working just fine.
if i pull the battery and put it back in the error clears for an hour or two then goes back to “Can’t Detect Device”
is there a setting that needs to be changed?

Did you start from scratch ? If you migrated you will continue to suffer problems like this.

how do you start from scratch? if you mean reset it and re-add everything? no i haven’t. it’s ridiculous that you’d have to do that.

That’s what I meant … but I (an many others) had to do so to get rid of all of the little re-occurring problems.

The upgrade gets you 95% of the way there … but no way to get the UI5 100% reliability.