Vera3 dead - other procedure to reinstall the firmaware

My Vera3 is dead. I have Power red, WAN green, Wifi red, Service green and LAN green. All other lights are off. Reset button don’t work. What could happened to my Vera3?

I have tried to follow the procedure described here:
but it doesn’t work. The Upgrade software doesn’t find my Vera3 unit.

Are there other options to reinstall the firmware and recover the unit? Any help is appreciated.

The best thing to do is have Customer Care try to resolve this for you. Please email and feel free to CC me. If you can access the UI via the local IP address please enable remote access by going to Settings–>Customer Care and include the code it generates in your email.

This worked for me … Vera support sent it to me …

Me as well. Just did it.

I’ve tryed that but after telnet IP system show “port 23 cannot be accessed”

Any suggestions?

After a lot of poblems I could finally initialice my Vera3 and get ir recovered before the firmware ugrade.

My question now is if that firmware is correct and I had badluck during update? Or newest firmware realice has a problem?

A soon as I could enter to dashboard, system redirect me to update firmware page, again… of course I didnt update it.