Vera use with Leviton Vizia RF devices

I have about 45 Leviton Vizia RF nodes in my house as well as a vera box. I setup the network (that includes Leviton dimmers/switches/keypads and non-Leviton HSM-100/Wayne Dalton thermostat) using a Leviton handheld controller. So the vera was setup as a secondary on the network and initially all worked just fine but it appears that as the Vera polls the devices it’s changing the associations on the Leviton Keypads. So the initial areas that I was controlling from the keypads is being erased by vera. If I go back to the keypad and reset/reprogram them using the handheld all goes back to normal but after a while it happens again. Does the polling and device setup that the vera box goes through alter the keypad associations even if it’s not the primary on the network? I did not check the box that said treat scene controller buttons as events since I thought that might cause an issue with the devices that I had already setup.



I gave up trying to use leviton multi-button controllers with vera. I set them up with the leviton controller and they just work. vera tech support has been zero help with this.

He said he uses the handheld to program and re-program the multi button switches.

I have had similar issue.
DO you and updates to the remote from vera?

I haven’t seen keypads losing configuration, but I only have one 4-zone and one 1-zone. What I’ve seen repeatedly, is Leviton switches stop responding to polls after couple month of polling by Vera. Those switches can still be controlled locally and remotely (i.e. ON/OFF), but cannot be polled by either Vera or Leviton master controller. I “cure” this problem by resetting the switches (air gap). I do have Vera secondary and I disable “Automatically configure” option for the switches.

My 4 button Leviton scene controller I just realized is not able to be polled by Vera.

Is this normal?

I use method 1 to configure the controller just fine and get a green cog when I send scenes over to it via the configure now button. The 4 button controller also works without any problems.

But, I just realized that I can’t poll it (get a pencil and red pad)
I just set the poll frequency to zero since Vera doesn’t need to know it’s state.

But, I wonder if this is what’s causing my Vera to lock up every 3-5 days with a log full of polling errors.

Also, Does anyone know if the Vera has to be within direct range of the 4 button scene controller to configure it? Or Can it configure it through the mesh.

I think controllers cannot be polled. At least I’ve never seen any of my controllers ever being polled successfully.

As of lock ups - I’m on the original (i.e. old) stable dongle and my Vera runs for weeks or months, until I upgrade the firmware and have to reboot it.

I wouldn’t expect them to be, especially if they are battery powered, but the default has it being polled every x (I forget how many) seconds. I set it to zero.

I’ll see if my Vera locks up by the end of the week.

Locked up Yesterday, Oh Well, I will patiently wait for a fix.

What’s annoying with the new lock up is that I have to reseat the dongle as well, before at least I could just reboot

I just tried to install a second Leviton VRCS4-MR in-wall scene controller, but when I do, this one doesn’t show the option to “Treat scene buttons as events see: method #2” like the other one does. I can add a scene to button 1 and it seems to function correctly, but adding a scene to button 2 doesn’t work. I don’t know if it makes any difference, but I installed the first controller when I was at 944, and now I’m at 958. Any advice?

I have set up that same 4-scene controller in two separate systems. One uses Vera along with a Nevo S70 and other without Nevo and a Leviton Think Essential USB stick. What I have found out is that as you add your devices you must use the Optimize functionality of the Z-wave controller to build and maintain the Z-wave mesh otherwise the routing table that is stored within each device somehow gets corrupt. I’ve also notice that the Lev 4-scene controller behaves erratic at times and so being patient with it is the best policy. I’d start with the primary controller, then the secondary controller and so on and then add the devices and then set up areas and scenes. Although with Nevo the approach is totally different. Also Vera cannot pull from controllers since they are not nodes but rather a control device which fall under a completely different classification of products under the Z-wave network. Hope that helps.


Best I can tell, there are a bunch of “obsolete” attributes hanging around against certain objects (like Scene Controllers) since they made this round of changes:

My newer Scene Controller install (against 1.0.944) is also missing this attribute, and the older Scene controller has it. Both are working perfectly fine though, so these extra/obsolete attributes seem benign at this time.

I added scenes to all 4x Buttons on the older controller and on 2x Buttons on the new one (all added in 1.0.944) and they all work… after I was defined, and attached, the scenes I would do the following operation against the Scene Controller Device:

[i]Devices[/i] --> [i]Z-Wave[/i] --> [i]YourSceneControler[/i] --> (+) -> [i](Configure node right now)[/i]

To “force” them to be updated. Not sure if it was necessary or not, but figured they likely needed an update since “part” of the Scene association really needed to be stored in the Z-Wave Scene Controller so it could work autonomously.

and yes, they are a little fussy as a Scene Controller :wink:

guessed, you’re right. The new scene controller is working. I’ve assigned scenes to two of the four buttons and both work. Thanks.