Vera showing up as rougue DHCP server

Good morning,
I was just checking my network secure gateway, and it’s throwing an alert that shows a rogue DHCP server coming from Vera’s IP address. I have a Vera Plus with the latest firmware (1.7.3232). I searched for Vera and DHCP, and the posts I saw were from 2015 or earlier. They said to go into Net & WiFi, and there would be a DHCP check box. I don’t see this in the current version. Has it moved somewhere? How do I turn off the DHCP server on Vera?

I’m a couple of versions behind on FirmWare, but it is one from this year. Mine is there.

You need to click “Manually Configure”

1 Like

Yeah, that was it. Figured it out. Thanks!

Thanks for this post. I had been beating my head against a wall trying to figure out why some devices on my home network would be grabbing 192.168.81.* addresses until I found this post and went and checked for rogue DHCP servers (with Microsoft’s Rogue DHCP Check utility at Download Microsoft Rogue DHCP Server detection - MajorGeeks).

Sure enough, my VeraLite was cheerfully handing out bogus DHCP addresses in that range, which at various times would make most devices on my home network flake out sometimes or all the time. What agitated me the most was that my Nest Protect smoke/carbon monoxide detectors would ALWAYS apparently grab the bogus IP address and therefore never work (and when factory reset would throw a P007 error when attempting to join WiFi).

Firmware upgrade to 1.7.1040 solved the problem for me.

It may never in a million years have dawned on me to: a) look for a rogue DHCP server, or b) to imagine that my VeraLite was the culprit! Awful. :frowning:

Anyway, thanks for the breadcrumbs to the resolution.

Started getting the rouge DHCP event sometime last year in my Unifi Controller, pointing the finger at the Vera. It started appearing regularly after applying a firmware update on the Vera, with the DHCP turned off. Another (or maybe two) firmware update and it stopped.

I’m on 1.7.4001, with the DHCP disabled in Vera’s web UI, but:
a) it’s still being detected as rogue DHCP server by Ubiquiti switches
b) the config when ssh’d to the Vera seems to suggest that it is still enabled

This is not cool.

If you haven’t rebooted the Vera, I’d suggest doing so—then check if the DHCP server is now disabled.

It is not. In fact, I dug deeper and amended some of the files that enable DHCP on the Vera. Got it to STFU about DHCP, then after a reboot, it’s now thinking it’s all that again.

This thing is close to heading out the window. I didn’t buy a router, I bought a fricken z-wave controller. It’s no wonder I’ve had intermittent network issues the past couple years with a rogue DHCP server online… at least now I have networking gear that won’t let it interfere.

1 Like

Hi i am getting the same issue and no solution anywhere. VeraLite (unit i have) does not have DHCP (off feature) and gateway from veralite is assigning IPs to all network device which is causing them to not have internet. Contacted Vera a week ago. Any help here from community would be a life saver. About to switch fully to samsung things… cant take it anymore

I solved this issue by switching to Hubitat. Haven’t looked back.

1 Like

Thanks Doctorkb, really hoping Vera support or anyone else will come through as i dont want to deal with re-adding all device and configuring scenes all over :frowning:

That seems to have become an oxymoron.

For what it’s worth, the transition isn’t too bad… and the rewards are many. Given that Vera has seen two VERY minor updates in the past year and this hasn’t been even identified as a known issue, I sincerely doubt it’ll ever get fixed.

Sorry to sound pessimistic…

The Vera Lite is seen as end of life by Vera and will not receive any firmware updates anymore. If the DHCP issue gives problems you can either change controller, or put the Vera on its own subnet behind a second router in your network. I had to do this for several years as either the Veras or some other device would go berserk when on the same subnet. The latest Edge/Plus releases do not seem to have this problem anymore. But as said. Those will not be available for the Lite and 3.

Cheers Rene

1 Like

Thanks Reneboer, that is really disappointing, so are you saying i need to get a new router to do this ? Seems pretty much overkill vs new controller outright l.
I can’t believe there is no ssh command to perm kill it or put it on a different subnet that way

Crossing Fingers : anyone in the forum have any ideas on commands to kill DHCP - T-3days before i toss it…

Try this… ssh into your Lite, and run the following commands:

uci delete dhcp.lan.start
uci delete dhcp.lan.limit
uci delete dhcp.lan.leasetime
uci set dhcp.lan.dynamicdhcp=0
uci commit dhcp
/etc/init.d/dnsmasq restart

See if that makes it go away.

thanks rigpapa. Seems Vera team also helped w/ this.

  • uci set dhcp.lan.ignore=1

  • uci set dhcp.wan.ignore=1

  • uci set dhcp.lan.force=0

  • uci set dhcp.wan.force=0

  • uci commit dhcp

  • /etc/init.d/dnsmasq restart

  • reboot

Well, what a coincidence! :smiley:

1 Like

For the record, I was having the issue with the Vera Plus, which is essentially the same as the Vera Secure (minus the siren).

This is rewarding bad behaviour. The best solution to a misbehaving network device is to toss it in the garbage. Vera is not special enough to warrant the network gymnastics you’re proposing – just switch to a device that doesn’t seek to scramble your network.