Vera Plus works hard without an internet connection

I bought a Vera Plus reading that it works without an internet connection. It works but not properly. If I turn on a light bulb it lights up after 1 minute. The sensor in the bathroom that at the entrance to the bathroom must instantly turn on the light in the bathroom, turns on the light after leaving the bathroom. All devices are z wave. Very dissatisfied. Do certain settings need to be made?

yes, there is a thread on de-clouding your vera. There are apparently some call-home functions that eventually fill logs/buffers and make it perform badly.

Unfortunately, the expert on that made too many disparaging remarks and has been banned for 99 years.

1 Like

Why did you create a new account to post the same question again though?

How do I delete an account?
Login problems …
I’m desperate, I’ve finished the holiday home and I can’t use Vera, lost money.
It is not fair to say that it works without the internet and does not work.

I recommend you to open a support ticket for your issues.
Do you have any plug-in installed? some plug-ins make the whole system behave odd without internet.



Well there’s your problem. I’ve seen for example a simple “and” pleg scene not run because no internet. I guess the “works without internet” statement is with a stock Vera without plugins. To explain, if a plug-in gets weather data from a site as trigger or turning on a cloud connected device the statement obviously fails.

1 Like

To my experience all Vera units need Internet connection even of you have not added them to account.

Without Internet connection Vera is too slow and sometimes does not work

I deleted all the plugins and it works very well. It remains to be seen in the coming days.

Time is the biggest problem, if you reboot Vera with no Internet connect it loses its correct date and time and then your scheduled scenes don’t run at the correct times.

Yes. What can be done?

A local NTP time server but I could never get it working. I had no Internet in the house for 2 weeks one time and I enabled the local NTP server on my Asus router.

I contacted Vera support and was given these instructions but it didn’t work for me.

Please try this: click on the tab: Apps> Develop apps> and on the option: Test Luup code (Lua) please paste the following codes one by one and click on: Go, once You have a positive confirmation message, continue with the next line, once You finish all the lines, the controller will reboot, please wait till You have all the lights on solid on the controller and do the log in one more time.

os.execute("opkg update")
os.execute("opkg install ntpclient")
os.execute("for i in 0 1 2 3; do ntpclient -c 1 -p 123 -h $; done")

I tried changing this line to point to my router instead

os.execute("for i in 0 1 2 3; do ntpclient -c 1 -p 123 -h $i.; done")

This should fix the unit time issue, please, try it and tell me how it went.

Then they suggested this.

If the previous code did not work, try this one:

os.execute("opkg update")
os.execute("opkg install ntpclient")
os.execute("for i in 0 1 2 3; do ntpclient -c 1 -p 1230 -h $[](; done")
os.execute("/etc/init.d/ntpclient restart") 

There are other threads on the forum about setting up a local NTP server, have a search for them.

What they gave you is utter nonsense. The correct command(s) to do this are given in the Reactor documentation on the page where I discuss clock issues: Clock Validity - Reactor


Good to know I will take a look.

I have read the doc you referenced and have my NAS ntp server enabled. I am unclear how to execute the script you gave. I created a manual scene with the code in it, but the run failed. I am on a vera edge, latest firmware. I would appreciate any direction.

You just log in to your Vera via SSH and issue those two commands, and then issue a reboot.